Somme.si ou Somme(si

Le
Olivier Courty
Bonjour à tous

J'ai dans un classeur, une petit tableau tout simple, mais je butte sur une
chose bête.

L'architecture de la feuille n'est pas modifiable car les données sont deja
des liaisons d'autres feuilles.


Le tableau
A B C D E F G H
1 F 100 D 200 F 25 D 50
2 F 50 D 75 F 12 D 20

Voila le tableau

Je voudrais faire la somme des F et la somme des D

et bien sur, je bloque

D'avance merci pour votre aide

Olivier
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Ellimac
Le #4608961
Bonjour,

Il faut faire l'addition de plusieurs Somme.Si :
=SOMME.SI($A$2:$A$5;J2;$B$2:$B$5)+SOMME.SI($C$2:$C$5;J2;$D$2:$D$5)+SOMME.SI($E$2:$E$5;J2;$F$2:$F$5)+SOMME.SI($G$2:$G$5;J2;$H$2:$H$5)

Camille

"Olivier Courty" wrote:

Bonjour à tous

J'ai dans un classeur, une petit tableau tout simple, mais je butte sur une
chose bête.

L'architecture de la feuille n'est pas modifiable car les données sont deja
des liaisons d'autres feuilles.


Le tableau
A B C D E F G H
1 F 100 D 200 F 25 D 50
2 F 50 D 75 F 12 D 20

Voila le tableau

Je voudrais faire la somme des F et la somme des D

et bien sur, je bloque

D'avance merci pour votre aide

Olivier





AV
Le #4608861
Le tableau
A B C D E F G H
1 F 100 D 200 F 25 D 50
2 F 50 D 75 F 12 D 20
Je voudrais faire la somme des F et la somme des D


Avec ton tableau nommé "tablo"
Matricielles à valider par ctrl+maj+entrée

Pour sommer les "correspondances "F""
=SOMME(SI(tablo="F";DECALER(tablo;;1)))
Pour sommer les "correspondances "D""
=SOMME(SI(tablo="D";DECALER(tablo;;1)))
Pour sommer "F" + "D"
=SOMME(SI((tablo="F")+(tablo="D");DECALER(tablo;;1)))

AV

Olivier Courty
Le #4608761
Excellent Alain,

C'est exactement ce que je voulais.

pour dire vrai, j'ai essayé avec décaler, mais avec Somme.si et cela ne
fonctionne pas.

Merci beaucoup pour ton aide précieuse..

Olivier


"AV" %
Le tableau
A B C D E F G H
1 F 100 D 200 F 25 D 50
2 F 50 D 75 F 12 D 20
Je voudrais faire la somme des F et la somme des D


Avec ton tableau nommé "tablo"
Matricielles à valider par ctrl+maj+entrée

Pour sommer les "correspondances "F""
=SOMME(SI(tablo="F";DECALER(tablo;;1)))
Pour sommer les "correspondances "D""
=SOMME(SI(tablo="D";DECALER(tablo;;1)))
Pour sommer "F" + "D"
=SOMME(SI((tablo="F")+(tablo="D");DECALER(tablo;;1)))

AV





Publicité
Poster une réponse
Anonyme