somme.si ou sommeprod?

Le
jpierrethillard
Bonjour,

J'ai une plage avec dates A2:B32 avec le format suivant lun-01-
janv-08.. jeu-31-janv-08
Dans une autre plage avec des heures I2:I32

Je voudrais faire la somme des heures des dimanches "dim" en G35.
Comment puis-je faire?

Merci pour les conseils

JP
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Boisgontier
Le #5284221
Bonjour,

=SOMMEPROD((JOURSEM(dates)=1)*heures)

JB



Bonjour,

J'ai une plage avec dates A2:B32 avec le format suivant lun-01-
janv-08..... jeu-31-janv-08
Dans une autre plage avec des heures I2:I32

Je voudrais faire la somme des heures des dimanches "dim" en G35.
Comment puis-je faire?

Merci pour les conseils

JP


JB
Le #5284211
On 2 fév, 14:08, wrote:
Bonjour,

J'ai une plage avec dates A2:B32 avec le format suivant lun-01-
janv-08..... jeu-31-janv-08
Dans une autre plage avec des heures I2:I32

Je voudrais faire la somme des heures des dimanches "dim" en G35.
Comment puis-je faire?

Merci pour les conseils

JP


JB
Le #5284201
=SOMMEPROD((JOURSEM(dates)=1)*heures)

JB

On 2 fév, 14:21, JB
On 2 fév, 14:08, wrote:



Bonjour,

J'ai une plage avec dates A2:B32 avec le format suivant lun-01-
janv-08..... jeu-31-janv-08
Dans une autre plage avec des heures I2:I32

Je voudrais faire la somme des heures des dimanches "dim" en G35.
Comment puis-je faire?

Merci pour les conseils

JP- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



jpierrethillard
Le #5284191
Bonjour JB

Non ça ne marche pas. J'ai tapé en G5:
=SOMMEPROD((A2:A32(dates)=1)*(H2:H32))
Ai-je commis une erreur?

JP
On 2 fév, 14:24, JB
=SOMMEPROD((JOURSEM(dates)=1)*heures)

JB

On 2 fév, 14:21, JB


On 2 fév, 14:08, wrote:

Bonjour,

J'ai une plage avec dates A2:B32 avec le format suivant lun-01-
janv-08..... jeu-31-janv-08
Dans une autre plage avec des heures I2:I32

Je voudrais faire la somme des heures des dimanches "dim" en G35.
Comment puis-je faire?

Merci pour les conseils

JP- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -




Boisgontier
Le #5284131
http://cjoint.com/?ccp5aj3UrD

JB


Bonjour JB

Non ça ne marche pas. J'ai tapé en G5:
=SOMMEPROD((A2:A32(dates)=1)*(H2:H32))
Ai-je commis une erreur?

JP
On 2 fév, 14:24, JB
=SOMMEPROD((JOURSEM(dates)=1)*heures)

JB

On 2 fév, 14:21, JB


On 2 fév, 14:08, wrote:

Bonjour,

J'ai une plage avec dates A2:B32 avec le format suivant lun-01-
janv-08..... jeu-31-janv-08
Dans une autre plage avec des heures I2:I32

Je voudrais faire la somme des heures des dimanches "dim" en G35.
Comment puis-je faire?

Merci pour les conseils

JP- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -- Masquer le texte des
messages précédents -


- Afficher le texte des messages précédents -




jpierrethillard
Le #5284081
JB

A ne rien y comprendre. Je fais la même chose (me semble t-il) dans
mon fichier mais rien à faire.
Le voici. Regarde en feuille 1 et 2 par exemple.

http://cjoint.com/?ccqtYaA578
Merci JP
On 2 fév, 15:59, "Boisgontier" wrote:
http://cjoint.com/?ccp5aj3UrD

JB


Bonjour JB

Non ça ne marche pas. J'ai tapé en G5:
=SOMMEPROD((A2:A32(dates)=1)*(H2:H32))
Ai-je commis une erreur?

JP
On 2 fév, 14:24, JB


=SOMMEPROD((JOURSEM(dates)=1)*heures)

JB

On 2 fév, 14:21, JB
On 2 fév, 14:08, wrote:

Bonjour,

J'ai une plage avec dates A2:B32 avec le format suivant lun-01-
janv-08..... jeu-31-janv-08
Dans une autre plage avec des heures I2:I32

Je voudrais faire la somme des heures des dimanches "dim" en G35.
Comment puis-je faire?

Merci pour les conseils

JP- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -- Masquer le texte de s
messages précédents -


- Afficher le texte des messages précédents -- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -





berapard
Le #5284061
La formule de type

=SOMMEPROD(I2:I32*(JOURSEM(A2:I32;1)=1))

fonctionne parfaitement

Philippe
JB
Le #5284051
Il y a des formules dans le champ des heures qui renvoient des
chaines:

=SOMME((JOURSEM(Dates)=1)*SI(ESTTEXTE(Heures);FAUX;Heures))
valider avec maj+ctrl+Entrée

http://cjoint.com/?ccqLi67xVx

JB

On 2 fév, 16:20, wrote:
JB

A ne rien y comprendre. Je fais la même chose (me semble t-il) dans
mon fichier mais rien à faire.
Le voici. Regarde en feuille 1 et 2 par exemple.

http://cjoint.com/?ccqtYaA578
Merci JP
On 2 fév, 15:59, "Boisgontier" wrote:



http://cjoint.com/?ccp5aj3UrD

JB


Bonjour JB

Non ça ne marche pas. J'ai tapé en G5:
=SOMMEPROD((A2:A32(dates)=1)*(H2:H32))
Ai-je commis une erreur?

JP
On 2 fév, 14:24, JB
=SOMMEPROD((JOURSEM(dates)=1)*heures)

JB

On 2 fév, 14:21, JB
On 2 fév, 14:08, wrote:

Bonjour,

J'ai une plage avec dates A2:B32 avec le format suivant lun-01-
janv-08..... jeu-31-janv-08
Dans une autre plage avec des heures I2:I32

Je voudrais faire la somme des heures des dimanches "dim" en G35.
Comment puis-je faire?

Merci pour les conseils

JP- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -- Masquer le texte des
messages précédents -


- Afficher le texte des messages précédents -- Masquer le texte de s messages précédents -


- Afficher le texte des messages précédents -- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -






jpierrethillard
Le #5283891
JB
Merci, le problème c'est que je n'ai pas tout compris. Je le regrette
mais bon je vais tenter d'approfondir (le champs des heures renvoie
des chaînes)

Merci encore
JP

2 fév, 16:38, JB
Il y a des formules dans le champ des heures qui renvoient des
chaines:

=SOMME((JOURSEM(Dates)=1)*SI(ESTTEXTE(Heures);FAUX;Heures))
valider avec maj+ctrl+Entrée

http://cjoint.com/?ccqLi67xVx

JB

On 2 fév, 16:20, wrote:



JB

A ne rien y comprendre. Je fais la même chose (me semble t-il) dans
mon fichier mais rien à faire.
Le voici. Regarde en feuille 1 et 2 par exemple.

http://cjoint.com/?ccqtYaA578
Merci JP
On 2 fév, 15:59, "Boisgontier" wrote:

http://cjoint.com/?ccp5aj3UrD

JB


Bonjour JB

Non ça ne marche pas. J'ai tapé en G5:
=SOMMEPROD((A2:A32(dates)=1)*(H2:H32))
Ai-je commis une erreur?

JP
On 2 fév, 14:24, JB
=SOMMEPROD((JOURSEM(dates)=1)*heures)

JB

On 2 fév, 14:21, JB
On 2 fév, 14:08, wrote:

Bonjour,

J'ai une plage avec dates A2:B32 avec le format suivant lun-01-
janv-08..... jeu-31-janv-08
Dans une autre plage avec des heures I2:I32

Je voudrais faire la somme des heures des dimanches "dim" en G35 .
Comment puis-je faire?

Merci pour les conseils

JP- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -- Masquer le text e des
messages précédents -


- Afficher le texte des messages précédents -- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -- Masquer le texte de s messages précédents -


- Afficher le texte des messages précédents -- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -







JB
Le #5283861
En H8:
=SI(SOMME(F3:G3)=0;"";SOMME(F3:G3))

peut être rempacé par:
=SI(SOMME(F3:G3)=0;0;SOMME(F3:G3))

+ Outis/Options/Affichage/Valeurs zéros

JB



On 2 fév, 20:40, wrote:
JB
Merci, le problème c'est que je n'ai pas tout compris. Je le regrette
mais bon je vais tenter d'approfondir (le champs des heures renvoie
des chaînes)

Merci encore
JP

2 fév, 16:38, JB


Il y a des formules dans le champ des heures qui renvoient des
chaines:

=SOMME((JOURSEM(Dates)=1)*SI(ESTTEXTE(Heures);FAUX;Heures))
valider avec maj+ctrl+Entrée

http://cjoint.com/?ccqLi67xVx

JB

On 2 fév, 16:20, wrote:

JB

A ne rien y comprendre. Je fais la même chose (me semble t-il) dans
mon fichier mais rien à faire.
Le voici. Regarde en feuille 1 et 2 par exemple.

http://cjoint.com/?ccqtYaA578
Merci JP
On 2 fév, 15:59, "Boisgontier" wrote:

http://cjoint.com/?ccp5aj3UrD

JB


Bonjour JB

Non ça ne marche pas. J'ai tapé en G5:
=SOMMEPROD((A2:A32(dates)=1)*(H2:H32))
Ai-je commis une erreur?

JP
On 2 fév, 14:24, JB
=SOMMEPROD((JOURSEM(dates)=1)*heures)

JB

On 2 fév, 14:21, JB
On 2 fév, 14:08, wrote:

Bonjour,

J'ai une plage avec dates A2:B32 avec le format suivant lun-01 -
janv-08..... jeu-31-janv-08
Dans une autre plage avec des heures I2:I32

Je voudrais faire la somme des heures des dimanches "dim" en G 35.
Comment puis-je faire?

Merci pour les conseils

JP- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -- Masquer le te xte des
messages précédents -


- Afficher le texte des messages précédents -- Masquer le text e des messages précédents -


- Afficher le texte des messages précédents -- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -- Masquer le texte de s messages précédents -


- Afficher le texte des messages précédents -- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -








Publicité
Poster une réponse
Anonyme