Somme des valeurs sur une période d'un mois

Le
Tristan
Bonjours amis experts,

Dans ma colonne A je rentre des dates exprimées en JJ/MM/AA. A chaque date
correspond une valeur dans la colonne B.
Dans un autre tableau, j'aimerais extraire la somme des valeurs pour chaque
mois de l'année.

Je nage.
Merci beaucoup pour votre aide.

Très courtoisement,
Tristan
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Tatanka
Le #6537261
Salut Tristan,

Une façon de faire :
Je suppose que :
1) La plage contenant tes dates se nomme « Dates ».
2) La plage contenant tes valeurs se nomme « Montant ».
3) Que tu entres les nombres de 1 à 12 dans la plage D2:D13.
Alors tu pourrais entrer cette formule :
=SOMMEPROD((MOIS(Dates)Ò)*(ANNEE(Dates) 08)*Montant)
en E2 et la tirer vers le bas.

Serge

"Tristan"
Bonjours amis experts,

Dans ma colonne A je rentre des dates exprimées en JJ/MM/AA. A chaque date
correspond une valeur dans la colonne B.
Dans un autre tableau, j'aimerais extraire la somme des valeurs pour chaque
mois de l'année.

Je nage.
Merci beaucoup pour votre aide.

Très courtoisement,
Tristan


Sam
Le #6537251
Bonjour,
en colonne A : les dates, en colonne B : un montant, en colonne C : 12 dates
par exemple le dernier jour de chaque mois, en colonne D la formule à mettre
en D1 et à tirer jusqu'à D12
=SOMMEPROD((MOIS($A$1:$A$5)=MOIS(C1))*$B$1:$B$5)

Cordialement
Michel

"Tristan" news:
Bonjours amis experts,

Dans ma colonne A je rentre des dates exprimées en JJ/MM/AA. A chaque date
correspond une valeur dans la colonne B.
Dans un autre tableau, j'aimerais extraire la somme des valeurs pour
chaque
mois de l'année.

Je nage.
Merci beaucoup pour votre aide.

Très courtoisement,
Tristan


Tristan
Le #6537681
Merci beaucoup messieurs !




Bonjour,
en colonne A : les dates, en colonne B : un montant, en colonne C : 12 dates
par exemple le dernier jour de chaque mois, en colonne D la formule à mettre
en D1 et à tirer jusqu'à D12
=SOMMEPROD((MOIS($A$1:$A$5)=MOIS(C1))*$B$1:$B$5)

Cordialement
Michel

"Tristan" news:
Bonjours amis experts,

Dans ma colonne A je rentre des dates exprimées en JJ/MM/AA. A chaque date
correspond une valeur dans la colonne B.
Dans un autre tableau, j'aimerais extraire la somme des valeurs pour
chaque
mois de l'année.

Je nage.
Merci beaucoup pour votre aide.

Très courtoisement,
Tristan







Tristan
Le #6537641
Messieurs,
J'ai donc testé les 2 méthodes. Rien n'y fait ! J'obtiens des 0 à mes
résultats...

Une autre piste peut être ?

Merci encore



Bonjour,
en colonne A : les dates, en colonne B : un montant, en colonne C : 12 dates
par exemple le dernier jour de chaque mois, en colonne D la formule à mettre
en D1 et à tirer jusqu'à D12
=SOMMEPROD((MOIS($A$1:$A$5)=MOIS(C1))*$B$1:$B$5)

Cordialement
Michel

"Tristan" news:
Bonjours amis experts,

Dans ma colonne A je rentre des dates exprimées en JJ/MM/AA. A chaque date
correspond une valeur dans la colonne B.
Dans un autre tableau, j'aimerais extraire la somme des valeurs pour
chaque
mois de l'année.

Je nage.
Merci beaucoup pour votre aide.

Très courtoisement,
Tristan







Tatanka
Le #6537621
BIZZ !

Tu pourrais peut-être envoyer un échantillon
de tes données sur Cjoint.com

Serge


"Tristan"
Messieurs,
J'ai donc testé les 2 méthodes. Rien n'y fait ! J'obtiens des 0 à mes
résultats...

Une autre piste peut être ?

Merci encore



Bonjour,
en colonne A : les dates, en colonne B : un montant, en colonne C : 12 dates
par exemple le dernier jour de chaque mois, en colonne D la formule à mettre
en D1 et à tirer jusqu'à D12
=SOMMEPROD((MOIS($A$1:$A$5)=MOIS(C1))*$B$1:$B$5)

Cordialement
Michel

"Tristan" news:
Bonjours amis experts,

Dans ma colonne A je rentre des dates exprimées en JJ/MM/AA. A chaque date
correspond une valeur dans la colonne B.
Dans un autre tableau, j'aimerais extraire la somme des valeurs pour
chaque
mois de l'année.

Je nage.
Merci beaucoup pour votre aide.

Très courtoisement,
Tristan









Tristan
Le #6538131
http://cjoint.com/data/fcpIVIHGMh.htm

Voilà l'idée, merci Serge



BIZZ !

Tu pourrais peut-être envoyer un échantillon
de tes données sur Cjoint.com

Serge


"Tristan"
Messieurs,
J'ai donc testé les 2 méthodes. Rien n'y fait ! J'obtiens des 0 à mes
résultats...

Une autre piste peut être ?

Merci encore



Bonjour,
en colonne A : les dates, en colonne B : un montant, en colonne C : 12 dates
par exemple le dernier jour de chaque mois, en colonne D la formule à mettre
en D1 et à tirer jusqu'à D12
=SOMMEPROD((MOIS($A$1:$A$5)=MOIS(C1))*$B$1:$B$5)

Cordialement
Michel

"Tristan" news:
Bonjours amis experts,

Dans ma colonne A je rentre des dates exprimées en JJ/MM/AA. A chaque date
correspond une valeur dans la colonne B.
Dans un autre tableau, j'aimerais extraire la somme des valeurs pour
chaque
mois de l'année.

Je nage.
Merci beaucoup pour votre aide.

Très courtoisement,
Tristan














Sam
Le #6538111
Bonjour,
en B3 de la feuille Somme
=SOMMEPROD((MOIS('Feuille de données'!$E$4:$E$6)=MOIS(A3))*'Feuille de
données'!$F$4:$F$6)

en C3 de la feuille Somme :
=SOMMEPROD((MOIS('Feuille de données'!$G$4:$G$6)=MOIS(A3))*'Feuille de
données'!$I$4:$I$6)

à tirer jusqu'en bas du tableau Somme

Cordialement
Michel
Tristan
Le #6538091
Bon, ça se précise...
J'ai tenté un truc avec SOMME.SI (=SOMME.SI(E4:E32;"mars-08";F4:F32)) qui
semble fonctionner à un détail près.
Pour ma date, j'ai demandé un type "mars-01". Lorsque je saisis la date (qui
se transforme du coup en "mars-08") ça ne sort rien. Par contre, lorsque je
fais une saisie texte 'mars-08', le calcul se fait bien.
Ce serait quand même génial que ça puisse fonctionner en saisissant la date...

Merci de votre aide précieuse
Tristan


BIZZ !

Tu pourrais peut-être envoyer un échantillon
de tes données sur Cjoint.com

Serge


"Tristan"
Messieurs,
J'ai donc testé les 2 méthodes. Rien n'y fait ! J'obtiens des 0 à mes
résultats...

Une autre piste peut être ?

Merci encore



Bonjour,
en colonne A : les dates, en colonne B : un montant, en colonne C : 12 dates
par exemple le dernier jour de chaque mois, en colonne D la formule à mettre
en D1 et à tirer jusqu'à D12
=SOMMEPROD((MOIS($A$1:$A$5)=MOIS(C1))*$B$1:$B$5)

Cordialement
Michel

"Tristan" news:
Bonjours amis experts,

Dans ma colonne A je rentre des dates exprimées en JJ/MM/AA. A chaque date
correspond une valeur dans la colonne B.
Dans un autre tableau, j'aimerais extraire la somme des valeurs pour
chaque
mois de l'année.

Je nage.
Merci beaucoup pour votre aide.

Très courtoisement,
Tristan














Tristan
Le #6538471
Merci beaucoup Michel !
J'ai copier exactement vos formules sans modifier quoi que ce soit en raison
de mon niveau de compréhension de béotien et je n'obtions que des #REF! en
résultat...

Merci encore
T.





Bonjour,
en B3 de la feuille Somme
=SOMMEPROD((MOIS('Feuille de données'!$E$4:$E$6)=MOIS(A3))*'Feuille de
données'!$F$4:$F$6)

en C3 de la feuille Somme :
=SOMMEPROD((MOIS('Feuille de données'!$G$4:$G$6)=MOIS(A3))*'Feuille de
données'!$I$4:$I$6)

à tirer jusqu'en bas du tableau Somme

Cordialement
Michel





Tristan
Le #6538451
Michel,

J'ai donc opté pour votre méthode qui semble parfaite, à ce détail près que
je n'obtiens que des #REF! en résultat.
J'ai cru un instant que c'était lié au format/type de date. Manifestement
pas...

La technologie est pleine de mystères.
Merci pour votre aide.

T.


Bon, ça se précise...
J'ai tenté un truc avec SOMME.SI (=SOMME.SI(E4:E32;"mars-08";F4:F32)) qui
semble fonctionner à un détail près.
Pour ma date, j'ai demandé un type "mars-01". Lorsque je saisis la date (qui
se transforme du coup en "mars-08") ça ne sort rien. Par contre, lorsque je
fais une saisie texte 'mars-08', le calcul se fait bien.
Ce serait quand même génial que ça puisse fonctionner en saisissant la date...

Merci de votre aide précieuse
Tristan


BIZZ !

Tu pourrais peut-être envoyer un échantillon
de tes données sur Cjoint.com

Serge


"Tristan"
Messieurs,
J'ai donc testé les 2 méthodes. Rien n'y fait ! J'obtiens des 0 à mes
résultats...

Une autre piste peut être ?

Merci encore



Bonjour,
en colonne A : les dates, en colonne B : un montant, en colonne C : 12 dates
par exemple le dernier jour de chaque mois, en colonne D la formule à mettre
en D1 et à tirer jusqu'à D12
=SOMMEPROD((MOIS($A$1:$A$5)=MOIS(C1))*$B$1:$B$5)

Cordialement
Michel

"Tristan" news:
Bonjours amis experts,

Dans ma colonne A je rentre des dates exprimées en JJ/MM/AA. A chaque date
correspond une valeur dans la colonne B.
Dans un autre tableau, j'aimerais extraire la somme des valeurs pour
chaque
mois de l'année.

Je nage.
Merci beaucoup pour votre aide.

Très courtoisement,
Tristan
















Publicité
Poster une réponse
Anonyme