Sommeprod année décaler

Le
syleg35
Bonjour à tous

SVP besoin d'aide pour modifier formule

J'ai cette formule pour avoir le total des valeurs par année, en colonne =
(D) les années de 2005 à 2013, en col (A) les mois et en (B) les valeur=
s

=SOMMEPROD((ANNEE($A$2:$A$200)=D2)*($B$2:$B$200))

mais pour raison propre à mon organisation, mon calcul année doit ce fa=
ire de décembre à novembre

Exemple : pour 2005 c'est égale à décembre 2004 à novembre 2005

pour 2006 c'est égale à décembre 2005 à novembre 2006

Merci à vous
Bonne journée
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
DanielCo
Le #25928982
Bonjour,
Formule matricielle (valider avec Ctrl+Maj+Entrée) :
=SOMMEPROD(((ANNEE($A$2:$A$200)Ò-1)*(MOIS($A$2:$A$200))+(ANNEE($A$2:$A$200)Ò)*(MOIS($A$2:$A$200)))*$B$2:$B$200)
Cordialement.
Daniel


Bonjour à tous

SVP besoin d'aide pour modifier formule

J'ai cette formule pour avoir le total des valeurs par année, en colonne (D)
les années de 2005 à 2013, en col (A) les mois et en (B) les valeurs

=SOMMEPROD((ANNEE($A$2:$A$200)Ò)*($B$2:$B$200))

mais pour raison propre à mon organisation, mon calcul année doit ce faire de
décembre à novembre

Exemple : pour 2005 c'est égale à décembre 2004 à novembre 2005

pour 2006 c'est égale à décembre 2005 à novembre 2006

Merci à vous
Bonne journée
Jacquouille
Le #25928972
Bonjour
Pour déc2004 et jan à nov inclus 2005
=Sommeprod((( année = 2004)*(mois)*(b2:b200))+(sommeprod((année =
2005)*(mois=<11)*(b2:b200)))
ou D2 04 --> =sommeprod(((annéeÒ)*(mois
)*(b2:b200))+(sommeprod((annéeÒ+1)*(mois=<11)*(b2:b200)))
Pas testé, mais les Dieux de SP veillent

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
a écrit dans le message de groupe de discussion :


Bonjour à tous

SVP besoin d'aide pour modifier formule

J'ai cette formule pour avoir le total des valeurs par année, en colonne (D)
les années de 2005 à 2013, en col (A) les mois et en (B) les valeurs

=SOMMEPROD((ANNEE($A$2:$A$200)Ò)*($B$2:$B$200))

mais pour raison propre à mon organisation, mon calcul année doit ce faire
de décembre à novembre

Exemple : pour 2005 c'est égale à décembre 2004 à novembre 2005

pour 2006 c'est égale à décembre 2005 à novembre 2006

Merci à vous
Bonne journée
DanielCo
Le #25929002
Oups, en relisant la formule de Jacquoouille, je me suis aperçu de mon
erreur :
=SOMMEPROD(((ANNEE($A$2:$A$200)Ò-1)*(MOIS($A$2:$A$200))+(ANNEE($A$2:$A$200)Ò)*(MOIS($A$2:$A$200)<12))*$B$2:$B$200)
Daniel


Bonjour,
Formule matricielle (valider avec Ctrl+Maj+Entrée) :
=SOMMEPROD(((ANNEE($A$2:$A$200)Ò-1)*(MOIS($A$2:$A$200))+(ANNEE($A$2:$A$200)Ò)*(MOIS($A$2:$A$200)))*$B$2:$B$200)
Cordialement.
Daniel


Bonjour à tous

SVP besoin d'aide pour modifier formule

J'ai cette formule pour avoir le total des valeurs par année, en colonne
(D) les années de 2005 à 2013, en col (A) les mois et en (B) les valeurs

=SOMMEPROD((ANNEE($A$2:$A$200)Ò)*($B$2:$B$200))

mais pour raison propre à mon organisation, mon calcul année doit ce faire
de décembre à novembre

Exemple : pour 2005 c'est égale à décembre 2004 à novembre 2005

pour 2006 c'est égale à décembre 2005 à novembre 2006

Merci à vous
Bonne journée
syleg35
Le #25929072
Bonjour ;
DanielCo

Merci !
la deuxième fonctionne c'est Ok

Bonne journée

Le samedi 11 janvier 2014 15:18:45 UTC+1, DanielCo a écrit :
Oups, en relisant la formule de Jacquoouille, je me suis aperᅵu d e mon

erreur :

=SOMMEPROD(((ANNEE($A$2:$A$200)Ò-1)*(MOIS($A$2:$A$200))+(ANNEE ($A$2:$A$200)Ò)*(MOIS($A$2:$A$200)<12))*$B$2:$B$200)

Daniel





> Bonjour,

> Formule matricielle (valider avec Ctrl+Maj+Entrᅵe) :

> =SOMMEPROD(((ANNEE($A$2:$A$200)Ò-1)*(MOIS($A$2:$A$200))+(ANN EE($A$2:$A$200)Ò)*(MOIS($A$2:$A$200)))*$B$2:$B$200)

> Cordialement.

> Daniel

>

>

>> Bonjour ᅵ tous

>>

>> SVP besoin d'aide pour modifier formule

>>

>> J'ai cette formule pour avoir le total des valeurs par annᅵe, en colonne

>> (D) les annᅵes de 2005 ᅵ 2013, en col (A) les mois et en (B) les valeurs

>>

>> =SOMMEPROD((ANNEE($A$2:$A$200)Ò)*($B$2:$B$200))

>>

>> mais pour raison propre ᅵ mon organisation, mon calcul annï ¿œe doit ce faire

>> de dᅵcembre ᅵ novembre

>>

>> Exemple : pour 2005 c'est ᅵgale ᅵ dᅵcembre 200 4 ᅵ novembre 2005

>>

>> pour 2006 c'est ᅵgale ᅵ dᅵcembre 2005 ᅵ novembre 2006

>>

>> Merci ᅵ vous

>> Bonne journᅵe
Publicité
Poster une réponse
Anonyme