SOMMEPROD avec cellules vides contenant ""

Le
Versatile
Bonjour
Imaginons que nous ayons en A1 500, A2 750, A3 1000, en A4 une formule
qui retourne "", si nous faisons en A5 :
=SOMMEPROD((A1:A4>900)*(A1:A4))
Cette formule retourne #VALEUR! au lieu de 1000 car ce SOMMEPROD ne
gère pas la cellule A4 qui pourtant ne contient rien (ou plutôt une
formule qui retourne "").

C'est bien dommage car SOMMEPROD est une petite merveille bien
pratique. Quelqu'un aurait une solution ? (Une solution autre que
celle consistant à forcer A4 de retourner un zéro au lieu de "")
Un grand merci.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Versatile
Le #18385261
On 14 jan, 15:35, Versatile
Bonjour
Imaginons que nous ayons en A1 500, A2 750, A3 1000, en A4 une formule
qui retourne "", si nous faisons en A5 :
=SOMMEPROD((A1:A4>900)*(A1:A4))
Cette formule retourne #VALEUR! au lieu de 1000 car ce SOMMEPROD ne
gère pas la cellule A4 qui pourtant ne contient rien (ou plutôt une
formule qui retourne "").

C'est bien dommage car SOMMEPROD est une petite merveille bien
pratique. Quelqu'un aurait une solution ? (Une solution autre que
celle consistant à forcer A4 de retourner un zéro au lieu de "")...
Un grand merci.



Bien en fait, je crois avoir trouvé la solution, il suffit de modifier
ainsi la formule :
=SOMME((A1:A4>900)*(SI(A1:A4="";0;A1:A4)))
suivi d'un CTRL+MAJ+ENTREE
Publicité
Poster une réponse
Anonyme