Sommeprod avec formule

Le
Guy85
Bonjour,
Dans B4 j'ai "Leclerc".
Dans E4 j'ai la formule suivante :
=SI($B4="";"";(RECHERCHEV($B4;Liste!$A$3:$D$57;4;0)))
ce qui me donne le mot "Alimentation"
Dans K5 je souhaiterais avoir la somme des dépenses d'alimentation.
J'ai mis la formule =SOMMEPROD(($E$4:$E$70="Alimentation")*$F$4:$F$70)
Dans ce cas là, la fonction "SOMMEPROD" ne fonctionne pas (à cause de la
formule je suppose)
Comment faire pour avoir le même résultat comme si il y avait le mot
"Alimentation" ?
Merci de votre aide
Cordialement
Guy
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Manu
Le #21483812
Essaie ceci :
=SOMMEPROD(($E$4:$E$70="Alimentation")*($F$4:$F$70))

Manu

"Guy85"
Bonjour,
Dans B4 j'ai "Leclerc".
Dans E4 j'ai la formule suivante :
=SI($B4="";"";(RECHERCHEV($B4;Liste!$A$3:$D$57;4;0)))
ce qui me donne le mot "Alimentation"
Dans K5 je souhaiterais avoir la somme des dépenses d'alimentation.
J'ai mis la formule =SOMMEPROD(($E$4:$E$70="Alimentation")*$F$4:$F$70)
Dans ce cas là, la fonction "SOMMEPROD" ne fonctionne pas (à cause de la
formule je suppose)
Comment faire pour avoir le même résultat comme si il y avait le mot
"Alimentation" ?
Merci de votre aide
Cordialement
Guy

Guy85
Le #21483852
Bonjour Manu,
C'est la même que la mienne.

"Manu"
Essaie ceci :
=SOMMEPROD(($E$4:$E$70="Alimentation")*($F$4:$F$70))

Manu

"Guy85"
Bonjour,
Dans B4 j'ai "Leclerc".
Dans E4 j'ai la formule suivante :
=SI($B4="";"";(RECHERCHEV($B4;Liste!$A$3:$D$57;4;0)))
ce qui me donne le mot "Alimentation"
Dans K5 je souhaiterais avoir la somme des dépenses d'alimentation.
J'ai mis la formule =SOMMEPROD(($E$4:$E$70="Alimentation")*$F$4:$F$70)
Dans ce cas là, la fonction "SOMMEPROD" ne fonctionne pas (à cause de la
formule je suppose)
Comment faire pour avoir le même résultat comme si il y avait le mot
"Alimentation" ?
Merci de votre aide
Cordialement
Guy





michdenis
Le #21483842
Bonjour,

Ta formule devrait fonctionner sauf si tu as des cellules au format
texte dans ta plage $F$4:$F$70 ou des entrées textes.

Si tu modifies ta formule comme ceci, ta formule ne tiendra pas
compte de la remarque précédente... mais elle n'additionnera pas
non plus les cellules ayant un contenu numérique mais un format texte.

=SOMMEPROD(($E$4:$E$70="Alimentation")*1;($F$4:$F$70))



"Guy85"
Bonjour,
Dans B4 j'ai "Leclerc".
Dans E4 j'ai la formule suivante :
=SI($B4="";"";(RECHERCHEV($B4;Liste!$A$3:$D$57;4;0)))
ce qui me donne le mot "Alimentation"
Dans K5 je souhaiterais avoir la somme des dépenses d'alimentation.
J'ai mis la formule =SOMMEPROD(($E$4:$E$70="Alimentation")*$F$4:$F$70)
Dans ce cas là, la fonction "SOMMEPROD" ne fonctionne pas (à cause de la
formule je suppose)
Comment faire pour avoir le même résultat comme si il y avait le mot
"Alimentation" ?
Merci de votre aide
Cordialement
Guy
Guy85
Le #21483932
Bonjour,
Dans la colonne F se ne sont que des Prix
Par contre dans la colonne E se sont des formules.
Ce qui veut dire que je ne peux pas faire le somme si le nom inscrit est là
suite à une formule ?
Tel que : =SI($B4="";"";(RECHERCHEV($B4;Liste!$A$3:$D$57;4;0))) =
(Alimentation)

"michdenis" eZwWq$
Bonjour,

Ta formule devrait fonctionner sauf si tu as des cellules au format
texte dans ta plage $F$4:$F$70 ou des entrées textes.

Si tu modifies ta formule comme ceci, ta formule ne tiendra pas
compte de la remarque précédente... mais elle n'additionnera pas
non plus les cellules ayant un contenu numérique mais un format texte.

=SOMMEPROD(($E$4:$E$70="Alimentation")*1;($F$4:$F$70))



"Guy85" discussion :

Bonjour,
Dans B4 j'ai "Leclerc".
Dans E4 j'ai la formule suivante :
=SI($B4="";"";(RECHERCHEV($B4;Liste!$A$3:$D$57;4;0)))
ce qui me donne le mot "Alimentation"
Dans K5 je souhaiterais avoir la somme des dépenses d'alimentation.
J'ai mis la formule =SOMMEPROD(($E$4:$E$70="Alimentation")*$F$4:$F$70)
Dans ce cas là, la fonction "SOMMEPROD" ne fonctionne pas (à cause de la
formule je suppose)
Comment faire pour avoir le même résultat comme si il y avait le mot
"Alimentation" ?
Merci de votre aide
Cordialement
Guy

Manu
Le #21483922
Ce n'est pas le meme jeux de parenthese

"Manu"
Essaie ceci :
=SOMMEPROD(($E$4:$E$70="Alimentation")*($F$4:$F$70))

Manu

"Guy85"
Bonjour,
Dans B4 j'ai "Leclerc".
Dans E4 j'ai la formule suivante :
=SI($B4="";"";(RECHERCHEV($B4;Liste!$A$3:$D$57;4;0)))
ce qui me donne le mot "Alimentation"
Dans K5 je souhaiterais avoir la somme des dépenses d'alimentation.
J'ai mis la formule =SOMMEPROD(($E$4:$E$70="Alimentation")*$F$4:$F$70)
Dans ce cas là, la fonction "SOMMEPROD" ne fonctionne pas (à cause de la
formule je suppose)
Comment faire pour avoir le même résultat comme si il y avait le mot
"Alimentation" ?
Merci de votre aide
Cordialement
Guy





Guy85
Le #21484062
Excuse_moi........effectivement, mais elle ne fonctionne pas plus.

"Manu"
Ce n'est pas le meme jeux de parenthese

"Manu"
Essaie ceci :
=SOMMEPROD(($E$4:$E$70="Alimentation")*($F$4:$F$70))

Manu

"Guy85"
Bonjour,
Dans B4 j'ai "Leclerc".
Dans E4 j'ai la formule suivante :
=SI($B4="";"";(RECHERCHEV($B4;Liste!$A$3:$D$57;4;0)))
ce qui me donne le mot "Alimentation"
Dans K5 je souhaiterais avoir la somme des dépenses d'alimentation.
J'ai mis la formule =SOMMEPROD(($E$4:$E$70="Alimentation")*$F$4:$F$70)
Dans ce cas là, la fonction "SOMMEPROD" ne fonctionne pas (à cause de la
formule je suppose)
Comment faire pour avoir le même résultat comme si il y avait le mot
"Alimentation" ?
Merci de votre aide
Cordialement
Guy









michdenis
Le #21484152
Que te retourne ta formule ?

Le fait que ce soit une formule qui retourne "Alimentation"
ne devrait pas causer de problème !

Il y a quelque chose que tu ne nous dis pas dans l'organisation
de tes données...



"Guy85" #
Bonjour,
Dans la colonne F se ne sont que des Prix
Par contre dans la colonne E se sont des formules.
Ce qui veut dire que je ne peux pas faire le somme si le nom inscrit est là
suite à une formule ?
Tel que : =SI($B4="";"";(RECHERCHEV($B4;Liste!$A$3:$D$57;4;0))) (Alimentation)

"michdenis" eZwWq$
Bonjour,

Ta formule devrait fonctionner sauf si tu as des cellules au format
texte dans ta plage $F$4:$F$70 ou des entrées textes.

Si tu modifies ta formule comme ceci, ta formule ne tiendra pas
compte de la remarque précédente... mais elle n'additionnera pas
non plus les cellules ayant un contenu numérique mais un format texte.

=SOMMEPROD(($E$4:$E$70="Alimentation")*1;($F$4:$F$70))



"Guy85" discussion :

Bonjour,
Dans B4 j'ai "Leclerc".
Dans E4 j'ai la formule suivante :
=SI($B4="";"";(RECHERCHEV($B4;Liste!$A$3:$D$57;4;0)))
ce qui me donne le mot "Alimentation"
Dans K5 je souhaiterais avoir la somme des dépenses d'alimentation.
J'ai mis la formule =SOMMEPROD(($E$4:$E$70="Alimentation")*$F$4:$F$70)
Dans ce cas là, la fonction "SOMMEPROD" ne fonctionne pas (à cause de la
formule je suppose)
Comment faire pour avoir le même résultat comme si il y avait le mot
"Alimentation" ?
Merci de votre aide
Cordialement
Guy

Guy85
Le #21484362
J'ai fait un fichier brouillon.
Effectivement ça fonctionne.
Je ne vois pas pourquoi cela ne fonctionne pas dans le fichier original.
Ça fonctionne qu'avec les cellules sans formule.

"michdenis" %
Que te retourne ta formule ?

Le fait que ce soit une formule qui retourne "Alimentation"
ne devrait pas causer de problème !

Il y a quelque chose que tu ne nous dis pas dans l'organisation
de tes données...



"Guy85" discussion :
#
Bonjour,
Dans la colonne F se ne sont que des Prix
Par contre dans la colonne E se sont des formules.
Ce qui veut dire que je ne peux pas faire le somme si le nom inscrit est

suite à une formule ?
Tel que : =SI($B4="";"";(RECHERCHEV($B4;Liste!$A$3:$D$57;4;0))) > (Alimentation)

"michdenis" eZwWq$
Bonjour,

Ta formule devrait fonctionner sauf si tu as des cellules au format
texte dans ta plage $F$4:$F$70 ou des entrées textes.

Si tu modifies ta formule comme ceci, ta formule ne tiendra pas
compte de la remarque précédente... mais elle n'additionnera pas
non plus les cellules ayant un contenu numérique mais un format texte.

=SOMMEPROD(($E$4:$E$70="Alimentation")*1;($F$4:$F$70))



"Guy85" discussion :

Bonjour,
Dans B4 j'ai "Leclerc".
Dans E4 j'ai la formule suivante :
=SI($B4="";"";(RECHERCHEV($B4;Liste!$A$3:$D$57;4;0)))
ce qui me donne le mot "Alimentation"
Dans K5 je souhaiterais avoir la somme des dépenses d'alimentation.
J'ai mis la formule =SOMMEPROD(($E$4:$E$70="Alimentation")*$F$4:$F$70)
Dans ce cas là, la fonction "SOMMEPROD" ne fonctionne pas (à cause de la
formule je suppose)
Comment faire pour avoir le même résultat comme si il y avait le mot
"Alimentation" ?
Merci de votre aide
Cordialement
Guy




Guy85
Le #21484342
Ça y est, j'ai trouvé.
Effectivement, il y avait du texte dans une cellule de la colonne F c'était
#N/A.
Merci de ton aide
cordialement
Guy

"michdenis" %
Que te retourne ta formule ?

Le fait que ce soit une formule qui retourne "Alimentation"
ne devrait pas causer de problème !

Il y a quelque chose que tu ne nous dis pas dans l'organisation
de tes données...



"Guy85" discussion :
#
Bonjour,
Dans la colonne F se ne sont que des Prix
Par contre dans la colonne E se sont des formules.
Ce qui veut dire que je ne peux pas faire le somme si le nom inscrit est

suite à une formule ?
Tel que : =SI($B4="";"";(RECHERCHEV($B4;Liste!$A$3:$D$57;4;0))) > (Alimentation)

"michdenis" eZwWq$
Bonjour,

Ta formule devrait fonctionner sauf si tu as des cellules au format
texte dans ta plage $F$4:$F$70 ou des entrées textes.

Si tu modifies ta formule comme ceci, ta formule ne tiendra pas
compte de la remarque précédente... mais elle n'additionnera pas
non plus les cellules ayant un contenu numérique mais un format texte.

=SOMMEPROD(($E$4:$E$70="Alimentation")*1;($F$4:$F$70))



"Guy85" discussion :

Bonjour,
Dans B4 j'ai "Leclerc".
Dans E4 j'ai la formule suivante :
=SI($B4="";"";(RECHERCHEV($B4;Liste!$A$3:$D$57;4;0)))
ce qui me donne le mot "Alimentation"
Dans K5 je souhaiterais avoir la somme des dépenses d'alimentation.
J'ai mis la formule =SOMMEPROD(($E$4:$E$70="Alimentation")*$F$4:$F$70)
Dans ce cas là, la fonction "SOMMEPROD" ne fonctionne pas (à cause de la
formule je suppose)
Comment faire pour avoir le même résultat comme si il y avait le mot
"Alimentation" ?
Merci de votre aide
Cordialement
Guy




Publicité
Poster une réponse
Anonyme