sommeprod avec multi critères

Le
yon
Bonsoir,

J'essaye d'écrire la formule suivante dans un tableau financier mais sans
succès:

=SOMMEPROD('Feuille'!$A$2:$G$220=$A58)*('Feuille'!$E$2:$E$220>G$7)*('Feuille'!$E$2:$E$220<H$7)

Il s'agit de faire la somme des valeurs d'une colonne A2:A220 pour les
valeurs A58
et compris entre les dates G7 et H7

Je remercie d'avance les âmes charitables.


--
yon
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
yon
Le #5055731
Merci Philippe pour ta réponse.

Cependant, je n'obtiens que des valeur = à 0.
J'ai vérifié et je ne vois où cela coince.

Merci d'avance
--
yon



Bonsoir,
Les plages utilisées dans le calcul doivent être de même taille ; essaye
ceci :

=SOMMEPROD('Feuille'!$A$2:$A$220=$A58)*('Feuille'!$E$2:$E$220>G$7)*('Feuille'!$E$2:$E$220<H$7)
--
http://www.excelabo.net/mpfe/connexion.php
http://dj.joss.free.fr/trombine.htm
Avec plaisir
Philippe.R
"yon" news:
Bonsoir,

J'essaye d'écrire la formule suivante dans un tableau financier mais sans
succès:

=SOMMEPROD('Feuille'!$A$2:$G$220=$A58)*('Feuille'!$E$2:$E$220>G$7)*('Feuille'!$E$2:$E$220<H$7)

Il s'agit de faire la somme des valeurs d'une colonne A2:A220 pour les
valeurs A58
et compris entre les dates G7 et H7

Je remercie d'avance les âmes charitables.


--
yon






Philippe.R
Le #5055691
Re,
Peux tu publier un extrait de ton classeur cjoint.com, pour visualiser le
problème ?
http://cjoint.com/
--
http://www.excelabo.net/mpfe/connexion.php
http://dj.joss.free.fr/trombine.htm
Avec plaisir
Philippe.R
"yon" news:
Merci Philippe pour ta réponse.

Cependant, je n'obtiens que des valeur = à 0.
J'ai vérifié et je ne vois où cela coince.

Merci d'avance
--
yon



Bonsoir,
Les plages utilisées dans le calcul doivent être de même taille ; essaye
ceci :

=SOMMEPROD('Feuille'!$A$2:$A$220=$A58)*('Feuille'!$E$2:$E$220>G$7)*('Feuille'!$E$2:$E$220<H$7)
--
http://www.excelabo.net/mpfe/connexion.php
http://dj.joss.free.fr/trombine.htm
Avec plaisir
Philippe.R
"yon" news:
Bonsoir,

J'essaye d'écrire la formule suivante dans un tableau financier mais
sans
succès:

=SOMMEPROD('Feuille'!$A$2:$G$220=$A58)*('Feuille'!$E$2:$E$220>G$7)*('Feuille'!$E$2:$E$220<H$7)

Il s'agit de faire la somme des valeurs d'une colonne A2:A220 pour les
valeurs A58
et compris entre les dates G7 et H7

Je remercie d'avance les âmes charitables.


--
yon








Trirème
Le #5055661
B'soir
Mais oui, aux parenthèses près :

Trirème


=SOMMEPROD('Feuille'!$A$2:$A$220=$A58)*('Feuille'!$E$2:$E$220>G$7)*('Feuille'!$E$2:$E$220<H$7)
=SOMMEPROD(('Feuille'!$A$2:$A$220=$A58)*('Feuille'!$E$2:$E$220>G$7)*('Feuille'!$E$2:$E$220<H$7))




yon
Le #5055641
Merci, c'est parti sur le lien.
--
yon



Bonsoir,

J'essaye d'écrire la formule suivante dans un tableau financier mais sans
succès:

=SOMMEPROD('Feuille'!$A$2:$G$220=$A58)*('Feuille'!$E$2:$E$220>G$7)*('Feuille'!$E$2:$E$220<H$7)

Il s'agit de faire la somme des valeurs d'une colonne A2:A220 pour les
valeurs A58
et compris entre les dates G7 et H7

Je remercie d'avance les âmes charitables.


--
yon


yon
Le #5055621
Cela marche !!!

Merci beaucoup à Philippe.R et Trirème.

Cela faisait plusieurs heures que je perdais dans cette formule.

Vous avez été très efficaces et sympas.

A bientôt
--
yon



Bonsoir,

J'essaye d'écrire la formule suivante dans un tableau financier mais sans
succès:

=SOMMEPROD('Feuille'!$A$2:$G$220=$A58)*('Feuille'!$E$2:$E$220>G$7)*('Feuille'!$E$2:$E$220<H$7)

Il s'agit de faire la somme des valeurs d'une colonne A2:A220 pour les
valeurs A58
et compris entre les dates G7 et H7

Je remercie d'avance les âmes charitables.


--
yon


Publicité
Poster une réponse
Anonyme