sommeprod sur date format jjj

Le
Ptck
Bonjour

=SOMMEPROD(($B$1:$AF$1="sam")*($B3:$AF3={"M";"AM";"M2";"M4"})*1)+SOMMEPROD(($B$1:$AF$1="dim")*($B3:$AF3={"M";"AM";"M2";"M4"})*1)


j'ai cette formule qui compte le nombre de M,AM,M2,M4 pour les samedi et
dimanche
j'ai mis en b1 la date 01/01/2010 et en b2 , b1+1 ce qui me donne 02/01/2010
etc puis j'ai formaté en personnalisé la cellule en jjj pour avoir sam ou
dim dans les cellules
mais la formule ne prend pas en compte le sam et dim normal la valeur de la
cellule n'est pas sam ou dim
y a t-il un moyen à part mettre en dur "sam" ou "dim" pour que la fomule
marche

merci pour votre aide
ptck
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacquouille
Le #21328811
Bonjour
Avec Excel et surtout SOMMEPROD, il faut bien distinguer deux choses.

La première, le contenu de la cellule, sa valeur. Nombreux problèmes,
surtout avec les dates, heures et couleurs issues d'une MEFC.
Ensuite, le formatage de la cellule, càd son apparence, son habillement.

Ainsi, si on entre 1 dans une cel, on sait l'additionner à d'autres. Si on
écrit 1 mètre, là on a des difficultés.Il faut alors passer au format
personnalisé.

Allez, on revient aux date-heure.

Pour Excel les dates ne sont que des chiffres normaux, qui représentent le
nombre de jours depuis le 1/1/1900. Ainsi, aujourdhui, 6 mars, c'est le
40243 ème jour.

Les heures ne sont que des 24 èmes de 1 jour. Ainsi, aujourd'hui à midi, ce
sera 40243,5 .....

C'est cela qu'interprète SOMMEPROD.

Le formatage de la cel (jj ou jjj ou jjjj) ne changera rien.

Il suffit dès lors de demander à Excel de bien vouloir travailler (attention
aux syndicats....) sur la valeur du jour de la semaine (JOURSEM) Cette
fonction revoie la valeur du jour de la semaine inscrit dans une cellule.
=joursem(a1) renverra 7 (samedi) si a1=aujourd'hui.dimanche=1, lundi=2,
mardi=3 ......

Donc, pour calculer le nombre de "AM" dans la col C si colB = le samedi
.....

=sommeprod((joursem(b1:b100)=7)*(c1:c100="AM"))

Sommeprod va analyser le jour de la semaine de la première cel de la col B,
ET analyser la première cel de colC pour voir si elle contient "AM".
Si OUI aux deux, alors Excel mémorise 1.( Explic très très réduite)

Voilà, en très gros le fonctionnement de la chose.

On peut encore écrire une page sur les dates, une autre sur SOMMEPROD et
encore une autre ....

Un brin d'Ecritures Saintes ? -----> Tout cela est mieux expliqué en long,
large et hauteur sur Excelabo.net .....

Si pas bon, reviens.
Bon courage
--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Ptck"
Bonjour

=SOMMEPROD(($B$1:$AF$1="sam")*($B3:$AF3={"M";"AM";"M2";"M4"})*1)+SOMMEPROD(($B$1:$AF$1="dim")*($B3:$AF3={"M";"AM";"M2";"M4"})*1)


j'ai cette formule qui compte le nombre de M,AM,M2,M4 pour les samedi et
dimanche
j'ai mis en b1 la date 01/01/2010 et en b2 , b1+1 ce qui me donne
02/01/2010 etc... puis j'ai formaté en personnalisé la cellule en jjj pour
avoir sam ou dim dans les cellules
mais la formule ne prend pas en compte le sam et dim normal la valeur de
la cellule n'est pas sam ou dim
y a t-il un moyen à part mettre en dur "sam" ou "dim" pour que la fomule
marche

merci pour votre aide
ptck




Ptck
Le #21328921
merci Jacquouille
je ferai un essai selon tes conseils
j'ai modifié ainsi
=SOMMEPROD((TEXTE($B$1:$AF$1;"jjj")="sam")*($B3:$AF3={"M";"AM";"M2";"M4"})*1)+SOMMEPROD((TEXTE($B$1:$AF$1;"jjj")="dim")*($B3:$AF3={"M";"AM";"M2";"M4"})*1)

ptck


"Jacquouille" news:
Bonjour
Avec Excel et surtout SOMMEPROD, il faut bien distinguer deux choses.

La première, le contenu de la cellule, sa valeur. Nombreux problèmes,
surtout avec les dates, heures et couleurs issues d'une MEFC.
Ensuite, le formatage de la cellule, càd son apparence, son habillement.

Ainsi, si on entre 1 dans une cel, on sait l'additionner à d'autres. Si
on écrit 1 mètre, là on a des difficultés.Il faut alors passer au format
personnalisé.

Allez, on revient aux date-heure.

Pour Excel les dates ne sont que des chiffres normaux, qui représentent le
nombre de jours depuis le 1/1/1900. Ainsi, aujourdhui, 6 mars, c'est le
40243 ème jour.

Les heures ne sont que des 24 èmes de 1 jour. Ainsi, aujourd'hui à midi,
ce sera 40243,5 .....

C'est cela qu'interprète SOMMEPROD.

Le formatage de la cel (jj ou jjj ou jjjj) ne changera rien.

Il suffit dès lors de demander à Excel de bien vouloir travailler
(attention aux syndicats....) sur la valeur du jour de la semaine
(JOURSEM) Cette fonction revoie la valeur du jour de la semaine inscrit
dans une cellule.
=joursem(a1) renverra 7 (samedi) si a1=aujourd'hui.dimanche=1, lundi=2,
mardi=3 ......

Donc, pour calculer le nombre de "AM" dans la col C si colB = le samedi
.....

=sommeprod((joursem(b1:b100)=7)*(c1:c100="AM"))

Sommeprod va analyser le jour de la semaine de la première cel de la col
B, ET analyser la première cel de colC pour voir si elle contient "AM".
Si OUI aux deux, alors Excel mémorise 1.( Explic très très réduite)

Voilà, en très gros le fonctionnement de la chose.

On peut encore écrire une page sur les dates, une autre sur SOMMEPROD et
encore une autre ....

Un brin d'Ecritures Saintes ? -----> Tout cela est mieux expliqué en long,
large et hauteur sur Excelabo.net .....

Si pas bon, reviens.
Bon courage
--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Ptck"
Bonjour

=SOMMEPROD(($B$1:$AF$1="sam")*($B3:$AF3={"M";"AM";"M2";"M4"})*1)+SOMMEPROD(($B$1:$AF$1="dim")*($B3:$AF3={"M";"AM";"M2";"M4"})*1)


j'ai cette formule qui compte le nombre de M,AM,M2,M4 pour les samedi et
dimanche
j'ai mis en b1 la date 01/01/2010 et en b2 , b1+1 ce qui me donne
02/01/2010 etc... puis j'ai formaté en personnalisé la cellule en jjj
pour avoir sam ou dim dans les cellules
mais la formule ne prend pas en compte le sam et dim normal la valeur de
la cellule n'est pas sam ou dim
y a t-il un moyen à part mettre en dur "sam" ou "dim" pour que la fomule
marche

merci pour votre aide
ptck








Caetera
Le #21329041

j'ai cette formule qui compte le nombre de M,AM,M2,M4 pour les samedi et
dimanche
j'ai mis en b1 la date 01/01/2010 et en b2 , b1+1 ce qui me donne 02/01/2010
etc... puis j'ai formaté en personnalisé la cellule en jjj pour avoir sam ou
dim dans les cellules
mais la formule ne prend pas en compte le sam et dim normal la valeur de la
cellule n'est pas sam ou dim




***********
Avec des dates (peu importe le format) en B1:AF1, utilise cette syntaxe :

=SOMMEPROD((JOURSEM(B1:AF1;2)>5)*(B3:AF3={"M";"AM";"M2";"M4"}))

Etc
Jacky
Le #21329031
Bonjour,

je ferai un essai selon tes conseils......


Il a dit/écrit "JOURSEM()", Jacquouille....."JOURSEM()"
pas texte()
--
Salutations
JJ


"Ptck"
merci Jacquouille
je ferai un essai selon tes conseils
j'ai modifié ainsi
=SOMMEPROD((TEXTE($B$1:$AF$1;"jjj")="sam")*($B3:$AF3={"M";"AM";"M2";"M4"})*1)+SOMMEPROD((TEXTE($B$1:$AF$1;"jjj")="dim")*($B3:$AF3={"M";"AM";"M2";"M4"})*1)

ptck


"Jacquouille"
Bonjour
Avec Excel et surtout SOMMEPROD, il faut bien distinguer deux choses.

La première, le contenu de la cellule, sa valeur. Nombreux problèmes, surtout avec les dates, heures et
couleurs issues d'une MEFC.
Ensuite, le formatage de la cellule, càd son apparence, son habillement.

Ainsi, si on entre 1 dans une cel, on sait l'additionner à d'autres. Si on écrit 1 mètre, là on a des
difficultés.Il faut alors passer au format personnalisé.

Allez, on revient aux date-heure.

Pour Excel les dates ne sont que des chiffres normaux, qui représentent le nombre de jours depuis le
1/1/1900. Ainsi, aujourdhui, 6 mars, c'est le 40243 ème jour.

Les heures ne sont que des 24 èmes de 1 jour. Ainsi, aujourd'hui à midi, ce sera 40243,5 .....

C'est cela qu'interprète SOMMEPROD.

Le formatage de la cel (jj ou jjj ou jjjj) ne changera rien.

Il suffit dès lors de demander à Excel de bien vouloir travailler (attention aux syndicats....) sur la
valeur du jour de la semaine (JOURSEM) Cette fonction revoie la valeur du jour de la semaine inscrit dans
une cellule.
=joursem(a1) renverra 7 (samedi) si a1=aujourd'hui.dimanche=1, lundi=2, mardi=3 ......

Donc, pour calculer le nombre de "AM" dans la col C si colB = le samedi .....

=sommeprod((joursem(b1:b100)=7)*(c1:c100="AM"))

Sommeprod va analyser le jour de la semaine de la première cel de la col B, ET analyser la première cel de
colC pour voir si elle contient "AM".
Si OUI aux deux, alors Excel mémorise 1.( Explic très très réduite)

Voilà, en très gros le fonctionnement de la chose.

On peut encore écrire une page sur les dates, une autre sur SOMMEPROD et encore une autre ....

Un brin d'Ecritures Saintes ? -----> Tout cela est mieux expliqué en long, large et hauteur sur
Excelabo.net .....

Si pas bon, reviens.
Bon courage
--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Ptck"
Bonjour

=SOMMEPROD(($B$1:$AF$1="sam")*($B3:$AF3={"M";"AM";"M2";"M4"})*1)+SOMMEPROD(($B$1:$AF$1="dim")*($B3:$AF3={"M";"AM";"M2";"M4"})*1)


j'ai cette formule qui compte le nombre de M,AM,M2,M4 pour les samedi et dimanche
j'ai mis en b1 la date 01/01/2010 et en b2 , b1+1 ce qui me donne 02/01/2010 etc... puis j'ai formaté en
personnalisé la cellule en jjj pour avoir sam ou dim dans les cellules
mais la formule ne prend pas en compte le sam et dim normal la valeur de la cellule n'est pas sam ou dim
y a t-il un moyen à part mettre en dur "sam" ou "dim" pour que la fomule marche

merci pour votre aide
ptck












Daniel.C
Le #21329021
Bonjour

Un autre manière de procéder, en utilisant la fonction JOURSEM :

=SOMMEPROD(((JOURSEM($B$1:$AF$1;2)=6)+(JOURSEM($B$1:$AF$1;2)=7))*($B3:$AF3={"M";"AM";"M2";"M4"})*1)

Daniel


merci Jacquouille
je ferai un essai selon tes conseils
j'ai modifié ainsi
=SOMMEPROD((TEXTE($B$1:$AF$1;"jjj")="sam")*($B3:$AF3={"M";"AM";"M2";"M4"})*1)+SOMMEPROD((TEXTE($B$1:$AF$1;"jjj")="dim")*($B3:$AF3={"M";"AM";"M2";"M4"})*1)

ptck


"Jacquouille" news:
Bonjour
Avec Excel et surtout SOMMEPROD, il faut bien distinguer deux choses.

La première, le contenu de la cellule, sa valeur. Nombreux problèmes,
surtout avec les dates, heures et couleurs issues d'une MEFC.
Ensuite, le formatage de la cellule, càd son apparence, son habillement.

Ainsi, si on entre 1 dans une cel, on sait l'additionner à d'autres. Si on
écrit 1 mètre, là on a des difficultés.Il faut alors passer au format
personnalisé.

Allez, on revient aux date-heure.

Pour Excel les dates ne sont que des chiffres normaux, qui représentent le
nombre de jours depuis le 1/1/1900. Ainsi, aujourdhui, 6 mars, c'est le
40243 ème jour.

Les heures ne sont que des 24 èmes de 1 jour. Ainsi, aujourd'hui à midi,
ce sera 40243,5 .....

C'est cela qu'interprète SOMMEPROD.

Le formatage de la cel (jj ou jjj ou jjjj) ne changera rien.

Il suffit dès lors de demander à Excel de bien vouloir travailler
(attention aux syndicats....) sur la valeur du jour de la semaine (JOURSEM)
Cette fonction revoie la valeur du jour de la semaine inscrit dans une
cellule.
=joursem(a1) renverra 7 (samedi) si a1=aujourd'hui.dimanche=1, lundi=2,
mardi=3 ......

Donc, pour calculer le nombre de "AM" dans la col C si colB = le samedi
.....

=sommeprod((joursem(b1:b100)=7)*(c1:c100="AM"))

Sommeprod va analyser le jour de la semaine de la première cel de la col B,
ET analyser la première cel de colC pour voir si elle contient "AM".
Si OUI aux deux, alors Excel mémorise 1.( Explic très très réduite)

Voilà, en très gros le fonctionnement de la chose.

On peut encore écrire une page sur les dates, une autre sur SOMMEPROD et
encore une autre ....

Un brin d'Ecritures Saintes ? -----> Tout cela est mieux expliqué en long,
large et hauteur sur Excelabo.net .....

Si pas bon, reviens.
Bon courage
-- Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Ptck"
Bonjour

=SOMMEPROD(($B$1:$AF$1="sam")*($B3:$AF3={"M";"AM";"M2";"M4"})*1)+SOMMEPROD(($B$1:$AF$1="dim")*($B3:$AF3={"M";"AM";"M2";"M4"})*1)


j'ai cette formule qui compte le nombre de M,AM,M2,M4 pour les samedi et
dimanche
j'ai mis en b1 la date 01/01/2010 et en b2 , b1+1 ce qui me donne
02/01/2010 etc... puis j'ai formaté en personnalisé la cellule en jjj pour
avoir sam ou dim dans les cellules
mais la formule ne prend pas en compte le sam et dim normal la valeur de
la cellule n'est pas sam ou dim
y a t-il un moyen à part mettre en dur "sam" ou "dim" pour que la fomule
marche

merci pour votre aide
ptck








Ptck
Le #21329161
je sais Jacky mais entre temps j'avais trouvé cette formule
=SOMMEPROD((TEXTE($B$1:$AF$1;"jjj")="sam")*($B3:$AF3={"M";"AM";"M2";"M4"})*1)+SOMMEPROD((TEXTE($B$1:$AF$1;"jjj")="dim")*($B3:$AF3={"M";"AM";"M2";"M4"})*1)

moins élégante que les votres
encore merci
ptck


"Jacky" u2sbT$
Bonjour,

je ferai un essai selon tes conseils......


Il a dit/écrit "JOURSEM()", Jacquouille....."JOURSEM()"
pas texte()
--
Salutations
JJ


"Ptck"
merci Jacquouille
je ferai un essai selon tes conseils
j'ai modifié ainsi
=SOMMEPROD((TEXTE($B$1:$AF$1;"jjj")="sam")*($B3:$AF3={"M";"AM";"M2";"M4"})*1)+SOMMEPROD((TEXTE($B$1:$AF$1;"jjj")="dim")*($B3:$AF3={"M";"AM";"M2";"M4"})*1)

ptck


"Jacquouille" news:

Bonjour
Avec Excel et surtout SOMMEPROD, il faut bien distinguer deux choses.

La première, le contenu de la cellule, sa valeur. Nombreux problèmes,
surtout avec les dates, heures et
couleurs issues d'une MEFC.
Ensuite, le formatage de la cellule, càd son apparence, son habillement.

Ainsi, si on entre 1 dans une cel, on sait l'additionner à d'autres. Si
on écrit 1 mètre, là on a des
difficultés.Il faut alors passer au format personnalisé.

Allez, on revient aux date-heure.

Pour Excel les dates ne sont que des chiffres normaux, qui représentent
le nombre de jours depuis le
1/1/1900. Ainsi, aujourdhui, 6 mars, c'est le 40243 ème jour.

Les heures ne sont que des 24 èmes de 1 jour. Ainsi, aujourd'hui à
midi, ce sera 40243,5 .....

C'est cela qu'interprète SOMMEPROD.

Le formatage de la cel (jj ou jjj ou jjjj) ne changera rien.

Il suffit dès lors de demander à Excel de bien vouloir travailler
(attention aux syndicats....) sur la
valeur du jour de la semaine (JOURSEM) Cette fonction revoie la valeur
du jour de la semaine inscrit dans
une cellule.
=joursem(a1) renverra 7 (samedi) si a1=aujourd'hui.dimanche=1, lundi=2,
mardi=3 ......

Donc, pour calculer le nombre de "AM" dans la col C si colB = le samedi
.....

=sommeprod((joursem(b1:b100)=7)*(c1:c100="AM"))

Sommeprod va analyser le jour de la semaine de la première cel de la col
B, ET analyser la première cel de
colC pour voir si elle contient "AM".
Si OUI aux deux, alors Excel mémorise 1.( Explic très très réduite)

Voilà, en très gros le fonctionnement de la chose.

On peut encore écrire une page sur les dates, une autre sur SOMMEPROD et
encore une autre ....

Un brin d'Ecritures Saintes ? -----> Tout cela est mieux expliqué en
long, large et hauteur sur
Excelabo.net .....

Si pas bon, reviens.
Bon courage
--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Ptck"
Bonjour

=SOMMEPROD(($B$1:$AF$1="sam")*($B3:$AF3={"M";"AM";"M2";"M4"})*1)+SOMMEPROD(($B$1:$AF$1="dim")*($B3:$AF3={"M";"AM";"M2";"M4"})*1)


j'ai cette formule qui compte le nombre de M,AM,M2,M4 pour les samedi
et dimanche
j'ai mis en b1 la date 01/01/2010 et en b2 , b1+1 ce qui me donne
02/01/2010 etc... puis j'ai formaté en
personnalisé la cellule en jjj pour avoir sam ou dim dans les cellules
mais la formule ne prend pas en compte le sam et dim normal la valeur
de la cellule n'est pas sam ou dim
y a t-il un moyen à part mettre en dur "sam" ou "dim" pour que la
fomule marche

merci pour votre aide
ptck

















Jacquouille
Le #21329371
Re
Si, dans tes cel, tu as écrit en dur "sam" et que, par conséquent ce sam
n'est pas issu d'un formatage de cel, alors vas-y à fond ....
Si on fait dans la dentelle (je recommande Brugges ou Calais), alors c'est
la proposition de Caetera la plus élaborée et celle de Daniel la plus facile
à comprendre.

--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Jacquouille" news:
Bonjour
Avec Excel et surtout SOMMEPROD, il faut bien distinguer deux choses.

La première, le contenu de la cellule, sa valeur. Nombreux problèmes,
surtout avec les dates, heures et couleurs issues d'une MEFC.
Ensuite, le formatage de la cellule, càd son apparence, son habillement.

Ainsi, si on entre 1 dans une cel, on sait l'additionner à d'autres. Si
on écrit 1 mètre, là on a des difficultés.Il faut alors passer au format
personnalisé.

Allez, on revient aux date-heure.

Pour Excel les dates ne sont que des chiffres normaux, qui représentent le
nombre de jours depuis le 1/1/1900. Ainsi, aujourdhui, 6 mars, c'est le
40243 ème jour.

Les heures ne sont que des 24 èmes de 1 jour. Ainsi, aujourd'hui à midi,
ce sera 40243,5 .....

C'est cela qu'interprète SOMMEPROD.

Le formatage de la cel (jj ou jjj ou jjjj) ne changera rien.

Il suffit dès lors de demander à Excel de bien vouloir travailler
(attention aux syndicats....) sur la valeur du jour de la semaine
(JOURSEM) Cette fonction revoie la valeur du jour de la semaine inscrit
dans une cellule.
=joursem(a1) renverra 7 (samedi) si a1=aujourd'hui.dimanche=1, lundi=2,
mardi=3 ......

Donc, pour calculer le nombre de "AM" dans la col C si colB = le samedi
.....

=sommeprod((joursem(b1:b100)=7)*(c1:c100="AM"))

Sommeprod va analyser le jour de la semaine de la première cel de la col
B, ET analyser la première cel de colC pour voir si elle contient "AM".
Si OUI aux deux, alors Excel mémorise 1.( Explic très très réduite)

Voilà, en très gros le fonctionnement de la chose.

On peut encore écrire une page sur les dates, une autre sur SOMMEPROD et
encore une autre ....

Un brin d'Ecritures Saintes ? -----> Tout cela est mieux expliqué en long,
large et hauteur sur Excelabo.net .....

Si pas bon, reviens.
Bon courage
--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Ptck"
Bonjour

=SOMMEPROD(($B$1:$AF$1="sam")*($B3:$AF3={"M";"AM";"M2";"M4"})*1)+SOMMEPROD(($B$1:$AF$1="dim")*($B3:$AF3={"M";"AM";"M2";"M4"})*1)


j'ai cette formule qui compte le nombre de M,AM,M2,M4 pour les samedi et
dimanche
j'ai mis en b1 la date 01/01/2010 et en b2 , b1+1 ce qui me donne
02/01/2010 etc... puis j'ai formaté en personnalisé la cellule en jjj
pour avoir sam ou dim dans les cellules
mais la formule ne prend pas en compte le sam et dim normal la valeur de
la cellule n'est pas sam ou dim
y a t-il un moyen à part mettre en dur "sam" ou "dim" pour que la fomule
marche

merci pour votre aide
ptck








Publicité
Poster une réponse
Anonyme