Sommeprod : où est l'erreur ?

Le
NewsMic
Bonjour,

En A2, j'ai un nombre stocké sous forme de texte. Le sommeprod ci-dessous me
donne les bons résultats. (J'ai validé par ctrl+maj+entrée pour obtenir une
matrice)
{=SOMMEPROD((Données!$B$2:$B$5275¢)*(Données!$R$2:$R$5275=9))}

Je fais la même chose, matrice comprise, pour un autre calcul sur la même
feuille de calcul, le résultat est 0. Si j'ajoute la parenthèse comme
ci-dessus juste après Sommeprod et avant la toute dernière à droite, j'ai
#N/A. Où est l'erreur ?
(F3 = 1) et (J2 = 1)
{=SOMMEPROD($B$2:$B$1944ó)*(Données!$R$2:$R$5275=J2)}

Merci
NewsMic
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
J
Le #17742121
Bonjour
manquerait pas de parenthèses?
=SOMMEPROD(($B$2:$B$1944ó)*(Données!$R$2:$R$5275=J2))
à valider par ctrl+maj+enter
Bon courage, les vrais experts prennent leur petit déj.
@+
J@@



NewsMic a écrit :
Bonjour,

En A2, j'ai un nombre stocké sous forme de texte. Le sommeprod ci-dessous me
donne les bons résultats. (J'ai validé par ctrl+maj+entrée pour obtenir une
matrice)
{=SOMMEPROD((Données!$B$2:$B$5275¢)*(Données!$R$2:$R$5275=9))}

Je fais la même chose, matrice comprise, pour un autre calcul sur la même
feuille de calcul, le résultat est 0. Si j'ajoute la parenthèse comme
ci-dessus juste après Sommeprod et avant la toute dernière à droite, j'ai
#N/A. Où est l'erreur ?
(F3 = 1) et (J2 = 1)
{=SOMMEPROD($B$2:$B$1944ó)*(Données!$R$2:$R$5275=J2)}

Merci
NewsMic





garnote
Le #17743951
Bonjour,

La fonction SOMMEPROD ne nécessite pas d'entrée matricielle
et les plages impliquées doivent avoir la même dimension:
SOMMEPROD affecte aux entrées de matrice non numériques la valeur zéro.

Ta première formule devrait s'écrire :
=SOMMEPROD((Données!$B$2:$B$5275=1*A2)*(Données!$R$2:$R$5275=9))
Quand à la seconde :
=SOMMEPROD(($B$2:$B$1944ó)*(Données!$R$2:$R$5275=J2))
elle ne peut pas fonctionner car les plages impliquées ne sont pas
de même dimension.

Serge




"NewsMic"
Bonjour,

En A2, j'ai un nombre stocké sous forme de texte. Le sommeprod ci-dessous me donne les bons résultats. (J'ai validé par
ctrl+maj+entrée pour obtenir une matrice)
{=SOMMEPROD((Données!$B$2:$B$5275¢)*(Données!$R$2:$R$5275=9))}

Je fais la même chose, matrice comprise, pour un autre calcul sur la même feuille de calcul, le résultat est 0. Si j'ajoute
la parenthèse comme ci-dessus juste après Sommeprod et avant la toute dernière à droite, j'ai #N/A. Où est l'erreur ?
(F3 = 1) et (J2 = 1)
{=SOMMEPROD($B$2:$B$1944ó)*(Données!$R$2:$R$5275=J2)}

Merci
NewsMic





Publicité
Poster une réponse
Anonyme