sommeprod et #N/A

Le
Misange
Coucou,
je bute sur un truc avec somme prod :
j'ai deux colonnes, l'une (A1:A10) contient des codes numériques, sans
valeurs vides et sans code d'erreur
la seconde (B1:B10) contient des montants calculés. Elle contient soit
des valeurs numériques, soit des #N/A et je ne souhaite pas modifier la
formule qui peut générer ce #N/A.

Comment faire fonctionner =sommeprod((A1:A10@01)*(B1:B10)) ?
J'ai essayé tout plein de trucs en vain, j'appelle donc un formuliste à
l'aide ;-)
merci
--
Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #4804081
Bonjour Misange,

=SOMME(A1:A10*(SI(ESTNA(B1:B10);0;B1:B10)))
Valider avec Maj+ctrl+entrée

JB

On 16 août, 15:01, Misange
Coucou,
je bute sur un truc avec somme prod :
j'ai deux colonnes, l'une (A1:A10) contient des codes numériques, sans
valeurs vides et sans code d'erreur
la seconde (B1:B10) contient des montants calculés. Elle contient soit
des valeurs numériques, soit des #N/A et je ne souhaite pas modifier la
formule qui peut générer ce #N/A.

Comment faire fonctionner =sommeprod((A1:)*(B1:B10)) ?
J'ai essayé tout plein de trucs en vain, j'appelle donc un formuliste à
l'aide ;-)
merci
--
Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !http://xlwiki. free.fr/wikihttp://www.excelabo.net


MichDenis
Le #4804071
Formule matricielle : Adapte la plage de cellule

=SOMME(SI(NON(ESTERREUR(B1:B5));B1:B5)*(A1:))



"Misange"
Coucou,
je bute sur un truc avec somme prod :
j'ai deux colonnes, l'une (A1:A10) contient des codes numériques, sans
valeurs vides et sans code d'erreur
la seconde (B1:B10) contient des montants calculés. Elle contient soit
des valeurs numériques, soit des #N/A et je ne souhaite pas modifier la
formule qui peut générer ce #N/A.

Comment faire fonctionner =sommeprod((A1:)*(B1:B10)) ?
J'ai essayé tout plein de trucs en vain, j'appelle donc un formuliste à
l'aide ;-)
merci
--
Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net
Misange
Le #4804061
Bonjour Jacques
C'est pas tout à fait ça : je dois choisir un critère dans A1:A10 donc
je vais me retrouver avec des somme.si et en réalité, il faut que je
fasse ma somme sur de multiples critères, d'où ma préférence pour
sommeprod.
Je sens que je vais quand même devoir rajouter un critère pour ce fameux
#N/A...

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Bonjour Misange,

=SOMME(A1:A10*(SI(ESTNA(B1:B10);0;B1:B10)))
Valider avec Maj+ctrl+entrée

JB

On 16 août, 15:01, Misange
Coucou,
je bute sur un truc avec somme prod :
j'ai deux colonnes, l'une (A1:A10) contient des codes numériques, sans
valeurs vides et sans code d'erreur
la seconde (B1:B10) contient des montants calculés. Elle contient soit
des valeurs numériques, soit des #N/A et je ne souhaite pas modifier la
formule qui peut générer ce #N/A.

Comment faire fonctionner =sommeprod((A1:)*(B1:B10)) ?
J'ai essayé tout plein de trucs en vain, j'appelle donc un formuliste à
l'aide ;-)
merci
--
Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !http://xlwiki.free.fr/wikihttp://www.excelabo.net






JB
Le #4804051
J'vais mal lu la question:

=SOMME((A1:)*SI(ESTNA(B1:B10);0;B1:B10))
Valider avec Maj+ctrl+entrée

JB

On 16 août, 15:36, Misange
Bonjour Jacques
C'est pas tout à fait ça : je dois choisir un critère dans A1:A10 d onc
je vais me retrouver avec des somme.si et en réalité, il faut que je
fasse ma somme sur de multiples critères, d'où ma préférence pour
sommeprod.
Je sens que je vais quand même devoir rajouter un critère pour ce fam eux
#N/A...

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !http://xlwiki. free.fr/wikihttp://www.excelabo.net




Bonjour Misange,

=SOMME(A1:A10*(SI(ESTNA(B1:B10);0;B1:B10)))
Valider avec Maj+ctrl+entrée

JB

On 16 août, 15:01, Misange
Coucou,
je bute sur un truc avec somme prod :
j'ai deux colonnes, l'une (A1:A10) contient des codes numériques, sa ns
valeurs vides et sans code d'erreur
la seconde (B1:B10) contient des montants calculés. Elle contient so it
des valeurs numériques, soit des #N/A et je ne souhaite pas modifier la
formule qui peut générer ce #N/A.

Comment faire fonctionner =sommeprod((A1:)*(B1:B10)) ?
J'ai essayé tout plein de trucs en vain, j'appelle donc un formulist e à
l'aide ;-)
merci
--
Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !http://xlwi ki.free.fr/wikihttp://www.excelabo.net- Masquer le texte des messages pré cédents -



- Afficher le texte des messages précédents -




Misange
Le #4804031
salut Denis

résultat non conforme à l'espéré ;-(
je vous joins un exemple des données
http://cjoint.com/?iqpZJgoXYw

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Formule matricielle : Adapte la plage de cellule

=SOMME(SI(NON(ESTERREUR(B1:B5));B1:B5)*(A1:))



"Misange"
Coucou,
je bute sur un truc avec somme prod :
j'ai deux colonnes, l'une (A1:A10) contient des codes numériques, sans
valeurs vides et sans code d'erreur
la seconde (B1:B10) contient des montants calculés. Elle contient soit
des valeurs numériques, soit des #N/A et je ne souhaite pas modifier la
formule qui peut générer ce #N/A.

Comment faire fonctionner =sommeprod((A1:)*(B1:B10)) ?
J'ai essayé tout plein de trucs en vain, j'appelle donc un formuliste à
l'aide ;-)
merci


Misange
Le #4804021
on s'approche mais c'est pas encore tout à fait ça :
sur l'exemple joint, avec la plage A1:A49P04, je récupère un #valeur

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

J'vais mal lu la question:

=SOMME((A1:)*SI(ESTNA(B1:B10);0;B1:B10))
Valider avec Maj+ctrl+entrée

JB

On 16 août, 15:36, Misange
Bonjour Jacques
C'est pas tout à fait ça : je dois choisir un critère dans A1:A10 donc
je vais me retrouver avec des somme.si et en réalité, il faut que je
fasse ma somme sur de multiples critères, d'où ma préférence pour
sommeprod.
Je sens que je vais quand même devoir rajouter un critère pour ce fameux
#N/A...

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !http://xlwiki.free.fr/wikihttp://www.excelabo.net




Bonjour Misange,
=SOMME(A1:A10*(SI(ESTNA(B1:B10);0;B1:B10)))
Valider avec Maj+ctrl+entrée
JB
On 16 août, 15:01, Misange
Coucou,
je bute sur un truc avec somme prod :
j'ai deux colonnes, l'une (A1:A10) contient des codes numériques, sans
valeurs vides et sans code d'erreur
la seconde (B1:B10) contient des montants calculés. Elle contient soit
des valeurs numériques, soit des #N/A et je ne souhaite pas modifier la
formule qui peut générer ce #N/A.
Comment faire fonctionner =sommeprod((A1:)*(B1:B10)) ?
J'ai essayé tout plein de trucs en vain, j'appelle donc un formuliste à
l'aide ;-)
merci
--
Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !http://xlwiki.free.fr/wikihttp://www.excelabo.net- Masquer le texte des messages précédents -
- Afficher le texte des messages précédents -










JB
Le #4804001
http://cjoint.com/?iqqhVH2oss

JB

On 16 août, 15:52, Misange
salut Denis

résultat non conforme à l'espéré ;-(
je vous joins un exemple des données
http://cjoint.com/?iqpZJgoXYw

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !http://xlwiki. free.fr/wikihttp://www.excelabo.net




Formule matricielle : Adapte la plage de cellule

=SOMME(SI(NON(ESTERREUR(B1:B5));B1:B5)*(A1:))

"Misange"
Coucou,
je bute sur un truc avec somme prod :
j'ai deux colonnes, l'une (A1:A10) contient des codes numériques, sans
valeurs vides et sans code d'erreur
la seconde (B1:B10) contient des montants calculés. Elle contient soit
des valeurs numériques, soit des #N/A et je ne souhaite pas modifier la
formule qui peut générer ce #N/A.

Comment faire fonctionner =sommeprod((A1:)*(B1:B10)) ?
J'ai essayé tout plein de trucs en vain, j'appelle donc un formuliste à
l'aide ;-)
merci- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



MichDenis
Le #4803991
Un fichier exemple de la formule expédiée :

http://cjoint.com/?iqqkKSBN3d




"Misange"
salut Denis

résultat non conforme à l'espéré ;-(
je vous joins un exemple des données
http://cjoint.com/?iqpZJgoXYw

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Formule matricielle : Adapte la plage de cellule

=SOMME(SI(NON(ESTERREUR(B1:B5));B1:B5)*(A1:))



"Misange"
Coucou,
je bute sur un truc avec somme prod :
j'ai deux colonnes, l'une (A1:A10) contient des codes numériques, sans
valeurs vides et sans code d'erreur
la seconde (B1:B10) contient des montants calculés. Elle contient soit
des valeurs numériques, soit des #N/A et je ne souhaite pas modifier la
formule qui peut générer ce #N/A.

Comment faire fonctionner =sommeprod((A1:)*(B1:B10)) ?
J'ai essayé tout plein de trucs en vain, j'appelle donc un formuliste à
l'aide ;-)
merci


JB
Le #4803971
Sur ton fichier, les données commencent en ligne 2.

http://cjoint.com/?iqqmCd3kCN

=SOMME((codeP04)*SI(ESTNA(montant);0;montant))

code þuil1!$A$2:$A$49
montant þuil1!$B$2:$B$49


JB
On 16 août, 15:57, Misange
on s'approche mais c'est pas encore tout à fait ça :
sur l'exemple joint, avec la plage A1:A49P04, je récupère un #val eur

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !http://xlwiki. free.fr/wikihttp://www.excelabo.net




J'vais mal lu la question:

=SOMME((A1:)*SI(ESTNA(B1:B10);0;B1:B10))
Valider avec Maj+ctrl+entrée

JB

On 16 août, 15:36, Misange
Bonjour Jacques
C'est pas tout à fait ça : je dois choisir un critère dans A1:A1 0 donc
je vais me retrouver avec des somme.si et en réalité, il faut que je
fasse ma somme sur de multiples critères, d'où ma préférence p our
sommeprod.
Je sens que je vais quand même devoir rajouter un critère pour ce fameux
#N/A...

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !http://xlwi ki.free.fr/wikihttp://www.excelabo.net




Bonjour Misange,
=SOMME(A1:A10*(SI(ESTNA(B1:B10);0;B1:B10)))
Valider avec Maj+ctrl+entrée
JB
On 16 août, 15:01, Misange
Coucou,
je bute sur un truc avec somme prod :
j'ai deux colonnes, l'une (A1:A10) contient des codes numériques, sans
valeurs vides et sans code d'erreur
la seconde (B1:B10) contient des montants calculés. Elle contient soit
des valeurs numériques, soit des #N/A et je ne souhaite pas modifi er la
formule qui peut générer ce #N/A.
Comment faire fonctionner =sommeprod((A1:)*(B1:B10)) ?
J'ai essayé tout plein de trucs en vain, j'appelle donc un formuli ste à
l'aide ;-)
merci
--
Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !http://xl wiki.free.fr/wikihttp://www.excelabo.net-Masquer le texte des messages pr écédents -
- Afficher le texte des messages précédents -- Masquer le texte de s messages précédents -





- Afficher le texte des messages précédents -






Misange
Le #4803961
merdum comme dirait jps, j'ai du glisser sur les touches alors ;-)
ca fonctionne comme il faut.
Denis et toi, vous me confirmez qu'on ne peut pas via sommeprod gérer
des #N/A ? C'est emmousaillant ça... mais on fera avec. Un truc à
ajouter sur XlWiki ...
Merci à vous deux de votre aide (on se sent moins seule, un 16 aout, y a
pas foule !)

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

http://cjoint.com/?iqqhVH2oss

JB

On 16 août, 15:52, Misange
salut Denis

résultat non conforme à l'espéré ;-(
je vous joins un exemple des données
http://cjoint.com/?iqpZJgoXYw

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !http://xlwiki.free.fr/wikihttp://www.excelabo.net




Formule matricielle : Adapte la plage de cellule
=SOMME(SI(NON(ESTERREUR(B1:B5));B1:B5)*(A1:))
"Misange"
Coucou,
je bute sur un truc avec somme prod :
j'ai deux colonnes, l'une (A1:A10) contient des codes numériques, sans
valeurs vides et sans code d'erreur
la seconde (B1:B10) contient des montants calculés. Elle contient soit
des valeurs numériques, soit des #N/A et je ne souhaite pas modifier la
formule qui peut générer ce #N/A.
Comment faire fonctionner =sommeprod((A1:)*(B1:B10)) ?
J'ai essayé tout plein de trucs en vain, j'appelle donc un formuliste à
l'aide ;-)
merci- Masquer le texte des messages précédents -
- Afficher le texte des messages précédents -








Publicité
Poster une réponse
Anonyme