SommeProd et OU

Le
Michel69
Bonjour à toutes et à tous,
Comment faire un SommeProd avec un OU. J'ai essayé avec le + mais les
résultas restent aléatoires.
Voilà ma formule
=SOMMEPROD((BDD!$AE$3:$AE$2000=B$3)*(BDD!$G$3:$G$2000=$A39)*((BDD!AD$3:$AD$2000<>"")+(BDD!$AI$3:$AI$2000<>"")))
En fait je vérifie si dans AE et G, j'ai le bon critère, si oui, il faut que
AD OU AE (mais pas les deux) soient différentes de vides.
Merci d'avance
Michel
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Modeste
Le #17556301
Bonsour® Michel69 avec ferveur ;o))) vous nous disiez :

Comment faire un SommeProd avec un OU. J'ai essayé avec le + mais les
résultas restent aléatoires.
Voilà ma formule :
=SOMMEPROD((BDD!$AE$3:$AE$2000=B$3)*(BDD!$G$3:$G$2000=$A39)*((BDD!A D$3:$AD$2000<>"")+(BDD!$AI$3:$AI$2000<>"")))
En fait je vérifie si dans AE et G, j'ai le bon critère, si oui, il
faut que AD OU AE (mais pas les deux) soient différentes de vides.




http://xlwiki.free.fr/wiki/wakka.php?wiki=SommeProd



--
--
@+
;o)))
Daniel.C
Le #17556501
Bonjour.
Ca a l'air correct. Peux-tu poster un exemple de dysfonctionnement ?
--
Cordialement.
Daniel
"Michel69" news:
Bonjour à toutes et à tous,
Comment faire un SommeProd avec un OU. J'ai essayé avec le + mais les
résultas restent aléatoires.
Voilà ma formule :
=SOMMEPROD((BDD!$AE$3:$AE$2000=B$3)*(BDD!$G$3:$G$2000=$A39)*((BDD!AD$3:$AD$2000<>"")+(BDD!$AI$3:$AI$2000<>"")))
En fait je vérifie si dans AE et G, j'ai le bon critère, si oui, il faut
que
AD OU AE (mais pas les deux) soient différentes de vides.
Merci d'avance
Michel


michdenis
Le #17556491
Un exemple :

=SOMMEPROD((A1:A5±)*((C1:C5<>"")+(D1:D5<>"")>0))

Dénombre le nombre de fois que A1:A5±
si : soit C1:C5 ou D1:D5 contient au moins une valeur





"Michel69" news:
Bonjour à toutes et à tous,
Comment faire un SommeProd avec un OU. J'ai essayé avec le + mais les
résultas restent aléatoires.
Voilà ma formule :
=SOMMEPROD((BDD!$AE$3:$AE$2000=B$3)*(BDD!$G$3:$G$2000=$A39)*((BDD!AD$3:$AD$2000<>"")+(BDD!$AI$3:$AI$2000<>"")))
En fait je vérifie si dans AE et G, j'ai le bon critère, si oui, il faut que
AD OU AE (mais pas les deux) soient différentes de vides.
Merci d'avance
Michel
Sam
Le #17556751
Bonjour,
la condition :
il faut que AD OU AE soient l'une ou l'autre différentes de vides mais pas
les deux en même temps
est elle entièrement à vérifier ?
car du coup on se retrouve avec un OU exclusif

Cordialement
Michel dit "Sam"

"Michel69" news:
Bonjour à toutes et à tous,
Comment faire un SommeProd avec un OU. J'ai essayé avec le + mais les
résultas restent aléatoires.
Voilà ma formule :
=SOMMEPROD((BDD!$AE$3:$AE$2000=B$3)*(BDD!$G$3:$G$2000=$A39)*((BDD!AD$3:$AD$2000<>"")+(BDD!$AI$3:$AI$2000<>"")))
En fait je vérifie si dans AE et G, j'ai le bon critère, si oui, il faut
que
AD OU AE (mais pas les deux) soient différentes de vides.
Merci d'avance
Michel


Sam
Le #17557011
et si tu réponds oui, la formule serait :
=SOMMEPROD((BDD!$AE$3:$AE$2000=B$3)*(BDD!$G$3:$G$2000=$A39)*(((BDD!AD$3:$AD$2000<>"")*(BDD!$AI$3:$AI$2000="")+(BDD!AD$3:$AD$2000="")*(BDD!$AI$3:$AI$2000<>"")))

Cordialement
Michel dit "Sam"

"Sam" 48f874f9$0$890$

Bonjour,
la condition :
il faut que AD OU AE soient l'une ou l'autre différentes de vides mais pas
les deux en même temps
est elle entièrement à vérifier ?
car du coup on se retrouve avec un OU exclusif

Cordialement
Michel dit "Sam"

"Michel69" news:
Bonjour à toutes et à tous,
Comment faire un SommeProd avec un OU. J'ai essayé avec le + mais les
résultas restent aléatoires.
Voilà ma formule :
=SOMMEPROD((BDD!$AE$3:$AE$2000=B$3)*(BDD!$G$3:$G$2000=$A39)*((BDD!AD$3:$AD$2000<>"")+(BDD!$AI$3:$AI$2000<>"")))
En fait je vérifie si dans AE et G, j'ai le bon critère, si oui, il faut
que
AD OU AE (mais pas les deux) soient différentes de vides.
Merci d'avance
Michel






Publicité
Poster une réponse
Anonyme