Sommeprod et joker*

Le
Lionel M
Bonjour

Sur mes lignes entre colonnes B jsq AF j'ai des codes ce type Mld6 avec un =
final qui peut aller de 0 (qui vaut pour mon cas 10) à 9 et j'aimerais=
faire l'addition du chiffre final avec sommeprod mais apparamment le joker=
n'est pas reconnu dans la formule
Quelqu'un aurait il une idée lumineuse pour m'aider ???

Merci a tous de votre aide

Lionel
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
LSteph
Le #26407132
Bonjour,
Sib2 contient Mld6
=cnum(droite(b2;1))
renverra 6 en nombre.
Cordialement.
--
LSteph
Lionel M
Le #26407134
Le samedi 13 août 2016 08:47:19 UTC+2, LSteph a écrit :
Bonjour,
Sib2 contient Mld6
=cnum(droite(b2;1))
renverra 6 en nombre.
Cordialement.
--
LSteph

Salut
Merci mais le but est de faire le total entre les colonnes B et AF .
Par exemple si j'ai Mld6 entre b et et q puis Mld0 (qui vaut 10) entre r et af je devrais obtenir 246 en resultat...
Merci
LSteph
Le #26407136
Re,
loupé le 0 qui vaut 10 (nota ce serait bien plus simple avec mld01 à   mld10)
donc pour le cas présent en supposant que le préfixe soit toujour s bien "mld",
à valider en matricielle:
=SOMME(CHOISIR(EQUIV(TRANSPOSE($B$1:$af$1);{"mld0";"mld1";"mld2";"mld3";" mld4";"mld5";"mld6";"mld7";"mld8";"mld9"};0);10;1;2;3;4;5;6;7;8;9))
....
Le samedi 13 août 2016 09:01:52 UTC+2, Lionel M a écrit :
Le samedi 13 août 2016 08:47:19 UTC+2, LSteph a écrit :
Bonjour,

Sib2 contient Mld6
=cnum(droite(b2;1))
renverra 6 en nombre.
Cordialement.
--
LSteph

Salut
Merci mais le but est de faire le total entre les colonnes B et AF .
Par exemple si j'ai Mld6 entre b et et q puis Mld0 (qui vaut 10) entre r et af je devrais obtenir 246 en resultat...
Merci
LSteph
Le #26407139
ou plus simple, j'étais bien parti:
toujours en supermatricielle: ctrl+maj+Entrée
=SOMME(CHOISIR(CNUM(DROITE($B$1:$af$1;1))+1;10;1;2;3;4;5;6;7;8;9))
--
LSteph
Lionel M
Le #26407141
Le samedi 13 août 2016 10:01:44 UTC+2, LSteph a écrit :
ou plus simple, j'étais bien parti:
toujours en supermatricielle: ctrl+maj+Entrée
=SOMME(CHOISIR(CNUM(DROITE($B$1:$af$1;1))+1;10;1;2;3;4;5;6;7;8;9))
--
LSteph

Re,
Merci de te decarcasser mais le probleme reste que cela doit prendre en com pte le code Mld car si je mets J108 ca va additionner alors qu'il ne faut p as...la "condition" de l'addition est le code Mld...
Désolé de ne pas avoir été suffisamment clair avant ...
Par ailleurs ton code me renvoie une erreur #N/A
Cordialement
Lionel
DanielCo
Le #26407149
Le samedi 13 août 2016 10:01:44 UTC+2, LSteph a écrit :
ou plus simple, j'étais bien parti:
toujours en supermatricielle: ctrl+maj+Entrée
=SOMME(CHOISIR(CNUM(DROITE($B$1:$af$1;1))+1;10;1;2;3;4;5;6;7;8;9))
--
LSteph

Re,
Merci de te decarcasser mais le probleme reste que cela doit prendre
en compte le code Mld car si je mets J108 ca va additionner alors
qu'il ne faut pas...la "condition" de l'addition est le code Mld...
Désolé de ne pas avoir été suffisamment clair avant ... Par ailleurs
ton code me renvoie une erreur #N/A
Cordialement
Lionel

Bonjour,
Matricielle :
=SOMME(SI(GAUCHE($A$1:$AF$1;3)="mld";CNUM(SI(DROITE($A$1:$AF$1;1)=0;10;DROITE($A$1:$AF$1;1)))))
Cordialement.
Daniel
DanielCo
Le #26407148
Le samedi 13 août 2016 10:01:44 UTC+2, LSteph a écrit :
ou plus simple, j'étais bien parti:
toujours en supermatricielle: ctrl+maj+Entrée
=SOMME(CHOISIR(CNUM(DROITE($B$1:$af$1;1))+1;10;1;2;3;4;5;6;7;8;9))
--
LSteph

Re,
Merci de te decarcasser mais le probleme reste que cela doit
prendre en compte le code Mld car si je mets J108 ca va additionner
alors qu'il ne faut pas...la "condition" de l'addition est le code
Mld... Désolé de ne pas avoir été suffisamment clair avant ... Par
ailleurs ton code me renvoie une erreur #N/A
Cordialement
Lionel

Bonjour,
Matricielle :
=SOMME(SI(GAUCHE($A$1:$AF$1;3)="mld";CNUM(SI(DROITE($A$1:$AF$1;1)=0;10;DROITE($A$1:$AF$1;1)))))
Cordialement.
Daniel

Oups, au temps pour moi. Ne tiens pas compte de la réponse précédente.
Daniel
DanielCo
Le #26407147
Le samedi 13 août 2016 10:01:44 UTC+2, LSteph a écrit :
ou plus simple, j'étais bien parti:
toujours en supermatricielle: ctrl+maj+Entrée
=SOMME(CHOISIR(CNUM(DROITE($B$1:$af$1;1))+1;10;1;2;3;4;5;6;7;8;9))
--
LSteph

Re,
Merci de te decarcasser mais le probleme reste que cela doit
prendre en compte le code Mld car si je mets J108 ca va additionner
alors qu'il ne faut pas...la "condition" de l'addition est le code
Mld... Désolé de ne pas avoir été suffisamment clair avant ... Par
ailleurs ton code me renvoie une erreur #N/A
Cordialement
Lionel

Bonjour,
Matricielle :
=SOMME(SI(GAUCHE($A$1:$AF$1;3)="mld";CNUM(SI(DROITE($A$1:$AF$1;1)=0;10;DROITE($A$1:$AF$1;1)))))
Cordialement.
Daniel

Plutôt :
=SOMME(SI(GAUCHE($A$1:$AF$1;3)="mld";CNUM(SI(DROITE($A$1:$AF$1;1)="0";10;DROITE($A$1:$AF$1;1)))))
Daniel
LSteph
Le #26407150
=SOMME(SI(GAUCHE($B1:$AF1;3)="mld";CHOISIR(CNUM(DROITE($B1:$AF1;1))+1;1 0;1;2;3;4;5;6;7;8;9));0)
en matricielle ctrl+maj+entrée et à entrer dans une seule cellule .
après tu pourra recopier vers bas si plusieurs lignes;

Merci de te decarcasser mais le probleme reste que cela doit prendre en c ompte le code Mld car si je mets J108 ca va additionner alors qu'il ne faut pas...la "condition" de l'addition est le code Mld...
Désolé de ne pas avoir été suffisamment clair avant . ..
Par ailleurs ton code me renvoie une erreur #N/A
Cordialement
Lionel
Lionel M
Le #26407164
Le samedi 13 août 2016 11:14:13 UTC+2, DanielCo a écrit :
Le samedi 13 août 2016 10:01:44 UTC+2, LSteph a écrit :
ou plus simple, j'étais bien parti:
toujours en supermatricielle: ctrl+maj+Entrée
=SOMME(CHOISIR(CNUM(DROITE($B$1:$af$1;1))+1;10;1;2;3;4;5;6;7;8;9))
--
LSteph

Re,
Merci de te decarcasser mais le probleme reste que cela doit
prendre en compte le code Mld car si je mets J108 ca va additionner
alors qu'il ne faut pas...la "condition" de l'addition est le code
Mld... Désolé de ne pas avoir été suffisamment cla ir avant ... Par
ailleurs ton code me renvoie une erreur #N/A
Cordialement
Lionel

Bonjour,
Matricielle :
=SOMME(SI(GAUCHE($A$1:$AF$1;3)="mld";CNUM(SI(DROITE($A$1:$AF$1;1) =0;10;DROITE($A$1:$AF$1;1)))))
Cordialement.
Daniel

Plutôt :
=SOMME(SI(GAUCHE($A$1:$AF$1;3)="mld";CNUM(SI(DROITE($A$1:$AF$1;1)=" 0";10;DROITE($A$1:$AF$1;1)))))
Daniel

Merci Daniel ca fonctionne et ca resoud mon probleme !!!
Publicité
Poster une réponse
Anonyme