SOMMEPROD((JOURSEM(B30:H30)=1)*(B35:H35>0))

Le
Patrick
Bonsoir,
J'ai cette partie de formule pour compter les dimanches qui fonctionne très
bien merci à Daniel.C :
SOMMEPROD((JOURSEM(B30:H30)=1)*(B35:H35>0))
Il faudrait que j'ajoute une condition au niveau de B30:H30 parce que
suivant les mois et les années les cellules
B30 E30 H30 sont vides E30 =SI(MOIS(N1+29)<>MOIS(N1);"";N1+29) et d'autre
fois sont avec le format date .
Je n'arrive pas à dire :
compte les cellules seulement avec la date et laisse les cellules vides ?

Merci
Bonne soirée.
Patrick.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #5427791
Bonsoir,

Avec le fichier, ce serait +facile:

=SOMMEPROD((JOURSEM(B30:H30)=1)*(B30:H30<>"")*(B35:H35>0)) ?

JB

On 31 mar, 20:50, "Patrick"
Bonsoir,
J'ai cette partie de formule  pour compter les dimanches qui fonctionne très
bien  merci à Daniel.C :
SOMMEPROD((JOURSEM(B30:H30)=1)*(B35:H35>0))
Il faudrait que j'ajoute une condition au niveau de B30:H30 parce que
suivant les mois et les années les cellules
B30 E30 H30  sont vides E30 =SI(MOIS(N1+29)<>MOIS(N1);"";N1+29) et d'a utre
fois sont avec le format date .
Je n'arrive pas à dire :
compte les cellules seulement avec la date et laisse les cellules vides ?

Merci
Bonne soirée.
Patrick.


Patrick
Le #5427581
Bonjour,
Voilà une feuille :
http://cjoint.com/?ebi0Xa1QAA
Si vous voulez ajouter des motifs hésiter pas.
Bonne matinée.
Patrick.

"JB"
Bonsoir,

Avec le fichier, ce serait +facile:

=SOMMEPROD((JOURSEM(B30:H30)=1)*(B30:H30<>"")*(B35:H35>0)) ?

JB

On 31 mar, 20:50, "Patrick"
Bonsoir,
J'ai cette partie de formule pour compter les dimanches qui fonctionne
très
bien merci à Daniel.C :
SOMMEPROD((JOURSEM(B30:H30)=1)*(B35:H35>0))
Il faudrait que j'ajoute une condition au niveau de B30:H30 parce que
suivant les mois et les années les cellules
B30 E30 H30 sont vides E30 =SI(MOIS(N1+29)<>MOIS(N1);"";N1+29) et d'autre
fois sont avec le format date .
Je n'arrive pas à dire :
compte les cellules seulement avec la date et laisse les cellules vides ?

Merci
Bonne soirée.
Patrick.


JB
Le #5427511
Bonjour,

=SOMME(SI(B30:H30<>"";(JOURSEM(B30:H30)=1)*(B35:H35>0)))
valider avec maj+ctrl+entrée

PS: les cellules fusionnées, c'est pas recommandé pour les formules
matricielles.

JB


On 1 avr, 09:00, "Patrick"
Bonjour,
Voilà une feuille :http://cjoint.com/?ebi0Xa1QAA
Si vous voulez ajouter des motifs hésiter pas.
Bonne matinée.
Patrick.

"JB"
Bonsoir,

Avec le fichier, ce serait +facile:

=SOMMEPROD((JOURSEM(B30:H30)=1)*(B30:H30<>"")*(B35:H35>0)) ?

JB

On 31 mar, 20:50, "Patrick"


Bonsoir,
J'ai cette partie de formule pour compter les dimanches qui fonctionne
très
bien merci à Daniel.C :
SOMMEPROD((JOURSEM(B30:H30)=1)*(B35:H35>0))
Il faudrait que j'ajoute une condition au niveau de B30:H30 parce que
suivant les mois et les années les cellules
B30 E30 H30 sont vides E30 =SI(MOIS(N1+29)<>MOIS(N1);"";N1+29) et d'au tre
fois sont avec le format date .
Je n'arrive pas à dire :
compte les cellules seulement avec la date et laisse les cellules vides ?

Merci
Bonne soirée.
Patrick.- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



Patrick
Le #5426681
Bonjour,
si j'ai bien compris:
=SOMMEPROD((JOURSEM(B23:V23)=1)*(B28:V28>0)) égale {=
SOMME((JOURSEM(B23:V23)=1)*(B28:V28>0))}
Merci pour la réponse et pour le conseil.
Bonne journée.
Patrick.


"JB"
Bonjour,

=SOMME(SI(B30:H30<>"";(JOURSEM(B30:H30)=1)*(B35:H35>0)))
valider avec maj+ctrl+entrée

PS: les cellules fusionnées, c'est pas recommandé pour les formules
matricielles.

JB


On 1 avr, 09:00, "Patrick"
Bonjour,
Voilà une feuille :http://cjoint.com/?ebi0Xa1QAA
Si vous voulez ajouter des motifs hésiter pas.
Bonne matinée.
Patrick.

"JB"
Bonsoir,

Avec le fichier, ce serait +facile:

=SOMMEPROD((JOURSEM(B30:H30)=1)*(B30:H30<>"")*(B35:H35>0)) ?

JB

On 31 mar, 20:50, "Patrick"


Bonsoir,
J'ai cette partie de formule pour compter les dimanches qui fonctionne
très
bien merci à Daniel.C :
SOMMEPROD((JOURSEM(B30:H30)=1)*(B35:H35>0))
Il faudrait que j'ajoute une condition au niveau de B30:H30 parce que
suivant les mois et les années les cellules
B30 E30 H30 sont vides E30 =SI(MOIS(N1+29)<>MOIS(N1);"";N1+29) et
d'autre
fois sont avec le format date .
Je n'arrive pas à dire :
compte les cellules seulement avec la date et laisse les cellules vides
?

Merci
Bonne soirée.
Patrick.- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



Publicité
Poster une réponse
Anonyme