Sommeprod multi criteres

Le
Manu
Bonjour,

Je souhaite faire une sommeprod pour compter le nombre de "CP" avec
plusieurs criteres qui sont aussi bien horizontal que vertical mais je ne
sais pas si sommprod peut faire cela,

Exemple :
J'ai de B11 à B376 toutes les dates d'une année
critere :
AA13 : debut d'une date
AA14 : fin d'une date

J'ai de C10 à R10 des noms
critere :
AA12 : un des noms

Je souhaite par consequent connaitre le nombre de CP qu'il y a dans la plage
C11:R376 en fonction des critres demandés en AA12 ; AA13 ; AA14

J'ai tenté cela :
=SOMMEPROD(1*($C$10:$R$10=$AA$12);1*($B$11:$B$376>=$AA$13);1*($B$11:$B$376<ª14);1*($C$11:$R$376="CP");($C$11:$R$376))

Mais il me revoie une erreur de valeur, est ce que c'est ma fonction qui
n'est pas bien choisie.

Merci

Manu
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
FdeCourt
Le #20798271
Salut,

A quoi sert le dernier argument ($C$11:$R$376)
Cette plage doit contenir du texte, dont faire une somme dessus ne
peut pas fonctionner.
En enlevant cette dernière condition, la formule doit fonctionner.

Poste ton classeur sur www.cjoint.com

Cordialement,

F.
Manu
Le #20798551
En fait tous les CP et autres... se trouvent dans cette plage,
Voir ci-joint :
http://www.cijoint.fr/cjlink.php?file=cj200912/cijl1Huqco.xls


"FdeCourt"
Salut,

A quoi sert le dernier argument ($C$11:$R$376)
Cette plage doit contenir du texte, dont faire une somme dessus ne
peut pas fonctionner.
En enlevant cette dernière condition, la formule doit fonctionner.

Poste ton classeur sur www.cjoint.com

Cordialement,

F.
Corona
Le #20799081
Bonjour Manu,
=SOMMEPROD( ($C$11:$R$376=$Z19) * ($B$11:$B$376>=$AA$13) *
($B$11:$B$376<=$AA$14) )
Philippe Tulliez
Manu a écrit :
Bonjour,

Je souhaite faire une sommeprod pour compter le nombre de "CP" avec
plusieurs criteres qui sont aussi bien horizontal que vertical mais je ne
sais pas si sommprod peut faire cela,

Exemple :
J'ai de B11 à B376 toutes les dates d'une année
critere :
AA13 : debut d'une date
AA14 : fin d'une date

J'ai de C10 à R10 des noms
critere :
AA12 : un des noms

Je souhaite par consequent connaitre le nombre de CP qu'il y a dans la plage
C11:R376 en fonction des critres demandés en AA12 ; AA13 ; AA14

J'ai tenté cela :
=SOMMEPROD(1*($C$10:$R$10=$AA$12);1*($B$11:$B$376>=$AA$13);1*($B$11:$B$376<ª14);1*($C$11:$R$376="CP");($C$11:$R$376))

Mais il me revoie une erreur de valeur, est ce que c'est ma fonction qui
n'est pas bien choisie.

Merci

Manu




Corona
Le #20799071
Désolé, je n'avais pas vu qu'il fallait aussi tester avec le nom de la
personne.
Correction du post précédent.
=SOMMEPROD( ($C$11:$R$376=$Z19) * ($B$11:$B$376>=$AA$13) *
($B$11:$B$376<=$AA$14) * ($AA$12 = $C$10:$R$10) )
Le fichier corrigé à l'adresse
http://www.cijoint.fr/cjlink.php?file=cj200912/cijda66Hzj.xls
Philippe

Manu a écrit :
Bonjour,

Je souhaite faire une sommeprod pour compter le nombre de "CP" avec
plusieurs criteres qui sont aussi bien horizontal que vertical mais je ne
sais pas si sommprod peut faire cela,

Exemple :
J'ai de B11 à B376 toutes les dates d'une année
critere :
AA13 : debut d'une date
AA14 : fin d'une date

J'ai de C10 à R10 des noms
critere :
AA12 : un des noms

Je souhaite par consequent connaitre le nombre de CP qu'il y a dans la plage
C11:R376 en fonction des critres demandés en AA12 ; AA13 ; AA14

J'ai tenté cela :
=SOMMEPROD(1*($C$10:$R$10=$AA$12);1*($B$11:$B$376>=$AA$13);1*($B$11:$B$376<ª14);1*($C$11:$R$376="CP");($C$11:$R$376))

Mais il me revoie une erreur de valeur, est ce que c'est ma fonction qui
n'est pas bien choisie.

Merci

Manu




Caetera
Le #20799311
"Manu"

Très mauvaise organisation des données....
Une seule feuille avec les dates en lignes et les noms d'employés en colonne !
Toutes les autres analyses, excel sait faire avec notamment les tcd (groupement
des dates par mois) !

Etc
Manu
Le #20799511
Merci Corona, Ca fonctionne impec.

Caetera, en fait, j'essais suite à ton conseil precedent de trouver une
parade en reorganisant toutes mes feuil pour arriver à faire toutes les
formules que je souhaite faire, cette feuil me permet de recapituler toutes
les feuil mois en une seule pour me simplifier les formules. J'ai encore bcp
de boulot dessus.

Merci

Manu

"Corona"
Désolé, je n'avais pas vu qu'il fallait aussi tester avec le nom de la
personne.
Correction du post précédent.
=SOMMEPROD( ($C$11:$R$376=$Z19) * ($B$11:$B$376>=$AA$13) *
($B$11:$B$376<=$AA$14) * ($AA$12 = $C$10:$R$10) )
Le fichier corrigé à l'adresse
http://www.cijoint.fr/cjlink.php?file=cj200912/cijda66Hzj.xls
Philippe

Manu a écrit :
Bonjour,

Je souhaite faire une sommeprod pour compter le nombre de "CP" avec
plusieurs criteres qui sont aussi bien horizontal que vertical mais je ne
sais pas si sommprod peut faire cela,

Exemple :
J'ai de B11 à B376 toutes les dates d'une année
critere :
AA13 : debut d'une date
AA14 : fin d'une date

J'ai de C10 à R10 des noms
critere :
AA12 : un des noms

Je souhaite par consequent connaitre le nombre de CP qu'il y a dans la
plage C11:R376 en fonction des critres demandés en AA12 ; AA13 ; AA14

J'ai tenté cela :
=SOMMEPROD(1*($C$10:$R$10=$AA$12);1*($B$11:$B$376>=$AA$13);1*($B$11:$B$376<ª14);1*($C$11:$R$376="CP");($C$11:$R$376))

Mais il me revoie une erreur de valeur, est ce que c'est ma fonction qui
n'est pas bien choisie.

Merci

Manu




Publicité
Poster une réponse
Anonyme