Sommeprod nbjourouvré...

Le
Manu
Bonjour,

J'ai en colonne A le calendrier d'une année complete

A
01/01/2010
02/01/2010
03/01/2010

Et cela jusqu'a la fin de l'année

en colonne B j'ai toute sorte de texte

Je souhaite compter le nombre de cellule remplie en colonne B qui tombe soit
un samedi, dimanche ainsi que jours feriés

J'ai deja nommé mes jours feriés et fait
NB.JOURS.OUVRES($A$2;$A$370;JOURS_feries) et maintenant je me bat avec le
sommeprod, mais je bloque

Merci pour votre aide.

Manu
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #21478901
Bonjour.
Avec une plage de jours chômés en G1:G100 :
=SOMMEPROD((B1:B365<>"")*((JOURSEM(A1:A365;2)>5)+ESTNUM(EQUIV(A1:A365;G1:G100;0))))
Cordialement.
Daniel

Bonjour,

J'ai en colonne A le calendrier d'une année complete

A
01/01/2010
02/01/2010
03/01/2010

Et cela jusqu'a la fin de l'année

en colonne B j'ai toute sorte de texte

Je souhaite compter le nombre de cellule remplie en colonne B qui tombe soit
un samedi, dimanche ainsi que jours feriés

J'ai deja nommé mes jours feriés et fait
NB.JOURS.OUVRES($A$2;$A$370;JOURS_feries) et maintenant je me bat avec le
sommeprod, mais je bloque

Merci pour votre aide.

Manu
Manu
Le #21479031
Super Daniel, merci, je cherchais completement ailleurs.

Merci encore

Manu

"Daniel.C" %
Bonjour.
Avec une plage de jours chômés en G1:G100 :
=SOMMEPROD((B1:B365<>"")*((JOURSEM(A1:A365;2)>5)+ESTNUM(EQUIV(A1:A365;G1:G100;0))))
Cordialement.
Daniel

Bonjour,

J'ai en colonne A le calendrier d'une année complete

A
01/01/2010
02/01/2010
03/01/2010

Et cela jusqu'a la fin de l'année

en colonne B j'ai toute sorte de texte

Je souhaite compter le nombre de cellule remplie en colonne B qui tombe
soit un samedi, dimanche ainsi que jours feriés

J'ai deja nommé mes jours feriés et fait
NB.JOURS.OUVRES($A$2;$A$370;JOURS_feries) et maintenant je me bat avec le
sommeprod, mais je bloque

Merci pour votre aide.

Manu




Manu
Le #21479171
J'ai tout de meme un soucis, la plage des dates est variable ca peut etre
jusqu'en A365 ou si on on est en bissextile en A366 et j'ai remarqué que si
j'utilise ta formule jusqu'à A366, ca ne fonctionne plus.

En A366, j'ai une formule qui mette rien si on est en année normal, sinon
qu'il me rajoute un jour, mes dates fonctionne bien, mais ce ne plait pas à
la formule si je prend cette cellule supplémentaire qui est pourtant
importante, il y a t'il une solution ?

Merci

Manu

"Manu" %
Super Daniel, merci, je cherchais completement ailleurs.

Merci encore

Manu

"Daniel.C" %
Bonjour.
Avec une plage de jours chômés en G1:G100 :
=SOMMEPROD((B1:B365<>"")*((JOURSEM(A1:A365;2)>5)+ESTNUM(EQUIV(A1:A365;G1:G100;0))))
Cordialement.
Daniel

Bonjour,

J'ai en colonne A le calendrier d'une année complete

A
01/01/2010
02/01/2010
03/01/2010

Et cela jusqu'a la fin de l'année

en colonne B j'ai toute sorte de texte

Je souhaite compter le nombre de cellule remplie en colonne B qui tombe
soit un samedi, dimanche ainsi que jours feriés

J'ai deja nommé mes jours feriés et fait
NB.JOURS.OUVRES($A$2;$A$370;JOURS_feries) et maintenant je me bat avec
le sommeprod, mais je bloque

Merci pour votre aide.

Manu








Daniel.C
Le #21479161
=SOMMEPROD((B1:B366<>"")*((JOURSEM(A1:A366;2)>5)+ESTNUM(EQUIV(A1:A366;G1:G100;0))))
Ca fonctionne chez moi ?
Daniel

J'ai tout de meme un soucis, la plage des dates est variable ca peut etre
jusqu'en A365 ou si on on est en bissextile en A366 et j'ai remarqué que si
j'utilise ta formule jusqu'à A366, ca ne fonctionne plus.

En A366, j'ai une formule qui mette rien si on est en année normal, sinon
qu'il me rajoute un jour, mes dates fonctionne bien, mais ce ne plait pas à
la formule si je prend cette cellule supplémentaire qui est pourtant
importante, il y a t'il une solution ?

Merci

Manu

"Manu" %
Super Daniel, merci, je cherchais completement ailleurs.

Merci encore

Manu

"Daniel.C" %
Bonjour.
Avec une plage de jours chômés en G1:G100 :
=SOMMEPROD((B1:B365<>"")*((JOURSEM(A1:A365;2)>5)+ESTNUM(EQUIV(A1:A365;G1:G100;0))))
Cordialement.
Daniel

Bonjour,

J'ai en colonne A le calendrier d'une année complete

A
01/01/2010
02/01/2010
03/01/2010

Et cela jusqu'a la fin de l'année

en colonne B j'ai toute sorte de texte

Je souhaite compter le nombre de cellule remplie en colonne B qui tombe
soit un samedi, dimanche ainsi que jours feriés

J'ai deja nommé mes jours feriés et fait
NB.JOURS.OUVRES($A$2;$A$370;JOURS_feries) et maintenant je me bat avec le
sommeprod, mais je bloque

Merci pour votre aide.

Manu








Manu
Le #21479251
Ca fonctionne quand il y a vraiment rien, mais A366, j'ai une formul style
=si(année(bisextile);A365+1;"") je simplifie bien sur mais ta formule
n'aprecie pas qu'il y ais une formule, verifie

Manu

"Daniel.C" %
=SOMMEPROD((B1:B366<>"")*((JOURSEM(A1:A366;2)>5)+ESTNUM(EQUIV(A1:A366;G1:G100;0))))
Ca fonctionne chez moi ?
Daniel

J'ai tout de meme un soucis, la plage des dates est variable ca peut etre
jusqu'en A365 ou si on on est en bissextile en A366 et j'ai remarqué que
si j'utilise ta formule jusqu'à A366, ca ne fonctionne plus.

En A366, j'ai une formule qui mette rien si on est en année normal, sinon
qu'il me rajoute un jour, mes dates fonctionne bien, mais ce ne plait pas
à la formule si je prend cette cellule supplémentaire qui est pourtant
importante, il y a t'il une solution ?

Merci

Manu

"Manu" %
Super Daniel, merci, je cherchais completement ailleurs.

Merci encore

Manu

"Daniel.C" %
Bonjour.
Avec une plage de jours chômés en G1:G100 :
=SOMMEPROD((B1:B365<>"")*((JOURSEM(A1:A365;2)>5)+ESTNUM(EQUIV(A1:A365;G1:G100;0))))
Cordialement.
Daniel

Bonjour,

J'ai en colonne A le calendrier d'une année complete

A
01/01/2010
02/01/2010
03/01/2010

Et cela jusqu'a la fin de l'année

en colonne B j'ai toute sorte de texte

Je souhaite compter le nombre de cellule remplie en colonne B qui
tombe soit un samedi, dimanche ainsi que jours feriés

J'ai deja nommé mes jours feriés et fait
NB.JOURS.OUVRES($A$2;$A$370;JOURS_feries) et maintenant je me bat avec
le sommeprod, mais je bloque

Merci pour votre aide.

Manu














Daniel.C
Le #21479281
Alors, formule matricielle (valider avec Ctrl+Maj+Entrée) :
=SOMMEPROD((B1:B366<>"")*(SI(ESTNUM(A1:A366);JOURSEM(A1:A366;2)>5;0)+ESTNUM(EQUIV(A1:A366;G1:G100;0))))
Daniel

Ca fonctionne quand il y a vraiment rien, mais A366, j'ai une formul style
=si(année(bisextile);A365+1;"") je simplifie bien sur mais ta formule
n'aprecie pas qu'il y ais une formule, verifie

Manu

"Daniel.C" %
=SOMMEPROD((B1:B366<>"")*((JOURSEM(A1:A366;2)>5)+ESTNUM(EQUIV(A1:A366;G1:G100;0))))
Ca fonctionne chez moi ?
Daniel

J'ai tout de meme un soucis, la plage des dates est variable ca peut etre
jusqu'en A365 ou si on on est en bissextile en A366 et j'ai remarqué que
si j'utilise ta formule jusqu'à A366, ca ne fonctionne plus.

En A366, j'ai une formule qui mette rien si on est en année normal, sinon
qu'il me rajoute un jour, mes dates fonctionne bien, mais ce ne plait pas
à la formule si je prend cette cellule supplémentaire qui est pourtant
importante, il y a t'il une solution ?

Merci

Manu

"Manu" %
Super Daniel, merci, je cherchais completement ailleurs.

Merci encore

Manu

"Daniel.C" %
Bonjour.
Avec une plage de jours chômés en G1:G100 :
=SOMMEPROD((B1:B365<>"")*((JOURSEM(A1:A365;2)>5)+ESTNUM(EQUIV(A1:A365;G1:G100;0))))
Cordialement.
Daniel

Bonjour,

J'ai en colonne A le calendrier d'une année complete

A
01/01/2010
02/01/2010
03/01/2010

Et cela jusqu'a la fin de l'année

en colonne B j'ai toute sorte de texte

Je souhaite compter le nombre de cellule remplie en colonne B qui tombe
soit un samedi, dimanche ainsi que jours feriés

J'ai deja nommé mes jours feriés et fait
NB.JOURS.OUVRES($A$2;$A$370;JOURS_feries) et maintenant je me bat avec
le sommeprod, mais je bloque

Merci pour votre aide.

Manu














Manu
Le #21479381
Merci Daniel,

je n'ais pas le temps de voir maintenant car sortie ciné avec mon fils, je
regarde demain et te tiens au courant, merci encore de ton implication.

Manu

"Daniel.C" %
Alors, formule matricielle (valider avec Ctrl+Maj+Entrée) :
=SOMMEPROD((B1:B366<>"")*(SI(ESTNUM(A1:A366);JOURSEM(A1:A366;2)>5;0)+ESTNUM(EQUIV(A1:A366;G1:G100;0))))
Daniel

Ca fonctionne quand il y a vraiment rien, mais A366, j'ai une formul
style =si(année(bisextile);A365+1;"") je simplifie bien sur mais ta
formule n'aprecie pas qu'il y ais une formule, verifie

Manu

"Daniel.C" %
=SOMMEPROD((B1:B366<>"")*((JOURSEM(A1:A366;2)>5)+ESTNUM(EQUIV(A1:A366;G1:G100;0))))
Ca fonctionne chez moi ?
Daniel

J'ai tout de meme un soucis, la plage des dates est variable ca peut
etre jusqu'en A365 ou si on on est en bissextile en A366 et j'ai
remarqué que si j'utilise ta formule jusqu'à A366, ca ne fonctionne
plus.

En A366, j'ai une formule qui mette rien si on est en année normal,
sinon qu'il me rajoute un jour, mes dates fonctionne bien, mais ce ne
plait pas à la formule si je prend cette cellule supplémentaire qui est
pourtant importante, il y a t'il une solution ?

Merci

Manu

"Manu" %
Super Daniel, merci, je cherchais completement ailleurs.

Merci encore

Manu

"Daniel.C" %
Bonjour.
Avec une plage de jours chômés en G1:G100 :
=SOMMEPROD((B1:B365<>"")*((JOURSEM(A1:A365;2)>5)+ESTNUM(EQUIV(A1:A365;G1:G100;0))))
Cordialement.
Daniel

Bonjour,

J'ai en colonne A le calendrier d'une année complete

A
01/01/2010
02/01/2010
03/01/2010

Et cela jusqu'a la fin de l'année

en colonne B j'ai toute sorte de texte

Je souhaite compter le nombre de cellule remplie en colonne B qui
tombe soit un samedi, dimanche ainsi que jours feriés

J'ai deja nommé mes jours feriés et fait
NB.JOURS.OUVRES($A$2;$A$370;JOURS_feries) et maintenant je me bat
avec le sommeprod, mais je bloque

Merci pour votre aide.

Manu




















Manu
Le #21481491
Bonjour,

Effectivment, ca fonctionne parfaitement mais maintenant je vais avoir un
autre soucis, car cette formule doit s'imbriquer dans une deja existante
mais qui n'est pas matricielle et pour l'instant je n'arrive pas à les faire
cohabiter, je fais mes recherches et si je n'y arrive pas, je demanderais
de l'aide à nouveau.

Merci encore

Manu

"Manu" e0xU%
Merci Daniel,

je n'ais pas le temps de voir maintenant car sortie ciné avec mon fils, je
regarde demain et te tiens au courant, merci encore de ton implication.

Manu

"Daniel.C" %
Alors, formule matricielle (valider avec Ctrl+Maj+Entrée) :
=SOMMEPROD((B1:B366<>"")*(SI(ESTNUM(A1:A366);JOURSEM(A1:A366;2)>5;0)+ESTNUM(EQUIV(A1:A366;G1:G100;0))))
Daniel

Ca fonctionne quand il y a vraiment rien, mais A366, j'ai une formul
style =si(année(bisextile);A365+1;"") je simplifie bien sur mais ta
formule n'aprecie pas qu'il y ais une formule, verifie

Manu

"Daniel.C" %
=SOMMEPROD((B1:B366<>"")*((JOURSEM(A1:A366;2)>5)+ESTNUM(EQUIV(A1:A366;G1:G100;0))))
Ca fonctionne chez moi ?
Daniel

J'ai tout de meme un soucis, la plage des dates est variable ca peut
etre jusqu'en A365 ou si on on est en bissextile en A366 et j'ai
remarqué que si j'utilise ta formule jusqu'à A366, ca ne fonctionne
plus.

En A366, j'ai une formule qui mette rien si on est en année normal,
sinon qu'il me rajoute un jour, mes dates fonctionne bien, mais ce ne
plait pas à la formule si je prend cette cellule supplémentaire qui
est pourtant importante, il y a t'il une solution ?

Merci

Manu

"Manu" %
Super Daniel, merci, je cherchais completement ailleurs.

Merci encore

Manu

"Daniel.C" news: %
Bonjour.
Avec une plage de jours chômés en G1:G100 :
=SOMMEPROD((B1:B365<>"")*((JOURSEM(A1:A365;2)>5)+ESTNUM(EQUIV(A1:A365;G1:G100;0))))
Cordialement.
Daniel

Bonjour,

J'ai en colonne A le calendrier d'une année complete

A
01/01/2010
02/01/2010
03/01/2010

Et cela jusqu'a la fin de l'année

en colonne B j'ai toute sorte de texte

Je souhaite compter le nombre de cellule remplie en colonne B qui
tombe soit un samedi, dimanche ainsi que jours feriés

J'ai deja nommé mes jours feriés et fait
NB.JOURS.OUVRES($A$2;$A$370;JOURS_feries) et maintenant je me bat
avec le sommeprod, mais je bloque

Merci pour votre aide.

Manu
























Sam
Le #21485272
Bonjour Daniel,
n'y a t'il pas un pb quand un jour férié tombe un WE ?
ne faudrait il pas mettre
=SOMMEPROD((B1:B366
Daniel.C
Le #21485372
Bonjour.
Tout à fait. Maintenant que tu le dis...
Daniel

Bonjour Daniel,
n'y a t'il pas un pb quand un jour férié tombe un WE ?
ne faudrait il pas mettre

=SOMMEPROD((B1:B366<>"")*MAX(1;(SI(ESTNUM(A1:A366);JOURSEM(A1:A366;2)>5;0)+ESTNUM(EQUIV(A1:A366;G1:G100;0)))))CordialementMichel
dit "Sam""Daniel.C" news:% Alors, formule matricielle
(valider avec Ctrl+Maj+Entrée)
:>=SOMMEPROD((B1:B366<>"")*(SI(ESTNUM(A1:A366);JOURSEM(A1:A366;2)>5;0)+ESTNUM(EQUIV(A1:A366;G1:G100;0))))>
Daniel>>> Ca fonctionne quand il y a vraiment rien, mais A366, j'ai une
formulstyle =si(année(bisextile);A365+1;"") je simplifie bien sur mais ta
formulen'aprecie pas qu'il y ais une formule, verifie>>>> Manu>>>> "Daniel.C"
news:%=SOMMEPROD((B1:B366<>"")*((JOURSEM(A1:A366;2)>5)+ESTNUM(EQUIV(A1:A366;G1:G100;0))))>>>
Ca fonctionne chez moi ?>>> Daniel>>>>>>> J'ai tout de meme un soucis, la
plage des dates est variable ca peutetre jusqu'en A365 ou si on on est en
bissextile en A366 et j'ai remarquéque si j'utilise ta formule jusqu'à A366,
ca ne fonctionne plus.>>>>>>>> En A366, j'ai une formule qui mette rien si on
est en année normal,sinon qu'il me rajoute un jour, mes dates fonctionne
bien, mais ce ne plaitpas à la formule si je prend cette cellule
supplémentaire qui est pourtantimportante, il y a t'il une solution ?>>>>>>>>
Merci>>>>>>>> Manu>>>>>>>> "Manu" message de news:% Super Daniel,
merci, je cherchais completement ailleurs.>>>>>>>>>> Merci encore>>>>>>>>>>
Manu>>>>>>>>>> "Daniel.C" de news:% Bonjour.>>>>>> Avec
une plage de jours chômés en G1:G100
:>>>>>>=SOMMEPROD((B1:B365<>"")*((JOURSEM(A1:A365;2)>5)+ESTNUM(EQUIV(A1:A365;G1:G100;0))))>>>>>>
Cordialement.>>>>>> Daniel>>>>>>>>>>>>> Bonjour,>>>>>>>>>>>>>> J'ai en
colonne A le calendrier d'une année complete>>>>>>>>>>>>>> A>>>>>>>
01/01/2010>>>>>>> 02/01/2010>>>>>>> 03/01/2010>>>>>>>>>>>>>> Et cela jusqu'a
la fin de l'année>>>>>>>>>>>>>> en colonne B j'ai toute sorte de
texte>>>>>>>>>>>>>> Je souhaite compter le nombre de cellule remplie en
colonne B quitombe soit un samedi, dimanche ainsi que jours
feriés>>>>>>>>>>>>>> J'ai deja nommé mes jours feriés et
faitNB.JOURS.OUVRES($A$2;$A$370;JOURS_feries) et maintenant je me bat avec
lesommeprod, mais je bloque>>>>>>>>>>>>>> Merci pour votre
aide.>>>>>>>>>>>>>> Manu>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Publicité
Poster une réponse
Anonyme