SOMMEPROD probléme de dates

Le
jaloulou
Bonjour à tous
J'ai créé un tableau à plusieurs colonnes (dont 3 en particulier : clients,
dates, valeurs). Je souhaiterais dans un second tableau (annuel : Jan -
Fev - Mars - Etc .) situé sur la même feuille, compter les valeurs
correspondant au même mois et au même client. J'utilise SOMMEPROD.
Je ne sais pas comment tester un date (sans passer par VB) pour qu'elle
corresponde à un mois donné.
J'espère avoir été clair.
Merci à vous tous
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
michdenis
Le #17577291
Pour un mois particulier : MOIS(B1:B9)
Pour limiter à une année particulier : ANNEE(B1:B9) 08
Pour limiter à un client particulier :A1:A9="LeClient"

Tu insères les différents items selon ton besoin !
=SOMMEPROD((MOIS(B1:B9))*(ANNEE(B1:B9) 08)*(A1:A9="LeClient"))



"jaloulou" 48fb0d8b$0$881$
Bonjour à tous
J'ai créé un tableau à plusieurs colonnes (dont 3 en particulier : clients,
dates, valeurs). Je souhaiterais dans un second tableau (annuel : Jan -
Fev - Mars - Etc ....) situé sur la même feuille, compter les valeurs
correspondant au même mois et au même client. J'utilise SOMMEPROD.
Je ne sais pas comment tester un date (sans passer par VB) pour qu'elle
corresponde à un mois donné.
J'espère avoir été clair.
Merci à vous tous
isabelle
Le #17577281
bonjour jaloulou,

par exemple :

2008-10-01 1
2008-10-16 2
2008-11-02 3
2008-11-04 4

=SOMMEPROD((MOIS(A1:A4))*(B1:B4))

retourne la valeur 7

isabelle

jaloulou a écrit :
Bonjour à tous
J'ai créé un tableau à plusieurs colonnes (dont 3 en particulier : clients,
dates, valeurs). Je souhaiterais dans un second tableau (annuel : Jan -
Fev - Mars - Etc ....) situé sur la même feuille, compter les valeurs
correspondant au même mois et au même client. J'utilise SOMMEPROD.
Je ne sais pas comment tester un date (sans passer par VB) pour qu'elle
corresponde à un mois donné.
J'espère avoir été clair.
Merci à vous tous




jaloulou
Le #17586711
Merci, je tournais autour de la solution mais je n'ai pas imaginé une
seconde que "MOIS" qui d'habitude s'applique à une valeur de cellule pouvait
s'appliquer également aux différentes valeurs d'une plage, pour moi ce
n'était pas logique.
Belle bête quand même que ce "Excel".

"jaloulou" 48fb0d8b$0$881$
Bonjour à tous
J'ai créé un tableau à plusieurs colonnes (dont 3 en particulier :
clients, dates, valeurs). Je souhaiterais dans un second tableau (annuel :
Jan - Fev - Mars - Etc ....) situé sur la même feuille, compter les
valeurs correspondant au même mois et au même client. J'utilise SOMMEPROD.
Je ne sais pas comment tester un date (sans passer par VB) pour qu'elle
corresponde à un mois donné.
J'espère avoir été clair.
Merci à vous tous




Publicité
Poster une réponse
Anonyme