Sommesi() avec un critère de date; je n'y arrive pas.

Le
luck82
Bonjour;

Je voudrai faire la somme de toutes les cellules de la colonne Z a la
condition que les cellules de la colonne V soit supèrieur à date =
01/01/2005.
Voilà c'est simple mais je n'ai jamais réussi à faire une formule contement
un critère de date.

Si quelqu'un peut m'aider et éventuellement m'expliquer comment on gère une
date dans une formule.


Merci par avance.
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #4243061
Bonjour,

=SOMME.SI(V2:V1000;">01/01/2005";Z2:E1000)

JB


On 17 mar, 08:40, "luck82"
Bonjour;

Je voudrai faire la somme de toutes les cellules de la colonne Z a la
condition que les cellules de la colonne V soit supèrieur à date =
01/01/2005.
Voilà c'est simple mais je n'ai jamais réussi à faire une formule c ontement
un critère de date.

Si quelqu'un peut m'aider et éventuellement m'expliquer comment on gè re une
date dans une formule.

Merci par avance.


JB
Le #4243051
Avec SommeProd()

=SOMMEPROD((D2:D10>DATEVAL("01/01/2005"))*(E2:E10))

JB

On 17 mar, 08:40, "luck82"
Bonjour;

Je voudrai faire la somme de toutes les cellules de la colonne Z a la
condition que les cellules de la colonne V soit supèrieur à date =
01/01/2005.
Voilà c'est simple mais je n'ai jamais réussi à faire une formule c ontement
un critère de date.

Si quelqu'un peut m'aider et éventuellement m'expliquer comment on gè re une
date dans une formule.

Merci par avance.


Jacky
Le #4243011
Bonjour,
Si quelqu'un peut m'aider et éventuellement m'expliquer comment on gère
une
date dans une formule.
Regarde ici:

http://cjoint.com/?drjRr0yfpp

--
Salutations
JJ


"luck82"
Bonjour;

Je voudrai faire la somme de toutes les cellules de la colonne Z a la
condition que les cellules de la colonne V soit supèrieur à date > 01/01/2005.
Voilà c'est simple mais je n'ai jamais réussi à faire une formule
contement
un critère de date.

Si quelqu'un peut m'aider et éventuellement m'expliquer comment on gère
une
date dans une formule.


Merci par avance.




luck82
Le #4242971
Merci pour la contribution de tous.

Je connais maintement de façon d'utiliser une date dans une formule: soit
avec la fonction dateval(jj/mm/aa) ou tout simplement comment argument avec
les "".
Merci à Jacky pour les exemples en fichier joint.

Bon week end.
LSteph
Le #4242951
Bonjour,
Outre le comment s'exprime la date dans la formule ,
ce que viennent d'évoquer les précédentes réponses,
autre solution:

En a1: 01/01/2005
en b1:
=SOMMEPROD((D2:D10>$a$1)*(E2:E10))


Cordialement.

lSteph


Bonjour;

Je voudrai faire la somme de toutes les cellules de la colonne Z a la
condition que les cellules de la colonne V soit supèrieur à date > 01/01/2005.
Voilà c'est simple mais je n'ai jamais réussi à faire une formule contement
un critère de date.

Si quelqu'un peut m'aider et éventuellement m'expliquer comment on gère une
date dans une formule.


Merci par avance.




luck82
Le #4242801
Je viens de pensé à un truc: sommeprod est super intéressant pour des
conditions multiples. Mais si je veux faire la somme des produits par
exemple (cellules de la colonne Z * cellules de la colonne X qui réponde à
la condition: cellules de la colonne A > à DATEVAL"01/01/05") je fais
comment.
En effet les différents arguments de cette fonction sont séparés par le
caractère logique * ; mais si je veux utiliser cet opérateur pour faire un
calcul, je fais comment.
LSteph
Le #4242721
..de la même façon ou presque la condition est un facteur comme un autre

exemple symbolisé par x y z

sommeprod((x:x)*(y:y)*(z:z))

si x le premier (bloc) renvoie VRAI donc 1
sinon 0 et rien n'est multiplié

ce qui donne 1*y*z soit y*z
ou 0*.. soit 0

Alors si on veut multiplier aussi par x:

sommeprod((x:x)*(x:x)*(y:y)*(z:z))

Cordialement.

lSteph



Je viens de pensé à un truc: sommeprod est super intéressant pour des
conditions multiples. Mais si je veux faire la somme des produits par
exemple (cellules de la colonne Z * cellules de la colonne X qui réponde à
la condition: cellules de la colonne A > à DATEVAL"01/01/05") je fais
comment.
En effet les différents arguments de cette fonction sont séparés par le
caractère logique * ; mais si je veux utiliser cet opérateur pour faire un
calcul, je fais comment.




Publicité
Poster une réponse
Anonyme