SOMMESI

Le
Manu
Salut tout le monde.

J'ai fait un tableur excel dans lequel, pour une vingtaine de départements,
je recense des besoins de salles de cours avec la durée des cours
correspondants. Je récapitule les 20 départements dans un onglet
récapitulatif, je trie le tout avec une macro pour arriver à un tableau
récapitulatif.
Dans ce dernier tableau, j'ai en ordonnée les différentes salles de cours et
en abcisse les différents départements, pour obtenir quel dpt demande quelle
salle et combien d'heures.
Pour ce dernier tableau, j'ai utilisé des SOMMESI, et tout fonctionne à
merveille (je me suis étonné moi même, lol), sauf pour 4 de mes départements
où la première donnée n'est pas traitée. Pourtant, ma formule est ok, pis ça
fonctionne pour les 16 autres départements
À quoi pourrait être dû ce non traitement ? Mes formats de valeurs semblent
corrects, je ne vois pas trop.
Le fichier est assez lourd (3Mo), mais je peux le zipper et l'envoyer si
besoin
--

D'avance, merci pour vos judicieux et précieux conseils !
Manu (Québec)
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Ellimac
Le #5376631
Bonsoir,

En effet il serait souhaitable d'avoir un bout de ton fichier

Camille


Salut tout le monde.

J'ai fait un tableur excel dans lequel, pour une vingtaine de départements,
je recense des besoins de salles de cours avec la durée des cours
correspondants. Je récapitule les 20 départements dans un onglet
récapitulatif, je trie le tout avec une macro pour arriver à un tableau
récapitulatif.
Dans ce dernier tableau, j'ai en ordonnée les différentes salles de cours et
en abcisse les différents départements, pour obtenir quel dpt demande quelle
salle et combien d'heures.
Pour ce dernier tableau, j'ai utilisé des SOMMESI, et tout fonctionne à
merveille (je me suis étonné moi même, lol), sauf pour 4 de mes départements
où la première donnée n'est pas traitée. Pourtant, ma formule est ok, pis ça
fonctionne pour les 16 autres départements...
À quoi pourrait être dû ce non traitement ? Mes formats de valeurs semblent
corrects, je ne vois pas trop.
Le fichier est assez lourd (3Mo), mais je peux le zipper et l'envoyer si
besoin...
--

D'avance, merci pour vos judicieux et précieux conseils !
Manu (Québec)


Trirème
Le #5376611
Bonsoir Manu,
Je vais encore essayer de vendre du tableau croisé dynamique TCD.
Sans vouloir minimiser ton travail, tu as réinventé ce pour quoi est fait le TCD.
Tu as certainement un besoin de présentation que ne satisfait pas le TCD et ça
je veux bien l'admettre.

Perso, je te suggère cette organisation :
- Un onglet avec ta base (alimentée ou non par le menu Données, grille ou
Données, formulaire)
- Un onglet avec le TCD élaboré à partir de la base
- Un onglet avec ton tableau actuel dans lequel tu mets des
LIREDONNEESTABCROISDYNAMIQUE() reprenant les valeurs en entête de ligne et de
colonne et les données du TCD.

Si ça te fait peur, parlons-en ici même, je prends moins cher que les psy ;-)

Cordialement,
Trirème

Salut tout le monde.

J'ai fait un tableur excel dans lequel, pour une vingtaine de départements,
je recense des besoins de salles de cours avec la durée des cours
correspondants. Je récapitule les 20 départements dans un onglet
récapitulatif, je trie le tout avec une macro pour arriver à un tableau
récapitulatif.
Dans ce dernier tableau, j'ai en ordonnée les différentes salles de cours et
en abcisse les différents départements, pour obtenir quel dpt demande quelle
salle et combien d'heures.
Pour ce dernier tableau, j'ai utilisé des SOMMESI, et tout fonctionne à
merveille (je me suis étonné moi même, lol), sauf pour 4 de mes départements
où la première donnée n'est pas traitée. Pourtant, ma formule est ok, pis ça
fonctionne pour les 16 autres départements...
À quoi pourrait être dû ce non traitement ? Mes formats de valeurs semblent
corrects, je ne vois pas trop.
Le fichier est assez lourd (3Mo), mais je peux le zipper et l'envoyer si
besoin...


Manu
Le #5109351
Bon matin, Trirème


Je connais un peu les TCD pour en avoir bidouillé quelques uns, mais pour
mon classeur, SOMMESI fait parfaitement l'affaire, puisqu'il me permet
d'avoir l'information souhaitée. En fait, j'ai regardé de plus près mon xls
hier et je me suis rendu compte que pour 4 départements (sur 25 environ), la
fonction SOMMESI est imopérante à cause du TRI qui ne se fait pas bien. Pour
les 21 autres, c,est OK, mais pour mes 4, quand je trie mes données, la
première ligne n'est pas prise en compte. : une fois que le tri est fait,
j'ai toutes mes valeurs (salle + nombre d'heures de réservation) triées en
A=>Z en bas du tableau (exemple lignes 50 à 65) et 1 salle + 1 nombre
d'heures à la 1ère ligne de mon tableau récapitulatif. Entre les deux, un
mnombre variable de lignes à zéro (qui correspondent aux champs vides des
demandes des départements)

Le problème viendrait donc du tri à la base. J'ai lu que parfois, le TRI ne
prenait pas en compte la première ligne puisque cette première ligne des
données était considéerée comme un titre de colonne par Windows. Il faut que
je trouve l'origine de ce petit bug pour mes 4 départements, ce qui devrait
me permettre de poursuivre, puisque, finalement, ça fonctionne pour 21
départements sur 25.

Je n'ai pas mon classeur à la maison, mais je pourrais en faire une copie
partielle au bureau et l'envoyer.

Merci !



--
Manu (Québec)



Bonsoir Manu,
Je vais encore essayer de vendre du tableau croisé dynamique TCD.
Sans vouloir minimiser ton travail, tu as réinventé ce pour quoi est fait le TCD.
Tu as certainement un besoin de présentation que ne satisfait pas le TCD et ça
je veux bien l'admettre.

Perso, je te suggère cette organisation :
- Un onglet avec ta base (alimentée ou non par le menu Données, grille ou
Données, formulaire)
- Un onglet avec le TCD élaboré à partir de la base
- Un onglet avec ton tableau actuel dans lequel tu mets des
LIREDONNEESTABCROISDYNAMIQUE() reprenant les valeurs en entête de ligne et de
colonne et les données du TCD.

Si ça te fait peur, parlons-en ici même, je prends moins cher que les psy ;-)

Cordialement,
Trirème

Salut tout le monde.

J'ai fait un tableur excel dans lequel, pour une vingtaine de départements,
je recense des besoins de salles de cours avec la durée des cours
correspondants. Je récapitule les 20 départements dans un onglet
récapitulatif, je trie le tout avec une macro pour arriver à un tableau
récapitulatif.
Dans ce dernier tableau, j'ai en ordonnée les différentes salles de cours et
en abcisse les différents départements, pour obtenir quel dpt demande quelle
salle et combien d'heures.
Pour ce dernier tableau, j'ai utilisé des SOMMESI, et tout fonctionne à
merveille (je me suis étonné moi même, lol), sauf pour 4 de mes départements
où la première donnée n'est pas traitée. Pourtant, ma formule est ok, pis ça
fonctionne pour les 16 autres départements...
À quoi pourrait être dû ce non traitement ? Mes formats de valeurs semblent
corrects, je ne vois pas trop.
Le fichier est assez lourd (3Mo), mais je peux le zipper et l'envoyer si
besoin...





Trirème
Le #5108881
Pour le tri, il me semble qu'Excel peut décider qu'il y a une ligne d'en têtes
si une case de la 1ère ligne contient du texte. Le mieux est d'ajouter
réellement une ligne d'en têtes pour être sûr de ne pas se tromper. Et ça te
permettra de faire un TCD avec de vraies étiquettes ;-)

Cordialement,
Trirème

Bon matin, Trirème


Je connais un peu les TCD pour en avoir bidouillé quelques uns, mais pour
mon classeur, SOMMESI fait parfaitement l'affaire, puisqu'il me permet
d'avoir l'information souhaitée. En fait, j'ai regardé de plus près mon xls
hier et je me suis rendu compte que pour 4 départements (sur 25 environ), la
fonction SOMMESI est imopérante à cause du TRI qui ne se fait pas bien. Pour
les 21 autres, c,est OK, mais pour mes 4, quand je trie mes données, la
première ligne n'est pas prise en compte. : une fois que le tri est fait,
j'ai toutes mes valeurs (salle + nombre d'heures de réservation) triées en
A=>Z en bas du tableau (exemple lignes 50 à 65) et 1 salle + 1 nombre
d'heures à la 1ère ligne de mon tableau récapitulatif. Entre les deux, un
mnombre variable de lignes à zéro (qui correspondent aux champs vides des
demandes des départements)

Le problème viendrait donc du tri à la base. J'ai lu que parfois, le TRI ne
prenait pas en compte la première ligne puisque cette première ligne des
données était considéerée comme un titre de colonne par Windows. Il faut que
je trouve l'origine de ce petit bug pour mes 4 départements, ce qui devrait
me permettre de poursuivre, puisque, finalement, ça fonctionne pour 21
départements sur 25.

Je n'ai pas mon classeur à la maison, mais je pourrais en faire une copie
partielle au bureau et l'envoyer.

Merci !





Manu
Le #5108671
Je vais donc insérer une ligne vide en haut de mes données et je vais
retester pendant les fêtes... Pour le moment, place à un peu de repos bien
mérité. On s,en reparle une prochaine fois !

merci, et un joyeux temps des fêtes !
--
Manu (Québec)



Pour le tri, il me semble qu'Excel peut décider qu'il y a une ligne d'en têtes
si une case de la 1ère ligne contient du texte. Le mieux est d'ajouter
réellement une ligne d'en têtes pour être sûr de ne pas se tromper. Et ça te
permettra de faire un TCD avec de vraies étiquettes ;-)

Cordialement,
Trirème

Bon matin, Trirème


Je connais un peu les TCD pour en avoir bidouillé quelques uns, mais pour
mon classeur, SOMMESI fait parfaitement l'affaire, puisqu'il me permet
d'avoir l'information souhaitée. En fait, j'ai regardé de plus près mon xls
hier et je me suis rendu compte que pour 4 départements (sur 25 environ), la
fonction SOMMESI est imopérante à cause du TRI qui ne se fait pas bien. Pour
les 21 autres, c,est OK, mais pour mes 4, quand je trie mes données, la
première ligne n'est pas prise en compte. : une fois que le tri est fait,
j'ai toutes mes valeurs (salle + nombre d'heures de réservation) triées en
A=>Z en bas du tableau (exemple lignes 50 à 65) et 1 salle + 1 nombre
d'heures à la 1ère ligne de mon tableau récapitulatif. Entre les deux, un
mnombre variable de lignes à zéro (qui correspondent aux champs vides des
demandes des départements)

Le problème viendrait donc du tri à la base. J'ai lu que parfois, le TRI ne
prenait pas en compte la première ligne puisque cette première ligne des
données était considéerée comme un titre de colonne par Windows. Il faut que
je trouve l'origine de ce petit bug pour mes 4 départements, ce qui devrait
me permettre de poursuivre, puisque, finalement, ça fonctionne pour 21
départements sur 25.

Je n'ai pas mon classeur à la maison, mais je pourrais en faire une copie
partielle au bureau et l'envoyer.

Merci !








Trirème
Le #5106241
Quand je parlais d'ajouter une ligne d'en têtes, je parlais d'une ligne avec des
mots dans les cellules, pas d'insérer une ligne vide, ce qui n'aurait aucun effet.

Bon repos et bonnes fêtes également.
Cordialement,
Trirème

Je vais donc insérer une ligne vide en haut de mes données et je vais
retester pendant les fêtes... Pour le moment, place à un peu de repos bien
mérité. On s,en reparle une prochaine fois !

merci, et un joyeux temps des fêtes !


Manu
Le #5117221
Salut, Trirème

De retour au boulot, j'ai retrouvé mon classeur. Plutôt que d'insérer une
ligne pour mon tri , j'ai modifié ma macro de tri pour les 4 départements
(sur 25) qui posaient problème, (en incluant une ligne de plus pour le tri)
et le tour est joué, tout fonctionne à merveille.

Alors un gros MERCI pour ces précieux conseils !
--
Manu (Québec)



Quand je parlais d'ajouter une ligne d'en têtes, je parlais d'une ligne avec des
mots dans les cellules, pas d'insérer une ligne vide, ce qui n'aurait aucun effet.

Bon repos et bonnes fêtes également.
Cordialement,
Trirème

Je vais donc insérer une ligne vide en haut de mes données et je vais
retester pendant les fêtes... Pour le moment, place à un peu de repos bien
mérité. On s,en reparle une prochaine fois !

merci, et un joyeux temps des fêtes !





Publicité
Poster une réponse
Anonyme