soucis inexpliqués dans des applications utilisant du php (phpmyadmi, squirrelamail) sur mon serveur debian sarge

Le
Thierry B
Bonjour,

J'ai quelques soucis inexpliqués dans des applications utilisant du php
sur mon serveur debian sarge

Par exemple, dans phpmyadmin, dans ma base de données mail, quand
j'essaie de modifier la valeur d'un champ de ma tablen j'ai ceci:
You don't have permission to access /phpmyadmin/tbl_change.php on this
server.

Dans squirrelmail, quand je réponds à un mail que j'ai recu (ca a l'air
de ne pas le faire, si j'ecris un nouveau mail, sans répondre à un mail
existant, quand je clique sur "envoyer", j'ai ceci:
You don't have permission to access /src/compose.php on this server.

J'utilise les version etch de ces paquets mais bon, vu qu'ils ne m'ont
demandé aucune autre dépendance etch sur ma debian sarge, il n'y a aucun
soucis normalement de ce coté là,d'autant plus, que j'avais aussi ce
problème avec phpmyadmin de sarge.

Une idée, d'où peuvent venir ces problèmes?

Merci bcp :-)


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Thierry B
Le #9526261
Bulot Grégory a écrit :
Le mercredi 21 mars 2007 18:43, Thierry B a écrit :
Bonjour,

J'ai quelques soucis inexpliqués dans des applications utilisant du php
sur mon serveur debian sarge

Par exemple, dans phpmyadmin, dans ma base de données mail, quand
j'essaie de modifier la valeur d'un champ de ma tablen j'ai ceci:
You don't have permission to access /phpmyadmin/tbl_change.php on this
server.

Dans squirrelmail, quand je réponds à un mail que j'ai recu (ca a l'air
de ne pas le faire, si j'ecris un nouveau mail, sans répondre à un mail
existant, quand je clique sur "envoyer", j'ai ceci:
You don't have permission to access /src/compose.php on this server.

J'utilise les version etch de ces paquets mais bon, vu qu'ils ne m'ont
demandé aucune autre dépendance etch sur ma debian sarge, il n'y a aucun
soucis normalement de ce coté là,d'autant plus, que j'avais aussi ce
problème avec phpmyadmin de sarge.

Une idée, d'où peuvent venir ces problèmes?



Ptet en regardant les droits sur ces fichiers (1)

stat -c '%U:%G %a(%A)' TonFichier


(1) la plupart du temps je sais pas ou se trouve les fichiers pour le webmail
et phpmyadmin, pour les trouver :
locate -i tbl_change.php
(si y a un message base trop vieille : updatedb et aller prendre un café en
attendant que la base soit généré). de mon côté fais un
ln -s /usr/bin/updatedb /etc/cron.daily/ comme cela c'est fait toutes les
nuits


Merci bcp :-)





Re,

Voila par exemple:

# stat -c '%U:%G %a(%A)' /usr/share/squirrelmail/src/compose.php
root:root 644(-rw-r--r--)

Mai bon, du fait que ca me le fait avec plusieurs applis, je me demande
si ca ne peut pas venir d'une mise à jour du php de sarge par exemple?

Apparemment, il y en a eu 2 en Mars et 3 en Novembre.

J'etais tenté de passer à php 5 sur ma sarge, enn utilisant backports
pour pouvoir utiliser plus d'applications, cela serait interessant de
tester peut-etre aussi pour voir si cela résound mon pb.

Quelqu'un utilise deja php 5 sur un serveur sous sarge? Car j'aimerais
bien y passer sans que ca soit trop le bordel lol.

Intuitivement, j'aurais listé tous les paquets que j'ai d'installer qui
contiennent "php4", et j'aurais installer le paquet correspond en
"php5", je ne sais pas si c'est une bonne méthode et si ca sufffit pour
que par defaut, il utilise php5.

Merci :-)


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Bulot Grégory
Le #9526251
Le jeudi 22 mars 2007 10:35, Thierry B a écrit :
Bulot Grégory a écrit :
> Le mercredi 21 mars 2007 18:43, Thierry B a écrit :



Je force 'repondre à la liste' pour éviter réponse en privée

>> Merci bcp :-)

Re,

Voila par exemple:

# stat -c '%U:%G %a(%A)' /usr/share/squirrelmail/src/compose.php
root:root 644(-rw-r--r--)

Mai bon, du fait que ca me le fait avec plusieurs applis, je me demande
si ca ne peut pas venir d'une mise à jour du php de sarge par exemple?

Apparemment, il y en a eu 2 en Mars et 3 en Novembre.

J'etais tenté de passer à php 5 sur ma sarge, enn utilisant backports
pour pouvoir utiliser plus d'applications, cela serait interessant de
tester peut-etre aussi pour voir si cela résound mon pb.

Quelqu'un utilise deja php 5 sur un serveur sous sarge? Car j'aimerais
bien y passer sans que ca soit trop le bordel lol.

Intuitivement, j'aurais listé tous les paquets que j'ai d'installer qui
contiennent "php4", et j'aurais installer le paquet correspond en
"php5", je ne sais pas si c'est une bonne méthode et si ca sufffit pour
que par defaut, il utilise php5.

Merci :-)



bah, j'sais pas ...

# su - www-data
$ cd /usr/share/squirrelmail/src/
S'il y a erreur, c'est qu'il y a un pb de droits sur un des répertoires p our
le server web
Thierry B
Le #9526241
Bulot Grégory a écrit :
Le jeudi 22 mars 2007 10:35, Thierry B a écrit :
Bulot Grégory a écrit :
Le mercredi 21 mars 2007 18:43, Thierry B a écrit :





Je force 'repondre à la liste' pour éviter réponse en privée

Merci bcp :-)




Re,

Voila par exemple:

# stat -c '%U:%G %a(%A)' /usr/share/squirrelmail/src/compose.php
root:root 644(-rw-r--r--)

Mai bon, du fait que ca me le fait avec plusieurs applis, je me demande
si ca ne peut pas venir d'une mise à jour du php de sarge par exemple?

Apparemment, il y en a eu 2 en Mars et 3 en Novembre.

J'etais tenté de passer à php 5 sur ma sarge, enn utilisant backports
pour pouvoir utiliser plus d'applications, cela serait interessant de
tester peut-etre aussi pour voir si cela résound mon pb.

Quelqu'un utilise deja php 5 sur un serveur sous sarge? Car j'aimerais
bien y passer sans que ca soit trop le bordel lol.

Intuitivement, j'aurais listé tous les paquets que j'ai d'installer qui
contiennent "php4", et j'aurais installer le paquet correspond en
"php5", je ne sais pas si c'est une bonne méthode et si ca sufffit pour
que par defaut, il utilise php5.

Merci :-)



bah, j'sais pas ...

# su - www-data
$ cd /usr/share/squirrelmail/src/
S'il y a erreur, c'est qu'il y a un pb de droits sur un des répertoires pour
le server web




Re,

Non, il n'y a pas d'erreur en faisant cette manip, le user www-data peut
lister ce repertoire.

Merci :-)


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Thierry B
Le #9526071
Bulot Grégory a écrit :
Le jeudi 22 mars 2007 10:35, Thierry B a écrit :
Bulot Grégory a écrit :
Le mercredi 21 mars 2007 18:43, Thierry B a écrit :





Je force 'repondre à la liste' pour éviter réponse en privée

Merci bcp :-)




Re,

Voila par exemple:

# stat -c '%U:%G %a(%A)' /usr/share/squirrelmail/src/compose.php
root:root 644(-rw-r--r--)

Mai bon, du fait que ca me le fait avec plusieurs applis, je me demande
si ca ne peut pas venir d'une mise à jour du php de sarge par exemple?

Apparemment, il y en a eu 2 en Mars et 3 en Novembre.

J'etais tenté de passer à php 5 sur ma sarge, enn utilisant backports
pour pouvoir utiliser plus d'applications, cela serait interessant de
tester peut-etre aussi pour voir si cela résound mon pb.

Quelqu'un utilise deja php 5 sur un serveur sous sarge? Car j'aimerais
bien y passer sans que ca soit trop le bordel lol.

Intuitivement, j'aurais listé tous les paquets que j'ai d'installer qui
contiennent "php4", et j'aurais installer le paquet correspond en
"php5", je ne sais pas si c'est une bonne méthode et si ca sufffit pour
que par defaut, il utilise php5.

Merci :-)



bah, j'sais pas ...

# su - www-data
$ cd /usr/share/squirrelmail/src/
S'il y a erreur, c'est qu'il y a un pb de droits sur un des répertoires pour
le server web




Re,

Bon, pour squirrelmail, j'ai trouvé.

C'est une règle de sécurisation d'apache: SecFilter " le bordel...lol.

Maintenant, il faut trouver la cause de l'erreur de phpmyadmin lol.

Merci :-)


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme