Souris (2)

Le
Luc
Bonsoir.
Et merci à tous ceux qui se sont intéressés à mon problème (que je ne suis
pas le seul à avoir, semble-t-il).

--> Serge / Azo4, la MàJ HID Non-User Input data Filter est pour Vista en
effet, et reliée à l'écran de veille.

1 petit bilan de la situation.
Je vais continuer de voir du côté de Logitech, mais peut-être avez-vous une
idée de ce qui se passe :

- Tout d'abord c'est arrivé (pas par une nuit sans lune comme David Vincent
!) après que j'aie changé le récepteur de la souris (Logitech M820, Laser
Optique sans fil) de port de HUB USB . Tout marchait bien, mais je trouvais
que le clic ne réagissait pas touhjours du 1er coup, et j'ai voulu raccourcir
la distance entre la souris et le récepteur.
1.
- Quel que soit le port USB, récepteur direct sur carte mère, avec rallonge
ou sur Hub, Windows détecte la 820 (--> Logitech HID-Compliant Cordless
Mouse), tente de l'installer, recherche les pilotes, et --> Impossible
d'installer, Erreur irrécupérable.
- L'installation du logiciel Logitech SetPoint ne va pas à son terme / échoue
- La souris fonctionne, le logiciel est présent malgré le point précédent et
affiche sa version et la souris + ses paramétrages (mais il faut régler la
vitesse presqu'au maxi sinon elle est très lente).
- Périphérique : Soit Inconnu, soit HID , mais pas Logitech
- Pilotes : 2 génériques Microsoft, aucun Logitech

2.
- Sur le 2ème PC, qui a aussi XP Pro SP2, la souris est reconnue et
installée immédiatement , via un Hub, elle vient s'ajouter à une MX
Revolution et une MX 1000, tous les pilotes sont là, Microsoft + Logitech, y
compris WdfCoInstaller 01000.dll. Tout marche.
Ce PC n'a rien de spécial par rapport à l'autre.

- Sur mon PC par contre la MX Revolution et la MX 1000 provoquent la même
chose que la 820 : Détection, puis Installation qui échoue.

3.
- J'ai réinstallé les drivers USB 2.0 de Via, au cas où.

- Sur PS/2 la 820 n'est pas reconnue du tout = pas de souris.

- Seule fonctionne une ancienne Logitech Cordless Click mais sur PS/2, sur
USB même chose qu'avec la laser : détection et échec.

- A noter que le logiciel dernière version 4.72 va à son terme avec la
Cordless.

Conclusion ?
Système / USB ne veulent plus des Logitech !! (le clavier est un Cherry,
sinon j'aurais du brancher l'ancien Logitech sur PS/2 aussi ?!!!).

PS : Tous les autres ports USB fonctionnent correctement (direct sur CM et
via le Hub, Imprimante, Lecteur MP3, Disque externe, Clés, ).

Etrange, non ?
Quoi faire ?
Certains me disent que tant qu'une souris marche
Ce n'est pas suffisant pour moi, il y a qq chose qui ne va pas (plus), et il
faut trouver quoi.

Merci à vous tous.
Luc
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Luc
Le #19467541
Merci "Coucou".
Le .reg n'était pas joint, mais j'ai trouvé comment faire, je vais afficher
tous les périphériques et voir s'il y a du ménage à faire.

Par contre, je suis peut-être un peu nul, mais je ne sais comment
décompresser une exe !
L'exe du logiciel SetPoint Logitech s'installe dans un répertoire Pr.
FilesLogitechSetpoint, mais il n'y a pas de Install ou autre Setup, donc on
ne peut pas l'installer à partir de ce répertoire.

A+
Luc

"Coucou à toutes et à tous" a écrit :

Bon, je vais m'en mêler ! :-)))

Il faut désinstaller RÉELLEMENT les anciennes installations de toutes les souris qui auraient pu être prises en compte depuis l'installation de Windows.

Pas si simple ! Il ne suffit pas d'aller dans le Gestionnaire de Périphériques ou dans Ajout/Suppression de Programmes.

Il faut faire apparaître TOUS les périphériques cachés, y compris les plus anciens, théoriquement désinstallés mais dont les drivers sont toujours dans System 32..
Or Windows n'a pas prévu cette option ! Faut aller bidouiller un peu dans la Base de Registre.
Ci-joint un petit fichier *.reg qui va permettre de la modifier d'un clic de souris, sans erreur possible.
Une fois ce fichier fusionné à la base de registre, il faudra aller dans le Gestionnaire de Périphériques puis aller dans l'option -> Affichage -> puis cocher "Afficher les périphériques cachés".

Alors apparaîtront toutes les traces des précédentes installations en grisé clair. Clic droit sur chacune d'elle puis Supprimer ou Désinstaller.
Il faudra faire cela pour tous les anciens périphériques en USB ou ayant un rapport avec les ports USB.

Redémarrer la machine puis tenter l'installation de la souris, en décompressant d'abord le fichier *.exe de Logitech à la racine de C: dans un dossier créé pour l'occasion.

Cette procédure ne peut être garantie à 100%, mais elle a souvent fonctionné pour des problèmes d'installation de périphériques en USB récalcitrants.

Cordialement


Coucou à toutes et à tous
Le #19468481
>Le .reg n'était pas joint, mais j'ai trouvé comment faire, je vais afficher
tous les périphériques et voir s'il y a du ménage à faire.



Non ! Ca ne marchera pas ! Sans cette modification de la base de registre,
l'option "Afficher tous les périphériques cachés" dans le Gestionnaire de
Périphériques n'affichera pas les anciens périphériques.

Le fichier *.reg était bien joint. Mais votre lecteur de News est mal
configuré et doit bloquer les pièces jointes.

Un fichier REG n'est rien d'autre qu'un fichier texte avec une extension
REG.
Vous pouvez donc le créer vous-même.

Copiez-collez le texte suivant, sans le modifier, dans un nouveau fichier
texte.
Renommez ensuite ce fichier texte *.TXT en *.REG.

Ci dessous ====================

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlSession
ManagerEnvironment]
"DEVMGR_SHOW_NONPRESENT_DEVICES"="1"


Ci-dessus====================
Cordialement.

JJV
Luc
Le #19469901
Hello !

Après avoir eu Logitech ce matin, je suis repassé chez moi et je suis tt de
suite allé voir : le paramétrage existait déjà (peut-être moi d'ailleurs, il
y a longtemps).
Effectivement mille périphériques s'affichent, certains qui correspondent à
des matériels qui n'existent plus : il va falloir que j'examine tout en
détail, de façon à supprimer uniquement ce qui doit l'être.

Avec l'assistance Logitech, j'ai supprimé sous ENUMUSB toutes les clés vid
046 de Logitech, et redémarré.
A nouveau détection de la souris HID, et échec d'installation.
Dans le Gestionnaire , Souris = "Inconnu" avec pilotes Microsoft et pas de
pilotes Logitech.
La souris marche et s'affiche dans le logiciel SetPoint pré-installé.

Je verrai ce que ça donne au prochain redémarrage, mais le problème a été
remonté plus haut chez Logitech, car le problème reste : impossible
d'installer tout périphérique Logitech sur USB.

Merci.
A+

"Coucou à toutes et à tous" a écrit :

>Le .reg n'était pas joint, mais j'ai trouvé comment faire, je vais afficher
>tous les périphériques et voir s'il y a du ménage à faire.

Non ! Ca ne marchera pas ! Sans cette modification de la base de registre,
l'option "Afficher tous les périphériques cachés" dans le Gestionnaire de
Périphériques n'affichera pas les anciens périphériques.

Le fichier *.reg était bien joint. Mais votre lecteur de News est mal
configuré et doit bloquer les pièces jointes.

Un fichier REG n'est rien d'autre qu'un fichier texte avec une extension
REG.
Vous pouvez donc le créer vous-même.

Copiez-collez le texte suivant, sans le modifier, dans un nouveau fichier
texte.
Renommez ensuite ce fichier texte *.TXT en *.REG.

Ci dessous ==================== >

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlSession
ManagerEnvironment]
"DEVMGR_SHOW_NONPRESENT_DEVICES"="1"


Ci-dessus==================== >
Cordialement.

JJV





Luc
Le #19469881
Au fait, "j'ai trouvé comment faire" signifiait que j'avais récupéré sur le
net la commande à exécuter pour modifier le registre !!! évidemment, je
n'allais pas afficher tous les périphériques cachés par l'effet de ma seule
volonté.

Bref, c'était déjà fait.

A propos des pièces jointes, chez moi comme ici au bureau, je consulte les
news via le site de Newsgroups France et Internet Explorer (6 ici et 8 chez
moi).

"Coucou à toutes et à tous" a écrit :

>Le .reg n'était pas joint, mais j'ai trouvé comment faire, je vais afficher
>tous les périphériques et voir s'il y a du ménage à faire.

Non ! Ca ne marchera pas ! Sans cette modification de la base de registre,
l'option "Afficher tous les périphériques cachés" dans le Gestionnaire de
Périphériques n'affichera pas les anciens périphériques.

Le fichier *.reg était bien joint. Mais votre lecteur de News est mal
configuré et doit bloquer les pièces jointes.

Un fichier REG n'est rien d'autre qu'un fichier texte avec une extension
REG.
Vous pouvez donc le créer vous-même.

Copiez-collez le texte suivant, sans le modifier, dans un nouveau fichier
texte.
Renommez ensuite ce fichier texte *.TXT en *.REG.

Ci dessous ==================== >

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlSession
ManagerEnvironment]
"DEVMGR_SHOW_NONPRESENT_DEVICES"="1"


Ci-dessus==================== >
Cordialement.

JJV





Nat
Le #19470681
Coool!
Ton petit .reg a réglé mon problème de scanner!!!!
Ça fait un petit moment qu'il répondait seulement quand ça lui tentait.
J'savais qu'il se mélangeait les pinceaux à travers tous les # qu'ils
s'octroyait à chaque fois que je l'avais branché/débranché mais je ne savais
pas trop comment m'en sortir.

Merci!


----.(-. .-).----



"Coucou à toutes et à tous" message de news:
Bon, je vais m'en mêler ! :-)))

Il faut désinstaller RÉELLEMENT les anciennes installations de toutes les
souris qui auraient pu être prises en compte depuis l'installation de
Windows.

Pas si simple ! Il ne suffit pas d'aller dans le Gestionnaire de
Périphériques ou dans Ajout/Suppression de Programmes.

Il faut faire apparaître TOUS les périphériques cachés, y compris les plus
anciens, théoriquement désinstallés mais dont les drivers sont toujours dans
System 32..
Or Windows n'a pas prévu cette option ! Faut aller bidouiller un peu dans la
Base de Registre.
Ci-joint un petit fichier *.reg qui va permettre de la modifier d'un clic
de souris, sans erreur possible.
Une fois ce fichier fusionné à la base de registre, il faudra aller dans le
Gestionnaire de Périphériques puis aller dans l'option -> Affichage -> puis
cocher "Afficher les périphériques cachés".

Alors apparaîtront toutes les traces des précédentes installations en grisé
clair. Clic droit sur chacune d'elle puis Supprimer ou Désinstaller.
Il faudra faire cela pour tous les anciens périphériques en USB ou ayant un
rapport avec les ports USB.

Redémarrer la machine puis tenter l'installation de la souris, en
décompressant d'abord le fichier *.exe de Logitech à la racine de C: dans
un dossier créé pour l'occasion.

Cette procédure ne peut être garantie à 100%, mais elle a souvent fonctionné
pour des problèmes d'installation de périphériques en USB récalcitrants.

Cordialement.

JJV
Luc
Le #19471811
Luc a écrit...

A propos des pièces jointes, chez moi comme ici au bureau, je
consulte les news via le site de Newsgroups France et Internet
Explorer (6 ici et 8 chez moi).



D'où l'intérêt d'utiliser le bon outil pour intervenir sur les newsgroups,
c'est-à-dire utiliser un logiciel de news plutôt que de passer par cette
interface web d'accès aux news de Microsoft (dite CDO) fort incommode.

http://www.faqoe.com/index.php?bas=/configureforum.htm

--
Cordialement,

Luc Burnouf [MVP]
http://www.faqoe.com/

adresse de réponse invalide
pour me joindre --> http://www.mailfusible.com/?ag7Yk2DXNg
Coucou à toutes et à tous
Le #19474331
>Coool!
Ton petit .reg a réglé mon problème de scanner!!!!
Ça fait un petit moment qu'il répondait seulement quand ça lui tentait.
J'savais qu'il se mélangeait les pinceaux à travers tous les # qu'ils
s'octroyait à chaque fois que je l'avais branché/débranché mais je ne
savais pas trop comment m'en sortir.



Ah ben ! A défaut d'avoir réparé la souris ! Hé hé !

JJV
Luc
Le #19477051
Merci, Luc.

Chez moi, OE et News, pas de problème, par contre ici au bureau, ça va être
+ dur ...!!

"Luc" a écrit :

Luc a écrit...

> A propos des pièces jointes, chez moi comme ici au bureau, je
> consulte les news via le site de Newsgroups France et Internet
> Explorer (6 ici et 8 chez moi).

D'où l'intérêt d'utiliser le bon outil pour intervenir sur les newsgroups,
c'est-à-dire utiliser un logiciel de news plutôt que de passer par cette
interface web d'accès aux news de Microsoft (dite CDO) fort incommode.

http://www.faqoe.com/index.php?bas=/configureforum.htm

--
Cordialement,

Luc Burnouf [MVP]
http://www.faqoe.com/

adresse de réponse invalide
pour me joindre --> http://www.mailfusible.com/?ag7Yk2DXNg




Luc
Le #19477041
Content d'avoir été, indirectement mais quand même, utile.

:-))

"Coucou à toutes et à tous" a écrit :

>Coool!
>Ton petit .reg a réglé mon problème de scanner!!!!
>Ça fait un petit moment qu'il répondait seulement quand ça lui tentait.
>J'savais qu'il se mélangeait les pinceaux à travers tous les # qu'ils
>s'octroyait à chaque fois que je l'avais branché/débranché mais je ne
>savais pas trop comment m'en sortir.

Ah ben ! A défaut d'avoir réparé la souris ! Hé hé !

JJV





Gloops
Le #19482401
Coucou à toutes et à tous a écrit, le 02/06/2009 23:53 :
Coool!
Ton petit .reg a réglé mon problème de scanner!!!!
Ça fait un petit moment qu'il répondait seulement quand ça lui t entait.
J'savais qu'il se mélangeait les pinceaux à travers tous les # qu' ils
s'octroyait à chaque fois que je l'avais branché/débranché mai s je ne
savais pas trop comment m'en sortir.



Ah ben ! A défaut d'avoir réparé la souris ! Hé hé !

JJV





Hello,

Je me demande si je vais tenter pour mon imprimante (parallèle via USB) .
Mais bon, c'est depuis qu'on a changé la carte mère, au bout d'un mom ent
ça coupe, je bouge un peu le fil et ça revient -parfois en étant ob ligé
de débrancher et rebrancher. Au début c'était embêtant, mais main tenant
(que le portable bouge rarement) j'arrive au bout d'une impression en
général.

Alors évidemment, bidouiller dans le registre pour résoudre des
problèmes de mauvais contacts ...
Publicité
Poster une réponse
Anonyme