Sous total de lignes typées

Le
Ludo
Bonjour,

Je debute sur Excel 2003 et j'ai la problèmatique suivante :
mon fichier excel est alimenté via ODBC par une base de données.

En simplifiant, j'obtiens comme resultatune liste de 4 colonnes :

TYPE ETAT VALEUR
INTERNE/EXTERNE
PB ACP 10000
INTERNE
PN ACP 900
INTERNE
PB ACP 550
INTERNE
PN ACP 1000
INTERNE
.

Je souhaiterais à l aide d'un macro obtenir les sous totaux de VALEUR
seulement pour les les lignes de TYPE PN quelquesoit le filtre utilisé (dans
mon exemple, je devrais avoir 1900)
(je vais avoir un sous-total par ETAT et par INTERNE/EXTERNE). J'ai essayé
d'utiliser la fonctionnalité sous total mais sans succès

Quelle est la methode à utiliser SVP?

Merci pour votre assistance
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Trirème
Le #4810291
Bonjour Ludo
Réponse : Tableau Croisé Dynamique (TCD)
Voir la réponse de Misange à Infogroup à 10h08.

Le dynamisme est relatif car il faut explicitement actualiser le tableau. Cependant, avec
un tout petit bout de code événementiel on peut tout automatisé.

Cordialement,
Trirème

Bonjour,

Je debute sur Excel 2003 et j'ai la problèmatique suivante :
mon fichier excel est alimenté via ODBC par une base de données.

En simplifiant, j'obtiens comme resultatune liste de 4 colonnes :

TYPE ETAT VALEUR
INTERNE/EXTERNE
PB ACP 10000
INTERNE
PN ACP 900
INTERNE
PB ACP 550
INTERNE
PN ACP 1000
INTERNE
....

Je souhaiterais à l aide d'un macro obtenir les sous totaux de VALEUR
seulement pour les les lignes de TYPE PN quelquesoit le filtre utilisé (dans
mon exemple, je devrais avoir 1900)
(je vais avoir un sous-total par ETAT et par INTERNE/EXTERNE). J'ai essayé
d'utiliser la fonctionnalité sous total mais sans succès...

Quelle est la methode à utiliser SVP?

Merci pour votre assistance


JB
Le #4810281
Bonjour,

=SOMMEPROD((SOUS.TOTAL(9;INDIRECT("c"&LIGNE(C2:C1000)))*(A2:A1000="pn") ))

JB

On 7 août, 11:56, Ludo
Bonjour,

Je debute sur Excel 2003 et j'ai la problèmatique suivante :
mon fichier excel est alimenté via ODBC par une base de données.

En simplifiant, j'obtiens comme resultatune liste de 4 colonnes :

TYPE ETAT VALEUR
INTERNE/EXTERNE
PB ACP 10000
INTERNE
PN ACP 900
INTERNE
PB ACP 550
INTERNE
PN ACP 1000
INTERNE
....

Je souhaiterais à l aide d'un macro obtenir les sous totaux de VALEUR
seulement pour les les lignes de TYPE PN quelquesoit le filtre utilisé (dans
mon exemple, je devrais avoir 1900)
(je vais avoir un sous-total par ETAT et par INTERNE/EXTERNE). J'ai essay é
d'utiliser la fonctionnalité sous total mais sans succès...

Quelle est la methode à utiliser SVP?

Merci pour votre assistance


Trirème
Le #4810271
tableau. Cependant, avec un tout petit bout de code événementiel on peut
tout automatisé.
... TOUT AUTOMATISER :(


Publicité
Poster une réponse
Anonyme