Sous-totaux mensuel

Le
rthompson
Bonjour à toutes et tous

Après une (rapide ) recherche ici et sur excelabo, je n'ai pas trouvé ce que
je cherche

Si dans une colonne A j'ai une série de dates et en colonne B des montants
je voudrais faire des sous-totaux pour chaque mois

Exemple

1 A B
2 01/05/08 5
3 06/05/08 9
4 11/05/08 3
5 04/06/08 4
6 16/06/08 15
7 09/07/08 4
8 21/08/08 3
9 25/08/08 8


Je voudrais que mes sous-totaux s'affiche en B pour chaque mois
Ce que je fais pour le moment est ceci via macro,
mais je suis certains qu'il y a une solution plus élégante

D'avance merci à vous et bon dimanche

A lundi

Rex



xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Sub subtotalunits()
Columns("M:M").Select
Selection.NumberFormat = "mmm-yyyy"
Range("M5:S38").Select
Selection.Subtotal GroupBy:=1, Function:=xlSum, TotalList:=Array(7), _
Replace:=True, PageBreaks:úlse, SummaryBelowData:=True
Columns("M:M").Select
Selection.NumberFormat = "[$-80C]dd-mmm-yy;@"
End Sub
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #11200021
Bonjour,
Je voudrais que mes sous-totaux s'affiche en B pour chaque mois


En B il y a les montants Non???

Je te propose ceci
En C2
=SI(MOIS(A2)<>MOIS(A3);SOMMEPROD((MOIS($A$2:$A$100)=MOIS(A2))*$B$2:$B$100);"")
ou un tableau avec
=SOMMEPROD((MOIS($A$2:$A$101)ò)*$B$2:$B$101)
Voir ici
http://cjoint.com/?hgnv7CYFTd
--
Salutations
JJ


"rthompson" news: %23%
Bonjour à toutes et tous

Après une (rapide ) recherche ici et sur excelabo, je n'ai pas trouvé ce
que je cherche

Si dans une colonne A j'ai une série de dates et en colonne B des montants
je voudrais faire des sous-totaux pour chaque mois

Exemple

1 A B
2 01/05/08 5
3 06/05/08 9
4 11/05/08 3
5 04/06/08 4
6 16/06/08 15
7 09/07/08 4
8 21/08/08 3
9 25/08/08 8


Je voudrais que mes sous-totaux s'affiche en B pour chaque mois
Ce que je fais pour le moment est ceci via macro,
mais je suis certains qu'il y a une solution plus élégante

D'avance merci à vous et bon dimanche

A lundi

Rex



xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Sub subtotalunits()
Columns("M:M").Select
Selection.NumberFormat = "mmm-yyyy"
Range("M5:S38").Select
Selection.Subtotal GroupBy:=1, Function:=xlSum, TotalList:=Array(7), _
Replace:=True, PageBreaks:úlse, SummaryBelowData:=True
Columns("M:M").Select
Selection.NumberFormat = "[$-80C]dd-mmm-yy;@"
End Sub
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx




rthompson
Le #11200101
Bonjour Jacky

Voilà une approche original à laquelle je n'avais pas pensé

Je vais me faire une feuille séparer avec les totaux de chaque produits par
mois

C'est tout bon

A bientôt

Merci


Rex



"Jacky" %
Bonjour,
Je voudrais que mes sous-totaux s'affiche en B pour chaque mois


En B il y a les montants Non???

Je te propose ceci
En C2
=SI(MOIS(A2)<>MOIS(A3);SOMMEPROD((MOIS($A$2:$A$100)=MOIS(A2))*$B$2:$B$100);"")
ou un tableau avec
=SOMMEPROD((MOIS($A$2:$A$101)ò)*$B$2:$B$101)
Voir ici
http://cjoint.com/?hgnv7CYFTd
--
Salutations
JJ


"rthompson" news: %23%
Bonjour à toutes et tous

Après une (rapide ) recherche ici et sur excelabo, je n'ai pas trouvé ce
que je cherche

Si dans une colonne A j'ai une série de dates et en colonne B des
montants
je voudrais faire des sous-totaux pour chaque mois

Exemple

1 A B
2 01/05/08 5
3 06/05/08 9
4 11/05/08 3
5 04/06/08 4
6 16/06/08 15
7 09/07/08 4
8 21/08/08 3
9 25/08/08 8


Je voudrais que mes sous-totaux s'affiche en B pour chaque mois
Ce que je fais pour le moment est ceci via macro,
mais je suis certains qu'il y a une solution plus élégante

D'avance merci à vous et bon dimanche

A lundi

Rex



xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Sub subtotalunits()
Columns("M:M").Select
Selection.NumberFormat = "mmm-yyyy"
Range("M5:S38").Select
Selection.Subtotal GroupBy:=1, Function:=xlSum, TotalList:=Array(7), _
Replace:=True, PageBreaks:úlse, SummaryBelowData:=True
Columns("M:M").Select
Selection.NumberFormat = "[$-80C]dd-mmm-yy;@"
End Sub
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx









rthompson
Le #11200671
Bonjour et merci

C'est également une solution

Mais j'ai décidé d'utiliser celle de Jacky
Je me suis fais une petite feuille supplémentaire ce qui, en plus,
me permet de faire d'autres analyses non-prévues au départ

A bientôt

Rex



"michdenis"
Si tu peux ajouter une colonne "Mois"
avec formule = Mois(A2) que tu recopies sur l'ensemble
de la plage. Tu masques cette colonne et là tu pourrras
faire tes regroupements avec la commande "Sous-totaux"
du menu données !



"rthompson" news: %23%
Bonjour à toutes et tous

Après une (rapide ) recherche ici et sur excelabo, je n'ai pas trouvé ce
que
je cherche

Si dans une colonne A j'ai une série de dates et en colonne B des montants
je voudrais faire des sous-totaux pour chaque mois

Exemple

1 A B
2 01/05/08 5
3 06/05/08 9
4 11/05/08 3
5 04/06/08 4
6 16/06/08 15
7 09/07/08 4
8 21/08/08 3
9 25/08/08 8


Je voudrais que mes sous-totaux s'affiche en B pour chaque mois
Ce que je fais pour le moment est ceci via macro,
mais je suis certains qu'il y a une solution plus élégante

D'avance merci à vous et bon dimanche

A lundi

Rex



xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Sub subtotalunits()
Columns("M:M").Select
Selection.NumberFormat = "mmm-yyyy"
Range("M5:S38").Select
Selection.Subtotal GroupBy:=1, Function:=xlSum, TotalList:=Array(7), _
Replace:=True, PageBreaks:úlse, SummaryBelowData:=True
Columns("M:M").Select
Selection.NumberFormat = "[$-80C]dd-mmm-yy;@"
End Sub
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx




Modeste
Le #11200791
Bonsour® rthompson avec ferveur ;o))) vous nous disiez :

Mais j'ai décidé d'utiliser celle de Jacky
Je me suis fais une petite feuille supplémentaire ce qui, en plus,
me permet de faire d'autres analyses non-prévues au départ



il y a aussi la méthode TCD

ainsi que la méthode SOMME.SI
=SOMME.SI($A$2:$A$27;N°Mois;$B$2:$B$27)

--
@+
;o)))
Modeste
Le #11200911
> ainsi que la méthode SOMME.SI
=SOMME.SI($A$2:$A$27;N°Mois;$B$2:$B$27)



en colonne C
C2=Mois(A2)
=SOMME.SI($C2:$C$27;N°Mois;$B$2:$B$27)





--
--
@+
;o)))
rthompson
Le #11200901
Bonjour Modeste (le retartadaire ;-)))


Et comme toujours des solutions étonnantes et simples

Oui, j'avais pensé au TDC, mais je ne joue pas encore à l'aise avec ce petit
bijou

Mais je m'y applique, et j'arrive parfois à faire des trucs pas mal

Le truc Somme.si
J'y avais pas pensé, et pour être franc
Quasi jamais utilisé, faudra que je m'y mette

Maintenant, il est temps de penser au souper
Petit bouillon de légumes, saumon avec sauce crevettes, croquettes et salade
le tout suivi de glace framboise-fraise-groseille

Et tout ça préparé par mes petites mains agiles

mmmmmmmmmmmmmmm!!!!!!!!!!

A lundi

Rex


PS

Ah oui, j'oubliais MERCI




"Modeste" %
Bonsour® rthompson avec ferveur ;o))) vous nous disiez :

Mais j'ai décidé d'utiliser celle de Jacky
Je me suis fais une petite feuille supplémentaire ce qui, en plus,
me permet de faire d'autres analyses non-prévues au départ



il y a aussi la méthode TCD

ainsi que la méthode SOMME.SI
=SOMME.SI($A$2:$A$27;N°Mois;$B$2:$B$27)

--
@+
;o)))
Jacky
Le #11201211
Bonjour Modeste

=SOMME.SI($A$2:$A$27;N°Mois;$B$2:$B$27)




Hummm!!!
L'Alsacien :-) à un doute sur cette formule
;o))

--
Salutations
JJ


"Modeste" %
Bonsour® rthompson avec ferveur ;o))) vous nous disiez :

Mais j'ai décidé d'utiliser celle de Jacky
Je me suis fais une petite feuille supplémentaire ce qui, en plus,
me permet de faire d'autres analyses non-prévues au départ



il y a aussi la méthode TCD

ainsi que la méthode SOMME.SI
=SOMME.SI($A$2:$A$27;N°Mois;$B$2:$B$27)

--
@+
;o)))
Publicité
Poster une réponse
Anonyme