soustraire des nombres

Le
Philippe Oysel
Bonjour à tous,
En colonne A j'ai des heures (croissantes) mais qui peuvent être séparés par
des cellules vides.
En colonne B je voudrais en regard de chaque cellule (où il y a une heure)
avoir la différence des 2 dernières cellules de la colonne A
Un petit exemple sera sans doute mieux parlant


A B
1 12:00
2
3
4 12:10 00:10
5 12:25 00:15
6
7
8
9 12:37 00:12
10
etc

Avec les fonctions j'ai essayé en recherchant la dernière cellule mais ça me
recalcule tout.
Peut-être en VBA avec une boucle ? Je ne sais pas faire.
Papy (60 ans) n'est pas doué et vous remercie de vos conseils
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
billy bob
Le #5242441
Bonjour,

la formule suivante en colonne B et à partir de la deuxième ligne :

=SI(ET(A2<>"";NON(ESTERREUR(RECHERCHEV(1;$A$1:A1;1;1))));A2 -
RECHERCHEV(1;$A$1:A1;1;1);"")

me semble répondre à ton problème

BB
billy bob
Le #5242431
Bonjour,

la formule suivante en colonne B et à partir de la 2e ligne

=SI(ET(A2<>"";NON(ESTERREUR(RECHERCHEV(1;$A$1:A1;1;1))));A2 -
RECHERCHEV(1;$A$1:A1;1;1);"")

semble répondre à ton problème

BB
JB
Le #5242411
Bonjour,

Simplifié(en B2): =SI(A2<>"";A2 - RECHERCHE(999;$A$1:A1);"")

JB

On 21 fév, 16:08, billy bob
Bonjour,

la formule suivante en colonne B et à partir de la deuxième ligne :

=SI(ET(A2<>"";NON(ESTERREUR(RECHERCHEV(1;$A$1:A1;1;1))));A2 -
RECHERCHEV(1;$A$1:A1;1;1);"")

me semble répondre à ton problème

BB


billy bob
Le #5242361
Snif,on m'a simplifié...

Pour justification la partie NON(ESTERREUR(....) permet de
s'affranchir d'une erreur dans le cas où la première valeur remplie ne
serait pas sur la première ligne

exple :

A B
1
2
3
4 12:10
5 12:25 00:15
6
7
8
9 12:37 00:12
10
etc...

Pour précision je ne suis pas susceptible, mais un peu soupe au lait


On 21 fév, 16:58, JB
Bonjour,

Simplifié(en B2): =SI(A2<>"";A2 - RECHERCHE(999;$A$1:A1);"")

JB



Philippe Oysel
Le #5241661
Je n'ai qu'un mot à dire :
BRAVO
C'est exactement ce que je voulais. Mais comment faites-vous ?
Merci à JB et billy bob de leur rapidité et de leurs connaissances.
Et bravo aussi pour ce forum que je consulte régulièrement, où je trouve de
vraies réponses (c'est pas le cas partout)
Philippe



"billy bob" news:
Bonjour,

la formule suivante en colonne B et à partir de la 2e ligne

=SI(ET(A2<>"";NON(ESTERREUR(RECHERCHEV(1;$A$1:A1;1;1))));A2 -
RECHERCHEV(1;$A$1:A1;1;1);"")

semble répondre à ton problème

BB
Publicité
Poster une réponse
Anonyme