SQL server 205 : reporting services : impossible de rafrachir un reporting

Le
Blodine
Bonjour,
J'utilisais mesnuellement un reporting qui fonctionnait correctement
jusqu'à dernièrement.

impossible de rafraichir un reporting ni depuis IE, ni sous visual studio,
ni avec un abonnement:

- sous IE --> après un certain temps --> message traitement annulé par
l'utilisateur
- sous visual studio --> toujours en exécution après +sieurs heures
- avec un abonnement --> une erreur s'est produite lors du traitement de
rapport

et pourtant quand je lance la requête sql directement sous MAnagement
studion elle aboutit après 1 minute 40 secondes, ce qui me semble
convenable. pour info : la requête ramène 8000 lignes.

J'ai testé les points suivants :
J'ai créé tans une table résultat de la requête . J'ai modifé la requête de
mon reporting afin d'interroger directement cette table intermédiaire. Et
bizarrement cela fonctionne je ne comprends pas pourquoi le reporting ne
fonctionne pas avec la requête initiale. La solution de la table
intermédiaire ne pouvant pas être envisagée.

Avez-vous une idée du problème ? réglage de reporting services ?

merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Blodine
Le #21403761
Complément : le reporting possède des paramètres de rapport servant à la
requête. En remplaçant les paramètres par des conditions en dur dans la
requête, il n' y a plus de problème ! mais cela ne répond pas aux besoins.
Avez-vous une idée comment régler le problème ?

merci


"Blodine" news:
Bonjour,
J'utilisais mesnuellement un reporting qui fonctionnait correctement
jusqu'à dernièrement.

impossible de rafraichir un reporting ni depuis IE, ni sous visual studio,
ni avec un abonnement:

- sous IE --> après un certain temps --> message traitement annulé par
l'utilisateur
- sous visual studio --> toujours en exécution après +sieurs heures
- avec un abonnement --> une erreur s'est produite lors du traitement de
rapport

et pourtant quand je lance la requête sql directement sous MAnagement
studion elle aboutit après 1 minute 40 secondes, ce qui me semble
convenable. pour info : la requête ramène 8000 lignes.

J'ai testé les points suivants :
J'ai créé tans une table résultat de la requête . J'ai modifé la requête
de mon reporting afin d'interroger directement cette table intermédiaire.
Et bizarrement cela fonctionne je ne comprends pas pourquoi le reporting
ne fonctionne pas avec la requête initiale. La solution de la table
intermédiaire ne pouvant pas être envisagée.

Avez-vous une idée du problème ? réglage de reporting services ?

merci

Patrice
Le #21412251
Comme "une erreur s'est produite pendant le traitement du rapport", aller
voir dans les journaux de Reporting Services ce qui devrait donner des
indications sur l'erreur...

--
Patrice

"Blodine" news:OF%
Complément : le reporting possède des paramètres de rapport servant à la
requête. En remplaçant les paramètres par des conditions en dur dans la
requête, il n' y a plus de problème ! mais cela ne répond pas aux besoins.
Avez-vous une idée comment régler le problème ?

merci


"Blodine" news:
Bonjour,
J'utilisais mesnuellement un reporting qui fonctionnait correctement
jusqu'à dernièrement.

impossible de rafraichir un reporting ni depuis IE, ni sous visual
studio, ni avec un abonnement:

- sous IE --> après un certain temps --> message traitement annulé par
l'utilisateur
- sous visual studio --> toujours en exécution après +sieurs heures
- avec un abonnement --> une erreur s'est produite lors du traitement de
rapport

et pourtant quand je lance la requête sql directement sous MAnagement
studion elle aboutit après 1 minute 40 secondes, ce qui me semble
convenable. pour info : la requête ramène 8000 lignes.

J'ai testé les points suivants :
J'ai créé tans une table résultat de la requête . J'ai modifé la requête
de mon reporting afin d'interroger directement cette table intermédiaire.
Et bizarrement cela fonctionne je ne comprends pas pourquoi le reporting
ne fonctionne pas avec la requête initiale. La solution de la table
intermédiaire ne pouvant pas être envisagée.

Avez-vous une idée du problème ? réglage de reporting services ?

merci




Publicité
Poster une réponse
Anonyme