Squeeze : plus de wifi après mise à jour

Le
pascatgm
Bonsoir,

Le sujet n'est pas très original mais même après 3-4 jours de recherches
je n'arrive pas à faire fonctionner de nouveau le wifi qui s'est
interrompu brutalement pendant la mise à jour jeudi soir

Sur un Compaq HP ss Squeeze , carte : Intel Pro Wireless 3945ABG (lspci).

lsmod | grep iw
iwl3945 46032 0
iwlcore 67478 1 iwl3945
mac80211 12343 2 iwl3945,iwlcore
cfg80211 87657 3 iwl3945,iwlcore,mac80211
led_class 1757 3 iwl3945,iwlcore, hp_accel



dans /etc/network/interfaces
iface wlan0 inet static
address 192.168.1.17
netmask 255.255.255.0
broadcast 192.168.1.255
network 192.168.1.0
gateway 192.168.1.1
wireless-essid XXX
wireless-key XXX

iwconfig me montre l'ESSID, le mac de la box, la cléBref la carte
est associée.

route -n
Destination Passerelle Genmask Indic Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0

j'ai une ligne (je ne sais pas d'où elle sort) avec la même chose sauf
192.169.254.0.0 et une Metric de 1000
puis la ligne définissant la passerelle normale

lorsque j'essaie de pinger la box j'obtiens un "Destination Host
Unreachable"

J'ai desactivé le NetworkManager, essayé de relancer en DHCP mais rien
n'y fait

Je ne vois pas très bien quoi faire.

Merci d'avance pour votre aide.

P.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/4D348BFD.2080003@gmail.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 4
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Thierry Chatelet
Le #23030261
On Monday 17 January 2011 19:35:41 pascatgm wrote:
Bonsoir,

Le sujet n'est pas très original mais même après 3-4 jours de reche rches
je n'arrive pas à faire fonctionner de nouveau le wifi qui s'est
interrompu brutalement pendant la mise à jour jeudi soir...

Sur un Compaq HP ss Squeeze , carte : Intel Pro Wireless 3945ABG (lspci).

lsmod | grep iw
iwl3945 46032 0
iwlcore 67478 1 iwl3945
mac80211 12343 2 iwl3945,iwlcore
cfg80211 87657 3 iwl3945,iwlcore,mac80211
led_class 1757 3 iwl3945,iwlcore, hp_accel



dans /etc/network/interfaces
iface wlan0 inet static
address 192.168.1.17
netmask 255.255.255.0
broadcast 192.168.1.255
network 192.168.1.0
gateway 192.168.1.1
wireless-essid XXX
wireless-key XXX

iwconfig me montre l'ESSID, le mac de la box, la clé...Bref la carte
est associée.

route -n
Destination Passerelle Genmask Indic Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0
wlan0

j'ai une ligne (je ne sais pas d'où elle sort) avec la même chose sauf
192.169.254.0.0 et une Metric de 1000
puis la ligne définissant la passerelle normale...

lorsque j'essaie de pinger la box j'obtiens un "Destination Host
Unreachable"

J'ai desactivé le NetworkManager, essayé de relancer en DHCP mais rien
n'y fait...

Je ne vois pas très bien quoi faire.

Merci d'avance pour votre aide.

P.




Juste une info, tous mes systèmes avec network-manager sont tombés en r ade
après une maj de fin de semaine, même ceux cablés. Les seuls qui n'on t pas eu
de problème sont ceux installés avec wicd. Comme j'avais un CD avec tou s ce
qu'il faut pour l' installer, ben.. j'ai pas cherché plus loin.
Thierry

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
pascatgm
Le #23030731
Thierry Chatelet a écrit :
On Monday 17 January 2011 19:35:41 pascatgm wrote:

Bonsoir,

Le sujet n'est pas très original mais même après 3-4 jours de recherches
je n'arrive pas à faire fonctionner de nouveau le wifi qui s'est
interrompu brutalement pendant la mise à jour jeudi soir...

Sur un Compaq HP ss Squeeze , carte : Intel Pro Wireless 3945ABG (lspci).

lsmod | grep iw
iwl3945 46032 0
iwlcore 67478 1 iwl3945
mac80211 12343 2 iwl3945,iwlcore
cfg80211 87657 3 iwl3945,iwlcore,mac80211
led_class 1757 3 iwl3945,iwlcore, hp_accel



dans /etc/network/interfaces
iface wlan0 inet static
address 192.168.1.17
netmask 255.255.255.0
broadcast 192.168.1.255
network 192.168.1.0
gateway 192.168.1.1
wireless-essid XXX
wireless-key XXX

iwconfig me montre l'ESSID, le mac de la box, la clé...Bref la carte
est associée.

route -n
Destination Passerelle Genmask Indic Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0
wlan0

j'ai une ligne (je ne sais pas d'où elle sort) avec la même chose sauf
192.169.254.0.0 et une Metric de 1000
puis la ligne définissant la passerelle normale...

lorsque j'essaie de pinger la box j'obtiens un "Destination Host
Unreachable"

J'ai desactivé le NetworkManager, essayé de relancer en DHCP mais rien
n'y fait...

Je ne vois pas très bien quoi faire.

Merci d'avance pour votre aide.

P.





Juste une info, tous mes systèmes avec network-manager sont tombés en rade
après une maj de fin de semaine, même ceux cablés. Les seuls qui n'ont pas eu
de problème sont ceux installés avec wicd. Comme j'avais un CD avec tous ce
qu'il faut pour l' installer, ben.. j'ai pas cherché plus loin.
Thierry




Ca ne fait que confirmer la cause.
Mais ce que je ne comprends pas c'est pourquoi la configuration
"manuelle", une fois networkManager désactivé, ne fonctionne pas...
Et où se trouve le problème...
P.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Pierre Meurisse
Le #23030931
Bonjour,

On Mon, Jan 17, 2011 at 07:35:41PM +0100, pascatgm wrote:

Bonsoir,

Le sujet n'est pas très original mais même après 3-4 jours de recherches
je n'arrive pas à faire fonctionner de nouveau le wifi qui s'est
interrompu brutalement pendant la mise à jour jeudi soir...




as-tu installé le paquet firmware-linux ?


--
Pierre Meurisse

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Jean-Yves F. Barbier
Le #23033261
On Wed, 19 Jan 2011 00:19:37 +0100, pascatgm

...
Pourtant ça ne fonctionne toujours pas.
Avec/Sans Network-manager, en DHCP ou en static rien ne semble marcher...
En DHCP "No DHCPOFFERS" received et le traditionnel "No working leases
in persistent database".
En static, lorsque je ping la live box toujours la même réponse :
ping 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
FROM 192.168.1.55 icmp_seq=1 Destination Host Unreachable



existe-t'il une route valide?

--
In which level of metalanguage are you now speaking?

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
pascatgm
Le #23033251
Pierre Meurisse a écrit :
Bonjour,

On Mon, Jan 17, 2011 at 07:35:41PM +0100, pascatgm wrote:

Bonsoir,

Le sujet n'est pas très original mais même après 3-4 jours de recherches
je n'arrive pas à faire fonctionner de nouveau le wifi qui s'est
interrompu brutalement pendant la mise à jour jeudi soir...





as-tu installé le paquet firmware-linux ?





Bonsoir
Lors de la mise à jour de ce soir (en Ethernet) le paquet
firmware-iwlwifi a été installé/mis à jour...Donc je pense que de ce
côté c'est bon.
Pourtant ça ne fonctionne toujours pas.
Avec/Sans Network-manager, en DHCP ou en static rien ne semble marcher...
En DHCP "No DHCPOFFERS" received et le traditionnel "No working leases
in persistent database".
En static, lorsque je ping la live box toujours la même réponse :
ping 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
FROM 192.168.1.55 icmp_seq=1 Destination Host Unreachable
...
^C
Et ceci sans règle iptables...Rien qui puisse gèner le traffic.
Je sèche...
Merci de votre aide éventuelle
P.G.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
pascatgm
Le #23033621
Jean-Yves F. Barbier a écrit :
On Wed, 19 Jan 2011 00:19:37 +0100, pascatgm

...

Pourtant ça ne fonctionne toujours pas.
Avec/Sans Network-manager, en DHCP ou en static rien ne semble marcher...
En DHCP "No DHCPOFFERS" received et le traditionnel "No working leases
in persistent database".
En static, lorsque je ping la live box toujours la même réponse :
ping 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
FROM 192.168.1.55 icmp_seq=1 Destination Host Unreachable




existe-t'il une route valide?




Au niveau route tout semble ok aussi comme je l'indiquais dans le mail
initial
route -n me renvoie bien la "route" vers 192.168.1.0 comme indiqué ds le
mail d'origine, vers l'extérieur via la passerelle (LB). J' ai bien le
169.254.0.0 (ou link-local sans le switch "-n") qui apparemment est
normal (bien que je n'en comprenne pas la signification).
Par contre j'ai trouvé ça :
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug`9450
Mais le "contournement" du bug par celui qui le signale est
assez...étrange : pas trouvé le noyau dont il parle.
Et j'ai également trouvé la trace d'une incompatibilité entre le driver
de la carte wifi et celui des cartes radeon. Mais j'ai une intel sur cet
HP (même si j'ai étrangement les "radeon-tools" d'installés)
Voilà où j'en suis...
Merci de votre aide.
P.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Daniel Huhardeaux
Le #23033731
Le 19/01/2011 09:16, pascatgm a écrit :
[...]
existe-t'il une route valide?





Au niveau route tout semble ok aussi comme je l'indiquais dans le mail
initial
route -n me renvoie bien la "route" vers 192.168.1.0 comme indiqué ds le
mail d'origine, vers l'extérieur via la passerelle (LB).



[...]

Mouais. 192.168.1.0 est une adresse de réseau. As tu une ligne

0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0
wlan0 ou
default gw 0.0.0.0 UG 0 0 0
wlan0

Dans cet exemple gw est le hostname de 192.168.1.1 qui serait l'IP de la
passerelle et wlan0 est l'interface réseau wifi. Il ne doit y avoir
qu'une seule route par défaut.

--
Daniel

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
pascatgm
Le #23034081
Daniel Huhardeaux a écrit :
Le 19/01/2011 09:16, pascatgm a écrit :
[...]
existe-t'il une route valide?





Au niveau route tout semble ok aussi comme je l'indiquais dans le mail
initial
route -n me renvoie bien la "route" vers 192.168.1.0 comme indiqué ds le
mail d'origine, vers l'extérieur via la passerelle (LB).



[...]

Mouais. 192.168.1.0 est une adresse de réseau. As tu une ligne


Pourquoi "Mouais" ? :)...Je sais bien que c'est une adresse réseau...

0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0
wlan0 ou
default gw 0.0.0.0 UG 0 0
0 wlan0

Dans cet exemple gw est le hostname de 192.168.1.1 qui serait l'IP de
la passerelle et wlan0 est l'interface réseau wifi. Il ne doit y avoir
qu'une seule route par défaut.



Et oui j'ai...La première...Et bien qu'une seule route par défaut...
P.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
corbie
Le #23035181
Bonjour,

En rajoutant cette ligne dans le fichier "grub.cfg" :

pnpbios=off pci=biosirq acpi=force irqpol

Le wifi fonctionne t-il ?

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
pascatgm
Le #23039301
a écrit :
Bonjour,

En rajoutant cette ligne dans le fichier "grub.cfg" :

pnpbios=off pci=biosirq acpi=force irqpol

Le wifi fonctionne t-il ?




Bonsoir et désolé du retard. Je n'ai put regarder le pb à nouveau que ce
soir.
J'ai passé les options au démarrage. Mais ça ne change rien au problème
qui reste le même...
Carte associée, mais pas moyen de pinger ne serait-ce que la passerelle...
Je n'ai toujours pas de solution...
P.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme