Squeeze et souris série

Le
Guy Roussin
Bonjour,

Nous disposons d'une salle de formation équipée de PC qui utilisent
un dispositif pédagogique qui impose l'utilisation de souris série.
Les PC fonctionnent en double démarrage windows/debian.
Pas de problème avec windows 7 et debian lenny.
Mais rien à faire avec squeeze qui ne réagit pas à la souris séri=
e sous X.
J'ai dans /etc/X11/xorg.conf une section pour cette souris (fonctionne
avec lenny):
Section "InputDevice"
Identifier "Serial Mouse"
Driver "mouse"
Option "CorePointer"
#Option "Protocol" "auto"
Option "Protocol" "IntelliMouse"
Option "Device" "/dev/ttyS0"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
#Option "Emulate3Timeout" "70"
#Option "SendCoreEvents" "true"
EndSection
J'ai essayé de jouer (en aveugle) avec quelques options de cette
section (http://www.x.org/archive/X11R7.5/doc/man/man4/mousedrv.4.html)
sans succès. La souris ne bouge pas

Le /dev/ttyS0 est bien actif
J'arrive à faire fonctionner gpm avec par exemple :
gpm -m /dev/ttyS0
ou
gpm -m /dev/ttyS0 -t ms3

Rien d'utile dans les logs.

Si vous avez une idée

Merci

--
Guy

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/4D9D8BFF.2090504@teledetection.fr
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
steve
Le #23265571
Le 07-04-2011, à 12:03:43 +0200, Guy Roussin () a écrit :

Bonjour,

Nous disposons d'une salle de formation équipée de PC qui utilisent
un dispositif pédagogique qui impose l'utilisation de souris série.
Les PC fonctionnent en double démarrage windows/debian.
Pas de problème avec windows 7 et debian lenny.
Mais rien à faire avec squeeze qui ne réagit pas à la souris série sous X.
J'ai dans /etc/X11/xorg.conf une section pour cette souris (fonctionne
avec lenny):
Section "InputDevice"
Identifier "Serial Mouse"
Driver "mouse"
Option "CorePointer"
#Option "Protocol" "auto"
Option "Protocol" "IntelliMouse"
Option "Device" "/dev/ttyS0"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
#Option "Emulate3Timeout" "70"
#Option "SendCoreEvents" "true"
EndSection
J'ai essayé de jouer (en aveugle) avec quelques options de cette
section (http://www.x.org/archive/X11R7.5/doc/man/man4/mousedrv.4.html)
sans succès. La souris ne bouge pas ...

Le /dev/ttyS0 est bien actif
J'arrive à faire fonctionner gpm avec par exemple :
gpm -m /dev/ttyS0
ou
gpm -m /dev/ttyS0 -t ms3

Rien d'utile dans les logs.

Si vous avez une idée ...



Peut-être : virer le xorg.conf ? Sous squeeze, il n'est plus utile
normalement.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Christophe Maquaire
Le #23265551
--=-TwwUORU2x2ezzuzDgWXz
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable

Le jeudi 07 avril 2011 à 12:03 +0200, Guy Roussin a écrit :
Bonjour,


Bonjour

Rien d'utile dans les logs.

Si vous avez une idée ...


Voir du côté d'inputattach, peut-être.

Merci


De rien,
--
Guy


Christophe


--=-TwwUORU2x2ezzuzDgWXz
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: This is a digitally signed message part

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iEYEABECAAYFAk2dkJYACgkQqkyGLxsLDsycTQCfQOB8m5l/n7niSyw0BgvaQWr5
20IAoKS7ZPtool7vthPGbnKuGTuZWZz6
=xFaz
-----END PGP SIGNATURE-----

--=-TwwUORU2x2ezzuzDgWXz--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Pascal Le Bris
Le #23265561
Le 04/07/11 12:14, steve a écrit :
Le 07-04-2011, à 12:03:43 +0200, Guy Roussin () a écrit :


Bonjour,

Nous disposons d'une salle de formation équipée de PC qui utilisent
un dispositif pédagogique qui impose l'utilisation de souris série.
Les PC fonctionnent en double démarrage windows/debian.
Pas de problème avec windows 7 et debian lenny.
Mais rien à faire avec squeeze qui ne réagit pas à la souris série sous X.
J'ai dans /etc/X11/xorg.conf une section pour cette souris (fonctionne
avec lenny):
Section "InputDevice"
Identifier "Serial Mouse"
Driver "mouse"
Option "CorePointer"
#Option "Protocol" "auto"
Option "Protocol" "IntelliMouse"
Option "Device" "/dev/ttyS0"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
#Option "Emulate3Timeout" "70"
#Option "SendCoreEvents" "true"
EndSection
J'ai essayé de jouer (en aveugle) avec quelques options de cette
section (http://www.x.org/archive/X11R7.5/doc/man/man4/mousedrv.4.html)
sans succès. La souris ne bouge pas ...

Le /dev/ttyS0 est bien actif
J'arrive à faire fonctionner gpm avec par exemple :
gpm -m /dev/ttyS0
ou
gpm -m /dev/ttyS0 -t ms3

Rien d'utile dans les logs.

Si vous avez une idée ...



Peut-être : virer le xorg.conf ? Sous squeeze, il n'est plus utile
normalement.




Bonjour
Plus utile ?
Pour ma part j'ai effectivement des config sans xorg.conf, mais
également avec en suivant : http://wiki.debian.org/Xorg

Cdlt

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bernard Schoenacker
Le #23265711
Le Thu, 07 Apr 2011 12:03:43 +0200,
Guy Roussin
Bonjour,

Nous disposons d'une salle de formation équipée de PC qui utilisent
un dispositif pédagogique qui impose l'utilisation de souris série.
Les PC fonctionnent en double démarrage windows/debian.
Pas de problème avec windows 7 et debian lenny.
Mais rien à faire avec squeeze qui ne réagit pas à la souris série
sous X. J'ai dans /etc/X11/xorg.conf une section pour cette souris
(fonctionne avec lenny):
Section "InputDevice"
Identifier "Serial Mouse"
Driver "mouse"
Option "CorePointer"
#Option "Protocol" "auto"
Option "Protocol" "IntelliMouse"
Option "Device" "/dev/ttyS0"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
#Option "Emulate3Timeout" "70"
#Option "SendCoreEvents" "true"
EndSection
J'ai essayé de jouer (en aveugle) avec quelques options de cette
section
(http://www.x.org/archive/X11R7.5/doc/man/man4/mousedrv.4.html) sans
succès. La souris ne bouge pas ...

Le /dev/ttyS0 est bien actif
J'arrive à faire fonctionner gpm avec par exemple :
gpm -m /dev/ttyS0
ou
gpm -m /dev/ttyS0 -t ms3

Rien d'utile dans les logs.

Si vous avez une idée ...

Merci




bonjour,

la première solution basique :

grep sermouse /etc/modules
grep mouse /etc/modules

mousedev
psmouse

après, serait il possible de vérifier les paquets :

mouseemu - Emulate mouse buttons and mouse wheel
xserver-xorg-input-mouse - Serveur X X.Org - pilote de souris

cf : apt-cache search mouse


slt
bernard


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Guy Roussin
Le #23265911
Peut-être : virer le xorg.conf ? Sous squeeze, il n'est plus utile
normalement.



Non, ça ne résout pas le problème.

Nous utilisons les drivers proprio nvidia pour nos cartes Quadro fx.
Donc on est un peu obligé d'avoir un fichier xorg.conf.
Si j'enlève le fichier xorg.conf, c'est le driver nouveau qui est ut ilisé
et l'affichage est très dégradé (quasi illisible). Et surt out, la souris
série ne fonctionne pas.

Merci.

Guy

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Guy Roussin
Le #23265951
Si vous avez une idée ...


Voir du côté d'inputattach, peut-être.



bingo !

J'ai tapé "inputattach -ms3 /dev/ttyS0" en console
et maintenant j'ai la souris qui bouge sous X !

Je vais explorer ça dans le détail.
Merci pour cette piste *très* intéressante.

Guy

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme