suppression RAID (kubuntu 8.10)

Le
Philippe
Bonjour,


Sur les versions précedentes, pas de soucis, deux disques sur une
carte PATA sur slot PCI étaient vus comme je le souhaite, de façon
indépendante et sans utiliser la possibilité de fonctionnement en RAID.

Le problème: une installation nouvelle de kubuntu 8.10 où je
n'arrive plus a monter les partition ntfs et ext3 de ces deux disques.

Le système comporte un disque SATA directement sur la carte mère, un
dvdrom PATA directement sur la carte mère itou et ces deux disques sur
une carte PSI PATA capable de fairre du RAID. Pour l'anecdote, ces deux
disques sont identiques.

Je n'envisage pas de les utiliser en RAID, je souhaite conserver un
mélange ntfs/ext3 (en ext3, c'était du test de différentes
distributions).

La question: comment retrouver un fonctionnement qui ignore la
possibilité de fonctionnement en RAID de la carte et de ses deux
disques?

merci pour l'aide

copie de ce que répond lsmod:

début
Module Size Used by
nvidia 6909268 0
usb_storage 82752 0
libusual 30356 1 usb_storage
af_packet 25728 2
rfcomm 44432 0
sco 18308 2
bridge 56980 0
stp 10628 1 bridge
bnep 20480 2
l2cap 30464 6 rfcomm,bnep
bluetooth 61924 6 rfcomm,sco,bnep,l2cap
ipv6 263972 18
ppdev 15620 0
cpufreq_powersave 9856 0
cpufreq_userspace 11396 0
cpufreq_ondemand 14988 0
cpufreq_conservative 14600 0
cpufreq_stats 13188 0
freq_table 12672 2 cpufreq_ondemand,cpufreq_stats
wmi 14504 0
video 25232 0
output 11008 1 video
sbs 19464 0
sbshc 13440 1 sbs
container 11520 0
pci_slot 12680 0
battery 18436 0
iptable_filter 10752 0
ip_tables 19600 1 iptable_filter
x_tables 22916 1 ip_tables
nls_iso8859_1 12032 1
nls_cp437 13696 1
vfat 18816 1
fat 57376 1 vfat
dm_crypt 21124 0
crypto_blkcipher 25476 1 dm_crypt
ac 12292 0
lp 17156 0
loop 23180 0
snd_hda_intel 384176 3
snd_pcm_oss 46848 0
snd_mixer_oss 22784 1 snd_pcm_oss
snd_pcm 83204 2 snd_hda_intel,snd_pcm_oss
snd_seq_dummy 10884 0
snd_seq_oss 38528 0
snd_seq_midi 14336 0
snd_rawmidi 29824 1 snd_seq_midi
snd_seq_midi_event 15232 2 snd_seq_oss,snd_seq_midi
pcspkr 10624 0
snd_seq 57776 6
snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 29960 2 snd_pcm,snd_seq
snd_seq_device 15116 5
snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
k8temp 12416 0
evdev 17696 9
snd 63268 15
snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore 15328 1 snd
snd_page_alloc 16136 2 snd_hda_intel,snd_pcm
parport_pc 39204 1
parport 42604 3 ppdev,lp,parport_pc
button 14224 0
ati_agp 14988 0
agpgart 42184 2 nvidia,ati_agp
shpchp 38036 0
pci_hotplug 34976 1 shpchp
i2c_piix4 16144 0
i2c_core 31892 2 nvidia,i2c_piix4
ext3 133256 2
jbd 55828 1 ext3
mbcache 16004 1 ext3
usbhid 35840 0
hid 50560 1 usbhid
sr_mod 22212 0
cdrom 43168 1 sr_mod
ata_generic 12932 0
pata_acpi 12160 0
sd_mod 42392 8
crc_t10dif 9984 1 sd_mod
sg 39732 0
ehci_hcd 43788 0
ohci_hcd 32016 0
pata_atiixp 12800 0
ahci 37132 5
pata_sil680 14084 2
usbcore 149360 6
usb_storage,libusual,usbhid,ehci_hcd,ohci_hcd
libata 178208 5
ata_generic,pata_acpi,pata_atiixp,ahci,pata_sil680
scsi_mod 155212 5 usb_storage,sr_mod,sd_mod,sg,libata
dock 16656 1 libata
r8169 36100 0
mii 13440 1 r8169
thermal 23708 0
processor 42156 1 thermal
fan 12548 0
fbcon 47648 0
tileblit 10880 1 fbcon
font 16512 1 fbcon
bitblit 13824 1 fbcon
softcursor 9984 1 bitblit
fuse 60828 3
dm_raid4_5 73996 0
dm_region_hash 19456 1 dm_raid4_5
dm_mem_cache 12800 1 dm_raid4_5
dm_message 11008 1 dm_raid4_5
dm_mirror 27008 0
dm_log 17924 3 dm_raid4_5,dm_region_hash,dm_mirror
dm_mod 63432 9 dm_crypt,dm_raid4_5,dm_mirror,dm_log
fin==



--
« Si tous les poètes voulaient se donner la main, ils toucheraient enfin
des doigts d'auteur! »
Philippe Vessaire Ò¿Ó¬
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
droopy191
Le #18760751
Philippe wrote:
Bonjour,



Salut,


Sur les versions précedentes, pas de soucis, deux disques sur une
carte PATA sur slot PCI étaient vus comme je le souhaite, de façon
indépendante et sans utiliser la possibilité de fonctionnement en RAID.

Le problème: une installation nouvelle de kubuntu 8.10 où je
n'arrive plus a monter les partition ntfs et ext3 de ces deux disques.




C'est à dire, quel est le message d'erreur ?

Que donne sudo fdisk -l ?




--
DR
Philippe
Le #18763311
droopy191 a écrit:

C'est à dire, quel est le message d'erreur ?


mount: /dev/sdc2 est déjà monté ou /media/archive-lin est occupé


Que donne sudo  fdisk -l ?


Disque /dev/sda: 320.0 Go, 320072933376 octets
255 heads, 63 sectors/track, 38913 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Identifiant disque: 0x0000ba16

Périphérique Amorce Début Fin Blocs Id Système
/dev/sda1 * 1 2444 19625728+ 7 HPFS/NTFS
La partition 1 ne se termine pas sur une frontière de cylindre.
/dev/sda2 2445 38913 292937242+ 5 Extended
La partition 2 ne se termine pas sur une frontière de cylindre.
/dev/sda5 2445 6103 29390886 83 Linux
/dev/sda6 6104 30418 195310206 83 Linux
/dev/sda7 30419 38564 65432713+ b W95 FAT32
/dev/sda8 38565 38913 2803311 82 Linux swap

Disque /dev/sdb: 123.5 Go, 123522416640 octets
255 heads, 63 sectors/track, 15017 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Identifiant disque: 0xa641015f

Périphérique Amorce Début Fin Blocs Id Système
/dev/sdb1 1 15017 120624021 7 HPFS/NTFS

Disque /dev/sdc: 123.5 Go, 123522416640 octets
255 heads, 63 sectors/track, 15017 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Identifiant disque: 0x74410170

Périphérique Amorce Début Fin Blocs Id Système
/dev/sdc1 1 4500 36146218+ 83 Linux
/dev/sdc2 4501 15017 84477802+ 83 Linux


--
« Si tous les poètes voulaient se donner la main, ils toucheraient enfin
des doigts d'auteur! »
Philippe Vessaire Ò¿Ó¬
droopy191
Le #18763691
Philippe wrote:
droopy191 a écrit:

C'est à dire, quel est le message d'erreur ?


mount: /dev/sdc2 est déjà monté ou /media/archive-lin est occupé




justement, ce disque n'est il pas dejà correctement monté ?
Vous voyez qq chose dans /media/archive-lin ?

que disent /etc/mtab et /etc/fstab

Que se passe t'il si vous demontez et remontez le disque à la main ?



Que donne sudo fdisk -l ?
Disque /dev/sdc: 123.5 Go, 123522416640 octets


255 heads, 63 sectors/track, 15017 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Identifiant disque: 0x74410170

Périphérique Amorce Début Fin Blocs Id Système
/dev/sdc1 1 4500 36146218+ 83 Linux
/dev/sdc2 4501 15017 84477802+ 83 Linux





RAS ici, sauf erreur de ma part, le raid dont vous parliez n'a rien à
faire dans l'histoire. on voit bien 2 disques et des partitions distinctes.



--
DR
Philippe
Le #18766311
droopy191 a fait l'effort d'écrire:

RAS ici, sauf erreur de ma part, le raid dont vous parliez n'a rien à
faire dans l'histoire. on voit bien 2 disques et des partitions


distinctes.

J'ai vérifié l'UUID, qui est obtenue avec la commande qui va bien...
Je cherche du coté de fuse..... rien trouvé encore.

a la main, test est forcément vide et libre, créé pour l'occasion:
:~# umount /dev/sdc2
umount: /dev/sdc2: n'est pas monté
:~# mount -t ext3 /dev/sdc2 /media/test
mount: /dev/sdc2 est déjà monté ou /media/test est occupé
:~# umount /dev/sdc2
umount: /dev/sdc2: n'est pas monté

ni sdb1 (ntfs) ni sdb2 (ext3) ne sont visibles dans mtab. Rien dans
/media/archive-lin ni /media/archive-b1


fstab


# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda5
UUIDÐ29a797-4147-4ec1-96a2-cb93026a5281 / ext3
relatime,errors=remount-ro 0 1
# /dev/sda6
UUIDšfcc79f-e2ba-4efc-8d09-1742a7acc648 /home ext3
relatime 0 2
# /dev/sdb1
UUID 7C94FE7C94D080 /media/archive-b1 ntfs
defaults,umask7,gidF 0 1
# /dev/sdc2
UUIDbdd156-35bb-4575-804e-d72b33ace65a /media/archive-lin ext3
relatime 0 2
# /dev/sda7
UUIDòD9-0F61 /media/fat32 vfat sync,quiet,utf8,umask7,gidF
0 1
# /dev/sda1
UUID4844FD4844ED4D /media/windows ntfs defaults,umask7,gidF
0 1
# /dev/sda8
UUID>f5ea36-72d8-428f-b153-6ee8f67f714d none swap sw
0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0
0

mtab


/dev/sda5 / ext3 rw,relatime,errors=remount-ro 0 0
tmpfs /lib/init/rw tmpfs rw,nosuid,mode55 0 0
/proc /proc proc rw,noexec,nosuid,nodev 0 0
sysfs /sys sysfs rw,noexec,nosuid,nodev 0 0
varrun /var/run tmpfs rw,nosuid,mode55 0 0
varlock /var/lock tmpfs rw,noexec,nosuid,nodev,mode77 0 0
udev /dev tmpfs rw,mode55 0 0
tmpfs /dev/shm tmpfs rw,nosuid,nodev 0 0
devpts /dev/pts devpts rw,noexec,nosuid,gid=5,modeb0 0 0
fusectl /sys/fs/fuse/connections fusectl rw 0 0
lrm /lib/modules/2.6.27-11-generic/volatile tmpfs rw,modeu5 0 0
/dev/sda6 /home ext3 rw,relatime 0 0
/dev/sda7 /media/fat32 vfat rw,sync,quiet,utf8,umask7,gidF 0 0
/dev/sda1 /media/windows fuseblk
rw,nosuid,nodev,allow_other,default_permissions, 0 0
securityfs /sys/kernel/security securityfs rw 0 0
droopy191
Le #18769441
Philippe wrote:
droopy191 a fait l'effort d'écrire:

RAS ici, sauf erreur de ma part, le raid dont vous parliez n'a rien à
faire dans l'histoire. on voit bien 2 disques et des partitions


distinctes.




En cherchant sur google, j'en viens à me demander si l'hypothèse est
finalement correcte.

Vous avez besoin de dmraid ? ( fakeraid )
Si vous n'etes pas sur, attention, ca pourrait ne pas redémarrer, donc
backup.

Je vous propose de le virer
apt-get remove dmraid




--
DR
Philippe
Le #18772271
droopy191 a fait l'effort d'écrire:


Je vous propose de le virer
apt-get remove dmraid



un petit reboot plus tard et elles se montent avec le fstab a l'endroit
voulu...

Je ne pensais pas à une solution si simple.

Il y a encore un temps d'arrêt que je trouve anormalement long au fsck
du boot mais c'est peu de chose.

La version AMD64 qui est sur sdc1 ne boote toujours pas.... mais c'est
un autre problème....


Merci
--
« Si tous les poètes voulaient se donner la main, ils toucheraient enfin
des doigts d'auteur! »
Philippe Vessaire Ò¿Ó¬
Philippe
Le #18772551
droopy191 a fait l'effort d'écrire:

Je vous propose de le virer
apt-get remove dmraid



Ça reste pas propre, je vais voir comment virer les modules qui
s'occupent du raid...

A+
--
« Si tous les poètes voulaient se donner la main, ils toucheraient enfin
des doigts d'auteur! »
Philippe Vessaire Ò¿Ó¬
droopy191
Le #18772721
Philippe wrote:
droopy191 a fait l'effort d'écrire:

Je vous propose de le virer
apt-get remove dmraid



Ça reste pas propre, je vais voir comment virer les modules qui
s'occupent du raid...




C'est pas génant amha.
La question intéressante est plutot pourquoi ca bloquait et pourquoi
c'etait installé. ( je viens de regarder sur ma xubuntu 8.10 et le
paquet n'et pas installé par défaut ).
Peut etre ayant detecté une carte raid, le paquet est installé par
l'installeur. Vous pourriez aussi regarder si votre carte n'a pas un
mode ide simple.

merci du retour



--
DR
Philippe
Le #18772901
droopy191 a fait l'effort d'écrire:

Peut etre ayant detecté une carte raid, le paquet est installé par
l'installeur. Vous pourriez aussi regarder si votre carte n'a pas un
mode ide simple.



Pour la carte, pas de jumper mais une configuration au setup que je
n'ai pas faite. Jusqu'à 8.04, tout allait bien. J'ai attendu que kde4
mûrisse un peu avant de changer et paf...

A+
--
« Si tous les poètes voulaient se donner la main, ils toucheraient enfin
des doigts d'auteur! »
Philippe Vessaire Ò¿Ó¬
Publicité
Poster une réponse
Anonyme