supprimer cellules selon la couleur

Le
lavoie
Excel 2003

J'ai utilisé le formattage conditionnel (A1 à A5000) pour identifier si les
valeurs de ces cellules sont présentes (jaunes) ou non dans une autre liste
(C1:C1000)

j'ai nommé C1:C50) Cible

La condition utilisée dans format conditionnelà été :
Si le formule =Nb.si(Cible;A2)=0 et format Motif en jaune
Et cela fonctionne tr`s bien

je voudrais supprimer les cellules restées à blanc donc présentes dans la
liste Cible

Un peu de code VBA s.v.p.supprimer
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
michdenis
Le #21089871
Bonjour,

Tu devrais procéder en utilisant le filtre avancé.
Un filtre élaboré demande une étiquette de colonne !

Tu détermines ta zone de critère en utilisant 2 cellules de ton choix
Exemple : G1 : Tu laisses totalement vide
G2 : tu tapes la formule : =NB.SI(Cible;A2)>0

A2 représente la première cellule de données de ta colonne A:A
Cible -> plage nommée de la plage de cellules de comparaison

Le résultat du filtre montrera les lignes qui sont en double.
Tu sélectionnes toutes la plage du résultat du filtre moins
la ligne d'en-tête, menu édition / atteindre / cellules / visibles seulement
et tu supprimes les lignes visibles.
Opération terminée.

Si tu dois répéter cette opération régulièrement, tu utilises l'enregistreur
de macro... et pour fignoler le code au besoin, tu reviens nous voir !




"lavoie"
Excel 2003

J'ai utilisé le formattage conditionnel (A1 à A5000) pour identifier si les
valeurs de ces cellules sont présentes (jaunes) ou non dans une autre liste
(C1:C1000)

j'ai nommé C1:C50) Cible

La condition utilisée dans format conditionnelà été :
Si le formule =Nb.si(Cible;A2)=0 et format Motif en jaune
Et cela fonctionne tr`s bien

je voudrais supprimer les cellules restées à blanc donc présentes dans la
liste Cible

Un peu de code VBA s.v.p.supprimer
lavoie
Le #21089861
Merci,
j'essaie tout de suite

A. Lavoie
"michdenis" news:
Bonjour,

Tu devrais procéder en utilisant le filtre avancé.
Un filtre élaboré demande une étiquette de colonne !

Tu détermines ta zone de critère en utilisant 2 cellules de ton choix
Exemple : G1 : Tu laisses totalement vide
G2 : tu tapes la formule : =NB.SI(Cible;A2)>0

A2 représente la première cellule de données de ta colonne A:A
Cible -> plage nommée de la plage de cellules de comparaison

Le résultat du filtre montrera les lignes qui sont en double.
Tu sélectionnes toutes la plage du résultat du filtre moins
la ligne d'en-tête, menu édition / atteindre / cellules / visibles


seulement
et tu supprimes les lignes visibles.
Opération terminée.

Si tu dois répéter cette opération régulièrement, tu utilises


l'enregistreur
de macro... et pour fignoler le code au besoin, tu reviens nous voir !




"lavoie"

discussion :

Excel 2003

J'ai utilisé le formattage conditionnel (A1 à A5000) pour identifier si


les
valeurs de ces cellules sont présentes (jaunes) ou non dans une autre


liste
(C1:C1000)

j'ai nommé C1:C50) Cible

La condition utilisée dans format conditionnelà été :
Si le formule =Nb.si(Cible;A2)=0 et format Motif en jaune
Et cela fonctionne tr`s bien

je voudrais supprimer les cellules restées à blanc donc présentes dans la
liste Cible

Un peu de code VBA s.v.p.supprimer



michdenis
Le #21090301
Concernant la formule :

Va afficher les cellules dont l'occurrence est plus grande que 1
G2 : tu tapes la formule : =NB.SI(Cible;A2)>1

Dont l'occurrence est égale à 1
G2 : tu tapes la formule : =NB.SI(Cible;A2)=1

à toi d'adapter selon tes besoins !
Publicité
Poster une réponse
Anonyme