supprimer opcache

Le
Pif - 34
Bonjour,

voici ma conf:
Centos 6.4, Php 5.4.26, httpd 2.2.15

j'ai un moodle que j'ai upgradé de la 2.5 à la 2.6. Le bénéfice est
l'utilisation de l'Opcache. Du coup, j'ai fait un yum install de
opcache.

depuis le site plante dans la version 2.6 et pas 2.5. L'erreur est un
plantage complet de PHP avec segmentation fault. J'ai installé deux
petites pages PHP hors moodle qui permettent de monitorer opcache, et le
résultat est le même dès qu'on appelle la première fonction :
segmentation fault qui plante httpd.

je me suis apercu en cherchant que j'avais déjà un opcache installé:
locate opcache.so
/usr/lib64/php/modules/opcache.so
/usr/lib64/php-zts/modules/opcache.so

donc je me demande ce que j'ai mal fait et je me demande si je peux
virer les deux opcache et les reinstaller ce qui résoudrait peut être le
problème ou au contraire s'il faut faire autre chose.

Avez-vous des conseils ?

Merci.


Ce courrier électronique ne contient aucun virus ou logiciel malveillant parce que la protection avast! Antivirus est active.
http://www.avast.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
yamo'
Le #26050462
Salut,

Le 24/03/2014 09:45, Pif - 34 a écrit:

voici ma conf:
Centos 6.4, Php 5.4.26, httpd 2.2.15

j'ai un moodle que j'ai upgradé de la 2.5 à la 2.6. Le bénéfice est
l'utilisation de l'Opcache. Du coup, j'ai fait un yum install de
opcache....

depuis le site plante dans la version 2.6 et pas 2.5. L'erreur est un
plantage complet de PHP avec segmentation fault. J'ai installé deux
petites pages PHP hors moodle qui permettent de monitorer opcache, et le
résultat est le même... dès qu'on appelle la première fonction :
segmentation fault qui plante httpd.





Déjà, je vérifierais ce qui est installé :

rpm -qa opcache

Et tu peux faire un yum downgrade opcache* et figer la version dans yum :

* dommage que ça n'existe pas avec apt-get!

Ce serait bien que quelqu’un vérifie que je n'écrit pas trop de conneries
; je suis plus à l'aise avec debian qu'avec les redhat like.


--
Stéphane
Pif - 34
Le #26050542
Le 24/03/2014 15:09, yamo' a écrit :
Salut,

Le 24/03/2014 09:45, Pif - 34 a écrit:

voici ma conf:
Centos 6.4, Php 5.4.26, httpd 2.2.15

j'ai un moodle que j'ai upgradé de la 2.5 à la 2.6. Le bénéfice est
l'utilisation de l'Opcache. Du coup, j'ai fait un yum install de
opcache....

depuis le site plante dans la version 2.6 et pas 2.5. L'erreur est un
plantage complet de PHP avec segmentation fault. J'ai installé deux
petites pages PHP hors moodle qui permettent de monitorer opcache, et le
résultat est le même... dès qu'on appelle la première fonction :
segmentation fault qui plante httpd.





Déjà, je vérifierais ce qui est installé :

rpm -qa opcache



il me répond rien...

quand je fais un pecl, ca parait bien...



Et tu peux faire un yum downgrade opcache* et figer la version dans yum
:
* dommage que ça n'existe pas avec apt-get!

Ce serait bien que quelqu’un vérifie que je n'écrit pas trop de
conneries ; je suis plus à l'aise avec debian qu'avec les redhat like.






---
Ce courrier électronique ne contient aucun virus ou logiciel malveillant parce que la protection avast! Antivirus est active.
http://www.avast.com
Benoit Izac
Le #26050982
Bonjour,

le 24/03/2014 à 15:09, yamo' a écrit dans le message

Et tu peux faire un yum downgrade opcache* et figer la version dans
yum :
* dommage que ça n'existe pas avec apt-get!



Je ne sais pas ce que fait exactement YUM mais il y a de chance que tu
puisses faire la même chose avec apt_preferences(5) (en tout cas tu peux
forcer un downgrade et figer la version).

--
Benoit Izac
Erwan David
Le #26052192
yamo'
Salut,

Le 24/03/2014 19:35, Benoit Izac a écrit:

le 24/03/2014 à 15:09, yamo' a écrit dans le message



Et tu peux faire un yum downgrade opcache* et figer la version dans
yum :




* dommage que ça n'existe pas avec apt-get!





Je ne sais pas ce que fait exactement YUM mais il y a de chance que tu
puisses faire la même chose avec apt_preferences(5) (en tout cas tu peux
forcer un downgrade et figer la version).





Oui je sais mais, apt-get downgrade monpaquet n'existe pas.



ni apt-get ou aptitude rollback


--
Les simplifications c'est trop compliqué
Benoit Izac
Le #26052422
Bonjour,

le 25/03/2014 à 16:01, yamo' a écrit dans le message

Et tu peux faire un yum downgrade opcache* et figer la version dans
yum :




* dommage que ça n'existe pas avec apt-get!





Je ne sais pas ce que fait exactement YUM mais il y a de chance que tu
puisses faire la même chose avec apt_preferences(5) (en tout cas tu peux
forcer un downgrade et figer la version).



Oui je sais mais, apt-get downgrade monpaquet n'existe pas.



Pas essayé mais peut-être que « apt-get install monpaquet » est
suffisant si tu as mis les bonnes lignes dans apt_preferences. Ou encore
« apt-get install monpaquet=laversion ».

Après si c'est l'argument « downgrade » que tu veux, effectivement ça
n'existe pas mais d'un autre coté je n'ai jamais eu ce besoin ; quel est
l'intérêt ? De plus, si il y a eu trois versions différentes, doit-on
revenir à la 2 ou à la 1 avec un « downgrade » ?

--
Benoit Izac
Benoit Izac
Le #26052412
Bonjour,

le 25/03/2014 à 16:31, Erwan David a écrit dans le message

ni apt-get ou aptitude rollback



Qui sont sensés faire quoi ?

--
Benoit Izac
Publicité
Poster une réponse
Anonyme