SVP besoin d'aide sur la vermagic d'un nouveau module !

Le
Jules ALIX
slt ttlm,

j'ai besoin de compiler un drivers (8712u.ko) pour ma nouvelle
clef wifi n.

l'objectif étant d'obtenir la même vermagic que les modules
déjà installés, on a ça :
2.6.30.5 SMP preempt mod_unload 486 4KSTACKS

alors qu'un nouveau module compilé, on obtient ça :
2.6.30.5-smp SMP mod_unload 686

sans quoi j'ai un message d'erreur : invalid module format
lorsque je lance un insmod ou un modprobe


je sais que vous êtes en vacances et que je pose une question
à la con ! mais je pense que vous avez tous changé de clef wifi
pour votre eeepc !

j'ai regardé vers :

multiprocessing (CONFIG_SMP),
preemption (CONFIG_PREEMPT*),
module versionning (CONFIG_MODVERSIONS),
processor family (CONFIG_M586/686)

4KSTACKS ! dans .CONFIG du noyau.

#CONFIG_LOCALVERSION=""
#CONFIG_MODULE_SRCVERSION_ALL not set

y a un config ou un kconfig à bidouiller ou quoi ?


merci !

--

Jules ALIX
"Pas schizo résistant, et pas de Burn out".
Allo ! les responsabilités et autres facilitie$ ?
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jules ALIX
Le #24109091
je pioche...une idée ?

le fichier version.h ? (LINUX_VERSION_CODE)
le fichier vermagic.h ?
le fichier utsrelease.h ?

le EXTRA_CFLAGS du Makefile ?
un mauvais appel des Makefile dans les subfolders?

la version de gcc ?
la façon dont gcc est appelé ?



--

Jules ALIX
"Pas schizo résistant, et pas de Burn out".
Allo ! les responsabilités et autres facilitie$ ?
Publicité
Poster une réponse
Anonyme