syntaxe

Le
Patrice
Bonjour,

J'ai plusieurs sous formulaire qui s'appellent :
SAISIE_ONGLET_6
SAISIE_ONGLET_7
SAISIE_ONGLET_8

Je voudrais faire référence à un des sous formulaire par une écriture de ce
type :
v_moi=6
Forms![SAISIE_ONGLET_principal].Form![SAISIE_ONGLET_" & v_moi & "]!nom="Titi"

J'ai pour message d'erreur qu'il ne reconnait pas le champ : SAISIE_ONGLET_"
& v_moi & "

Evidemment si je mets :
Forms![SAISIE_ONGLET_principal].Form![SAISIE_ONGLET_6]!nom="Titi", ça marche !

Quelqu'un peut-il m'aider

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Raymond [mvp]
Le #6281271
Bonjour.

essaie ceci, pour simplifier:

Forms("SAISIE_ONGLET_principal")("SAISIE_ONGLET_" & v_moi)("nom")="Titi"

--
@+
Raymond Access MVP http://OfficeSystem.Access.free.fr/
Pour débuter sur le forum: http://www.mpfa.info/
Non Stop Mix '07 - Paris. La nouvelle scène web fête la créativité !
http://www.comscamp.com/Tracker/Redirect.ashx?linkid°64304e-439a-45c7-9d2f-c3326db58273


"Patrice" news:
| Bonjour,
|
| J'ai plusieurs sous formulaire qui s'appellent :
| SAISIE_ONGLET_6
| SAISIE_ONGLET_7
| SAISIE_ONGLET_8
| ...
| Je voudrais faire référence à un des sous formulaire par une écriture de
ce
| type :
| v_moi=6
| Forms![SAISIE_ONGLET_principal].Form![SAISIE_ONGLET_" & v_moi &
"]!nom="Titi"
|
| J'ai pour message d'erreur qu'il ne reconnait pas le champ :
SAISIE_ONGLET_"
| & v_moi & "
|
| Evidemment si je mets :
| Forms![SAISIE_ONGLET_principal].Form![SAISIE_ONGLET_6]!nom="Titi", ça
marche !
|
| Quelqu'un peut-il m'aider
|
| Merci
Patrice
Le #6281231
Merci beaucoup, ça marche !!


Bonjour.

essaie ceci, pour simplifier:

Forms("SAISIE_ONGLET_principal")("SAISIE_ONGLET_" & v_moi)("nom")="Titi"

--
@+
Raymond Access MVP http://OfficeSystem.Access.free.fr/
Pour débuter sur le forum: http://www.mpfa.info/
Non Stop Mix '07 - Paris. La nouvelle scène web fête la créativité !
http://www.comscamp.com/Tracker/Redirect.ashx?linkid°64304e-439a-45c7-9d2f-c3326db58273


"Patrice" news:
| Bonjour,
|
| J'ai plusieurs sous formulaire qui s'appellent :
| SAISIE_ONGLET_6
| SAISIE_ONGLET_7
| SAISIE_ONGLET_8
| ...
| Je voudrais faire référence à un des sous formulaire par une écriture de
ce
| type :
| v_moi=6
| Forms![SAISIE_ONGLET_principal].Form![SAISIE_ONGLET_" & v_moi &
"]!nom="Titi"
|
| J'ai pour message d'erreur qu'il ne reconnait pas le champ :
SAISIE_ONGLET_"
| & v_moi & "
|
| Evidemment si je mets :
| Forms![SAISIE_ONGLET_principal].Form![SAISIE_ONGLET_6]!nom="Titi", ça
marche !
|
| Quelqu'un peut-il m'aider
|
| Merci





Publicité
Poster une réponse
Anonyme