Syntaxe SomDom

Le
Guy FALESSE
Bonjour à tous,

J'ai un problème avec la syntaxe de cette fonction:

=SomDom("PrixAchat";"tblDépenses & PartDate("aaaa";
Date() )";"Rayon='Jeux'")

Cela fait quelque temps que j'essaie et rien à faire toujours :la syntaxe
n'est pas correcte.
Si quelqu'un pouvait m'aider, cela m'enlèverait une belle épine hors du
pied. :-)

D'avance merci.

@+

Guy FALESSE
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Fabien
Le #18462331
Guy FALESSE a écrit :
Bonjour à tous,

J'ai un problème avec la syntaxe de cette fonction:

=SomDom("PrixAchat";"tblDépenses & PartDate("aaaa";
Date() )";"Rayon='Jeux'")

Cela fait quelque temps que j'essaie et rien à faire toujours :la syntaxe
n'est pas correcte.
Si quelqu'un pouvait m'aider, cela m'enlèverait une belle épine hors du
pied. :-)

D'avance merci.

@+

Guy FALESSE




Salut,
somdom("[PrixAchat]";"tblDépenses" & year(now());"[Rayon]='Jeux'")
ou
somdom("[PrixAchat]";"tblDépenses" &
DatePart("yyyy";now());"[Rayon]='Jeux'")
ou
somdom("[PrixAchat]";"tblDépenses" & format(now();"yyyy");"[Rayon]='Jeux'")
au choix ;-)

@+
Guy FALESSE
Le #18462491
Salut Fabien,

Je n'ai plus d'erreur de syntaxe, mais Access n'accepte pas en ce sens que
dans le champ j'ai l'erreur #nom?
Pas de chance. :-(
@+

Guy FALESSE

"Fabien"
Guy FALESSE a écrit :
Bonjour à tous,

J'ai un problème avec la syntaxe de cette fonction:

=SomDom("PrixAchat";"tblDépenses & PartDate("aaaa";
Date() )";"Rayon='Jeux'")

Cela fait quelque temps que j'essaie et rien à faire toujours :la syntaxe
n'est pas correcte.
Si quelqu'un pouvait m'aider, cela m'enlèverait une belle épine hors du
pied. :-)

D'avance merci.

@+

Guy FALESSE


Salut,
somdom("[PrixAchat]";"tblDépenses" & year(now());"[Rayon]='Jeux'")
ou
somdom("[PrixAchat]";"tblDépenses" &
DatePart("yyyy";now());"[Rayon]='Jeux'")
ou
somdom("[PrixAchat]";"tblDépenses" &
format(now();"yyyy");"[Rayon]='Jeux'")
au choix ;-)

@+


Fabien
Le #18462481
Guy FALESSE a écrit :
Salut Fabien,

Je n'ai plus d'erreur de syntaxe, mais Access n'accepte pas en ce sens que
dans le champ j'ai l'erreur #nom?
Pas de chance. :-(
@+

Guy FALESSE

"Fabien"
Guy FALESSE a écrit :
Bonjour à tous,

J'ai un problème avec la syntaxe de cette fonction:

=SomDom("PrixAchat";"tblDépenses & PartDate("aaaa";
Date() )";"Rayon='Jeux'")

Cela fait quelque temps que j'essaie et rien à faire toujours :la syntaxe
n'est pas correcte.
Si quelqu'un pouvait m'aider, cela m'enlèverait une belle épine hors du
pied. :-)

D'avance merci.

@+

Guy FALESSE


Salut,
somdom("[PrixAchat]";"tblDépenses" & year(now());"[Rayon]='Jeux'")
ou
somdom("[PrixAchat]";"tblDépenses" &
DatePart("yyyy";now());"[Rayon]='Jeux'")
ou
somdom("[PrixAchat]";"tblDépenses" &
format(now();"yyyy");"[Rayon]='Jeux'")
au choix ;-)

@+






Alors re-vérifie l'orthographe des noms de champs et de tables.
#nom est symptomatique de ce genre d'erreur.
@+
Guy FALESSE
Le #18462801
Merci Fabien,

La syntaxe : somdom("[PrixAchat]";"tblDépenses" &
Année(Maintenant()));"[Rayon]='Jeux'") - l'orthographe est bonne, mais me
donne #nom?
Si j'écris en "dur" =SomDom("PrixAchat";"tblDépenses2009";"Rayon='Jeux'")
c'est bon.

Mais par contre dans un autre champ: =SomDom("Gains";"tblDépenses" &
Année(Maintenant())), c'est bon.
Alors là ??? :-(
@+

Guy FALESSE



"Fabien"
Guy FALESSE a écrit :
Salut Fabien,

Je n'ai plus d'erreur de syntaxe, mais Access n'accepte pas en ce sens
que dans le champ j'ai l'erreur #nom?
Pas de chance. :-(
@+

Guy FALESSE

"Fabien"
Guy FALESSE a écrit :
Bonjour à tous,

J'ai un problème avec la syntaxe de cette fonction:

=SomDom("PrixAchat";"tblDépenses & PartDate("aaaa";
Date() )";"Rayon='Jeux'")

Cela fait quelque temps que j'essaie et rien à faire toujours :la
syntaxe n'est pas correcte.
Si quelqu'un pouvait m'aider, cela m'enlèverait une belle épine hors du
pied. :-)

D'avance merci.

@+

Guy FALESSE


Salut,
somdom("[PrixAchat]";"tblDépenses" & year(now());"[Rayon]='Jeux'")
ou
somdom("[PrixAchat]";"tblDépenses" &
DatePart("yyyy";now());"[Rayon]='Jeux'")
ou
somdom("[PrixAchat]";"tblDépenses" &
format(now();"yyyy");"[Rayon]='Jeux'")
au choix ;-)

@+






Alors re-vérifie l'orthographe des noms de champs et de tables.
#nom est symptomatique de ce genre d'erreur.
@+



Michel__D
Le #18462791
Bonjour,

"Guy FALESSE"
Bonjour à tous,

J'ai un problème avec la syntaxe de cette fonction:

=SomDom("PrixAchat";"tblDépenses & PartDate("aaaa";
Date() )";"Rayon='Jeux'")

Cela fait quelque temps que j'essaie et rien à faire toujours :la syntaxe
n'est pas correcte.
Si quelqu'un pouvait m'aider, cela m'enlèverait une belle épine hors du
pied. :-)



Je pense que tu devrais jeter un oeil sur l'aide de SomDom.
Fabien
Le #18463071
Guy FALESSE a écrit :
Merci Fabien,

La syntaxe : somdom("[PrixAchat]";"tblDépenses" &
Année(Maintenant()));"[Rayon]='Jeux'") - l'orthographe est bonne, mais me
donne #nom?
Si j'écris en "dur" =SomDom("PrixAchat";"tblDépenses2009";"Rayon='Jeux'")
c'est bon.

Mais par contre dans un autre champ: =SomDom("Gains";"tblDépenses" &
Année(Maintenant())), c'est bon.
Alors là ??? :-(
@+

Guy FALESSE



"Fabien"
Guy FALESSE a écrit :
Salut Fabien,

Je n'ai plus d'erreur de syntaxe, mais Access n'accepte pas en ce sens
que dans le champ j'ai l'erreur #nom?
Pas de chance. :-(
@+

Guy FALESSE

"Fabien"
Guy FALESSE a écrit :
Bonjour à tous,

J'ai un problème avec la syntaxe de cette fonction:

=SomDom("PrixAchat";"tblDépenses & PartDate("aaaa";
Date() )";"Rayon='Jeux'")

Cela fait quelque temps que j'essaie et rien à faire toujours :la
syntaxe n'est pas correcte.
Si quelqu'un pouvait m'aider, cela m'enlèverait une belle épine hors du
pied. :-)

D'avance merci.

@+

Guy FALESSE


Salut,
somdom("[PrixAchat]";"tblDépenses" & year(now());"[Rayon]='Jeux'")
ou
somdom("[PrixAchat]";"tblDépenses" &
DatePart("yyyy";now());"[Rayon]='Jeux'")
ou
somdom("[PrixAchat]";"tblDépenses" &
format(now();"yyyy");"[Rayon]='Jeux'")
au choix ;-)

@+





Alors re-vérifie l'orthographe des noms de champs et de tables.
#nom est symptomatique de ce genre d'erreur.
@+







ben enleves les [] ;-)
Guy FALESSE
Le #18463061
Salut Fabien,

somdom("PrixAchat";"tblDépenses" & Année(Maintenant()));"Rayon='Jeux'")
me donne toujours #nom?
Bizarre non?
@+

Guy FALESSE


"Fabien"
Guy FALESSE a écrit :
Merci Fabien,

La syntaxe : somdom("[PrixAchat]";"tblDépenses" &
Année(Maintenant()));"[Rayon]='Jeux'") - l'orthographe est bonne, mais me
donne #nom?
Si j'écris en "dur" =SomDom("PrixAchat";"tblDépenses2009";"Rayon='Jeux'")
c'est bon.

Mais par contre dans un autre champ: =SomDom("Gains";"tblDépenses" &
Année(Maintenant())), c'est bon.
Alors là ??? :-(
@+

Guy FALESSE



"Fabien"
Guy FALESSE a écrit :
Salut Fabien,

Je n'ai plus d'erreur de syntaxe, mais Access n'accepte pas en ce sens
que dans le champ j'ai l'erreur #nom?
Pas de chance. :-(
@+

Guy FALESSE

"Fabien"
Guy FALESSE a écrit :
Bonjour à tous,

J'ai un problème avec la syntaxe de cette fonction:

=SomDom("PrixAchat";"tblDépenses & PartDate("aaaa";
Date() )";"Rayon='Jeux'")

Cela fait quelque temps que j'essaie et rien à faire toujours :la
syntaxe n'est pas correcte.
Si quelqu'un pouvait m'aider, cela m'enlèverait une belle épine hors
du pied. :-)

D'avance merci.

@+

Guy FALESSE


Salut,
somdom("[PrixAchat]";"tblDépenses" & year(now());"[Rayon]='Jeux'")
ou
somdom("[PrixAchat]";"tblDépenses" &
DatePart("yyyy";now());"[Rayon]='Jeux'")
ou
somdom("[PrixAchat]";"tblDépenses" &
format(now();"yyyy");"[Rayon]='Jeux'")
au choix ;-)

@+





Alors re-vérifie l'orthographe des noms de champs et de tables.
#nom est symptomatique de ce genre d'erreur.
@+







ben enleves les [] ;-)



Fabien
Le #18463311
Guy FALESSE a écrit :
Salut Fabien,

somdom("PrixAchat";"tblDépenses" & Année(Maintenant()));"Rayon='Jeux'")
me donne toujours #nom?
Bizarre non?
@+

Guy FALESSE


"Fabien"
Guy FALESSE a écrit :
Merci Fabien,

La syntaxe : somdom("[PrixAchat]";"tblDépenses" &
Année(Maintenant()));"[Rayon]='Jeux'") - l'orthographe est bonne, mais me
donne #nom?
Si j'écris en "dur" =SomDom("PrixAchat";"tblDépenses2009";"Rayon='Jeux'")
c'est bon.

Mais par contre dans un autre champ: =SomDom("Gains";"tblDépenses" &
Année(Maintenant())), c'est bon.
Alors là ??? :-(
@+

Guy FALESSE



"Fabien"
Guy FALESSE a écrit :
Salut Fabien,

Je n'ai plus d'erreur de syntaxe, mais Access n'accepte pas en ce sens
que dans le champ j'ai l'erreur #nom?
Pas de chance. :-(
@+

Guy FALESSE

"Fabien"
Guy FALESSE a écrit :
Bonjour à tous,

J'ai un problème avec la syntaxe de cette fonction:

=SomDom("PrixAchat";"tblDépenses & PartDate("aaaa";
Date() )";"Rayon='Jeux'")

Cela fait quelque temps que j'essaie et rien à faire toujours :la
syntaxe n'est pas correcte.
Si quelqu'un pouvait m'aider, cela m'enlèverait une belle épine hors
du pied. :-)

D'avance merci.

@+

Guy FALESSE


Salut,
somdom("[PrixAchat]";"tblDépenses" & year(now());"[Rayon]='Jeux'")
ou
somdom("[PrixAchat]";"tblDépenses" &
DatePart("yyyy";now());"[Rayon]='Jeux'")
ou
somdom("[PrixAchat]";"tblDépenses" &
format(now();"yyyy");"[Rayon]='Jeux'")
au choix ;-)

@+




Alors re-vérifie l'orthographe des noms de champs et de tables.
#nom est symptomatique de ce genre d'erreur.
@+






ben enleves les [] ;-)







Me semble qu'il y a une ) en trop
somdom("PrixAchat";"tblDépenses" & Année(Maintenant());"Rayon='Jeux'")
au lieu de
somdom("PrixAchat";"tblDépenses" & Année(Maintenant()));"Rayon='Jeux'")
Guy FALESSE
Le #18463471
Salut Fabien,

somdom("PrixAchat";"tblDépenses" & Année(Maintenant());"Rayon='Jeux'") ne
change rien =-(
Désolé.
@+

Guy FALESSE

"Fabien" %
Guy FALESSE a écrit :
Salut Fabien,

somdom("PrixAchat";"tblDépenses" & Année(Maintenant()));"Rayon='Jeux'")
me donne toujours #nom?
Bizarre non?
@+

Guy FALESSE


"Fabien"
Guy FALESSE a écrit :
Merci Fabien,

La syntaxe : somdom("[PrixAchat]";"tblDépenses" &
Année(Maintenant()));"[Rayon]='Jeux'") - l'orthographe est bonne, mais
me donne #nom?
Si j'écris en "dur"
=SomDom("PrixAchat";"tblDépenses2009";"Rayon='Jeux'") c'est bon.

Mais par contre dans un autre champ: =SomDom("Gains";"tblDépenses" &
Année(Maintenant())), c'est bon.
Alors là ??? :-(
@+

Guy FALESSE



"Fabien"
Guy FALESSE a écrit :
Salut Fabien,

Je n'ai plus d'erreur de syntaxe, mais Access n'accepte pas en ce
sens que dans le champ j'ai l'erreur #nom?
Pas de chance. :-(
@+

Guy FALESSE

"Fabien" news:
Guy FALESSE a écrit :
Bonjour à tous,

J'ai un problème avec la syntaxe de cette fonction:

=SomDom("PrixAchat";"tblDépenses & PartDate("aaaa";
Date() )";"Rayon='Jeux'")

Cela fait quelque temps que j'essaie et rien à faire toujours :la
syntaxe n'est pas correcte.
Si quelqu'un pouvait m'aider, cela m'enlèverait une belle épine
hors du pied. :-)

D'avance merci.

@+

Guy FALESSE


Salut,
somdom("[PrixAchat]";"tblDépenses" & year(now());"[Rayon]='Jeux'")
ou
somdom("[PrixAchat]";"tblDépenses" &
DatePart("yyyy";now());"[Rayon]='Jeux'")
ou
somdom("[PrixAchat]";"tblDépenses" &
format(now();"yyyy");"[Rayon]='Jeux'")
au choix ;-)

@+




Alors re-vérifie l'orthographe des noms de champs et de tables.
#nom est symptomatique de ce genre d'erreur.
@+






ben enleves les [] ;-)







Me semble qu'il y a une ) en trop
somdom("PrixAchat";"tblDépenses" & Année(Maintenant());"Rayon='Jeux'") au
lieu de
somdom("PrixAchat";"tblDépenses" & Année(Maintenant()));"Rayon='Jeux'")


Guy FALESSE
Le #18463451
Salut Michel,
Merci pour ta réponse.
J'ai bien sûr voulu aller voir à somdom dans l'aide.
Je suis encore occupé à chercher, pas de réponse, j'ai essayé fonction de
domaine, rien, Access donne des réponses à c^pté de "la plaque"
@+

Guy FALESSE


"Michel__D" news: glc43j$sj4$
Bonjour,

"Guy FALESSE" news:
Bonjour à tous,

J'ai un problème avec la syntaxe de cette fonction:

=SomDom("PrixAchat";"tblDépenses & PartDate("aaaa";
Date() )";"Rayon='Jeux'")

Cela fait quelque temps que j'essaie et rien à faire toujours :la syntaxe
n'est pas correcte.
Si quelqu'un pouvait m'aider, cela m'enlèverait une belle épine hors du
pied. :-)



Je pense que tu devrais jeter un oeil sur l'aide de SomDom.



Publicité
Poster une réponse
Anonyme