--target-release d'aptitude ne fonctionne pas.

Le
Valrik
Bonjour à tous,
Ma debian est en version stable (lenny) et je voulais installer quelques
paquets de la version testing, afin de bénéficier d'une nouvelle version du
module geometry LaTex.
J'ai commencé par purger le paquet texlive-latex-base.
J'étais donc dans la situation suivante :
:-) $ apt-show-versions -a texlive-latex-base
Not installed
texlive-latex-base 2007.dfsg.2-1~lenny2 lenny ftp.fr.debian.org
texlive-latex-base 2009-11 testing ftp.fr.debian.org
texlive-latex-base not installed
Puis
:-) $ sudo aptitude -t testing install texlive-latex-base
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances
Lecture des informations d'état Fait
Lecture de l'information d'état étendu
Initialisation de l'état des paquets Fait
Lecture des descriptions de tâches Fait
Les NOUVEAUX paquets suivants vont être installés :
dvipdfmx{a} texlive-base{a} texlive-base-bin{a} texlive-base-bin-doc{a}
texlive-doc-base{a} texlive-latex-base texlive-latex-base-doc{a}
0 paquets mis à jour, 7 nouvellement installés, 0 à enlever et 0 non mis à
jour.
Il est nécessaire de télécharger 0o/45,5Mo d'archives. Après dépaquetage,
87,3Mo seront utilisés.
Voulez-vous continuer ? [Y/n/?]
Écriture de l'information d'état étendu Fait
Sélection du paquet texlive-base-bin précédemment désélectionné.
(Lecture de la base de données 211135 fichiers et répertoires déjà
installés.)
Dépaquetage de texlive-base-bin (à partir
de /texlive-base-bin_2007.dfsg.2-4+lenny3_i386.deb)
Sélection du paquet dvipdfmx précédemment désélectionné.
Dépaquetage de dvipdfmx (à partir
de /dvipdfmx_1%3a20080607-1_i386.deb)
Sélection du paquet texlive-doc-base précédemment désélectionné.
Dépaquetage de texlive-doc-base (à partir
de /texlive-doc-base_2007.dfsg.2-1_all.deb)
Sélection du paquet texlive-base précédemment désélectionné.

A la fin de l'installation, j'ai :
:-) $ apt-show-versions -a texlive-latex-base
texlive-latex-base 2007.dfsg.2-1~lenny2 install ok installed
texlive-latex-base 2007.dfsg.2-1~lenny2 lenny ftp.fr.debian.org
texlive-latex-base 2009-11 testing ftp.fr.debian.org
texlive-latex-base/lenny uptodate 2007.dfsg.2-1~lenny2
:-) $
On peut voir que j'ai installé la version lenny et non la testing :-(

Autres précisions :
:-) $ awk '/testing/' /etc/apt/sources.list
deb ftp://ftp.fr.debian.org/debian/ testing main contrib non-free
et
:-) $ more /etc/apt/preferences
Package: *
Pin: release a=stable
Pin-Priority: 1000

Package: *
Pin: release a=lenny-backports
Pin-Priority: 950

Package: *
Pin: release a=testing
Pin-Priority: 900
:-) $
Je dois sans doute faire une mauvaise manip Mais là, je suis un peu
sec ! :-(
Pourtant, j'ai testé des tas de commandes et cherché sur la toile. Rien
faire !
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Valrik
Le #23023011
Valrik wrote:

--target-release d'aptitude ne fonctionne pas.


N'ayant pas de réponse pour l'instant j'ai également posté sur le forum
http://www.debian-fr.org.
moi-meme
Le #23023431
Le Sat, 15 Jan 2011 00:34:43 +0100, Valrik a écrit :

N'ayant pas de réponse pour l'instant j'ai également posté sur le forum



tenter aussi f.c.text.tex
Valrik
Le #23023701
moi-meme wrote:

Le Sat, 15 Jan 2011 00:34:43 +0100, Valrik a écrit :

N'ayant pas de réponse pour l'instant j'ai également posté sur le forum



tenter aussi f.c.text.tex


Sans vouloir vous offenser, je ne crois pas car il s'agit d'un problème
d'administration debian linux. Celui-ci se produit avec n'importe quel
paquet.
Merci tout de même. :-)
Beurk
Le #23024241
Valrik s'exprimait

......
A la fin de l'installation, j'ai :
:-) $ apt-show-versions -a texlive-latex-base
texlive-latex-base 2007.dfsg.2-1~lenny2 install ok installed
texlive-latex-base 2007.dfsg.2-1~lenny2 lenny ftp.fr.debian.org
texlive-latex-base 2009-11 testing ftp.fr.debian.org
texlive-latex-base/lenny uptodate 2007.dfsg.2-1~lenny2
:-) $
On peut voir que j'ai installé la version lenny et non la testing :-(



Bonjour,

As tu essayé avec et sans l'option - t, -s pour simuler et -V pour
les versions de paquet, pour voir s'il y a une différence ?

aptitude -s -V install texlive-latex-base

:-) $ more /etc/apt/preferences

Package: *
Pin: release a=testing
Pin-Priority: 900



Peut-être remplacer la wildcard (*) par texlive-latex-base, essayer
apt-get -t ou apt-get install texlive-latex-base 09-11
Valrik
Le #23025551
Beurk wrote:

Valrik s'exprimait

......
A la fin de l'installation, j'ai :
:-) $ apt-show-versions -a texlive-latex-base
texlive-latex-base 2007.dfsg.2-1~lenny2 install ok installed
texlive-latex-base 2007.dfsg.2-1~lenny2 lenny ftp.fr.debian.org
texlive-latex-base 2009-11 testing ftp.fr.debian.org
texlive-latex-base/lenny uptodate 2007.dfsg.2-1~lenny2
:-) $
On peut voir que j'ai installé la version lenny et non la testing :-(



Bonjour,

As tu essayé avec et sans l'option - t, -s pour simuler et -V pour
les versions de paquet, pour voir s'il y a une différence ?

aptitude -s -V install texlive-latex-base

:-) $ more /etc/apt/preferences



Package: *
Pin: release a=testing
Pin-Priority: 900



Peut-être remplacer la wildcard (*) par texlive-latex-base, essayer
apt-get -t ou apt-get install texlive-latex-base 09-11



Bonjour et merci pour ton aide.
Tu trouveras la solution du problème sur le forum à l'adresse suivante :
http://www.debian-fr.org/target-release-d-aptitude-ne-fonctionne-pas-t31346.html
(Forum très actif au demeurant)
L'explication est très intéressante, je dois dire.
C'était tout bête, mais il fallait y penser... ;-)
moi-meme
Le #23026001
Le Sat, 15 Jan 2011 11:31:43 +0100, Valrik a écrit :

tenter aussi f.c.text.tex


Sans vouloir vous offenser, je ne crois pas car il s'agit d'un problème
d'administration debian linux. Celui-ci se produit avec n'importe quel
paquet.
Merci tout de même.



alors l.d.user.french ?

sans obligation et pas offensé du tout.
Valrik
Le #23026391
moi-meme wrote:

Le Sat, 15 Jan 2011 11:31:43 +0100, Valrik a écrit :

tenter aussi f.c.text.tex


Sans vouloir vous offenser, je ne crois pas car il s'agit d'un problème
d'administration debian linux. Celui-ci se produit avec n'importe quel
paquet.
Merci tout de même.



alors l.d.user.french ?

sans obligation et pas offensé du tout.



Si cela t'intéresse, tu trouveras la solution au problème sur le forum à
l'adresse suivante :
http://www.debian-fr.org/target-release-d-aptitude-ne-fonctionne-pas-t31346.html
(Forum très actif au demeurant)
L'explication est très intéressante, je dois dire.
C'était tout bête, mais il fallait y penser...   ;-)
Publicité
Poster une réponse
Anonyme