Télécharger un fichier distant depuis son adresse HTTP

Le
Thierry 46
Bonjour,

Est-il possible d'enregistrer un fichier dont on ne connait que 'adresse
http sans avoir à l'ouvrir?

Télécharger un fichier distant depuis son adresse HTTP

J'arrive à tout automatiser mais pour ce passage je suis obligé de
passer par des envoietouche cela fonctionne à 100% sur mon micro mais
pas sur d'autres micros !


Merci de m'aider à éviter de voir apparaitre la boite de dialogue
"enregistrer sous" et de devoir la piloter !!!

Downloadfile("http://domaine/chemin/fichier.zip","F:Mesdocumentsfichier.zip")

l'API URLDownloadToFile ???

Y a t'il une solution Windev ou par VBS ???

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JeAn-PhI
Le #17369031
Thierry 46 a pensé très fort :
Bonjour,

Est-il possible d'enregistrer un fichier dont on ne connait que 'adresse http
sans avoir à l'ouvrir?

Télécharger un fichier distant depuis son adresse HTTP

J'arrive à tout automatiser mais pour ce passage je suis obligé de passer par
des envoietouche... cela fonctionne à 100% sur mon micro mais pas sur
d'autres micros !


Merci de m'aider à éviter de voir apparaitre la boite de dialogue
"enregistrer sous" et de devoir la piloter !!!

Downloadfile("http://domaine/chemin/fichier.zip","F:Mesdocumentsfichier.zip")

l'API URLDownloadToFile ???

Y a t'il une solution Windev ou par VBS ???

Merci



httprequête() ? peut être ? et httpdonnerésultat()

--
Cordialement JeAn-PhI
Thierry 46
Le #17370741
Bonjour,

Sur les autres micros (à part le mien où c'est ok) le système ne prend
pas en compte le senkeys "%r" (ALT r), ensuite c'est ok si on
intervient....
Problème de focus ? ??

JeAn-PhI a écrit :
Thierry 46 a pensé très fort :
Bonjour,

Est-il possible d'enregistrer un fichier dont on ne connait que
'adresse http sans avoir à l'ouvrir?

Télécharger un fichier distant depuis son adresse HTTP

J'arrive à tout automatiser mais pour ce passage je suis obligé de
passer par des envoietouche... cela fonctionne à 100% sur mon micro
mais pas sur d'autres micros !


Merci de m'aider à éviter de voir apparaitre la boite de dialogue
"enregistrer sous" et de devoir la piloter !!!

Downloadfile("http://domaine/chemin/fichier.zip","F:Mesdocumentsfichier.zip")


l'API URLDownloadToFile ???

Y a t'il une solution Windev ou par VBS ???

Merci



httprequête() ? peut être ? et httpdonnerésultat()



JeAn-PhI
Le #17371931
Thierry 46 a exposé le 29/09/2008 :
Bonjour,

Sur les autres micros (à part le mien où c'est ok) le système ne prend pas en
compte le senkeys "%r" (ALT r), ensuite c'est ok si on intervient....
Problème de focus ? ??

JeAn-PhI a écrit :
Thierry 46 a pensé très fort :
Bonjour,

Est-il possible d'enregistrer un fichier dont on ne connait que 'adresse
http sans avoir à l'ouvrir?

Télécharger un fichier distant depuis son adresse HTTP

J'arrive à tout automatiser mais pour ce passage je suis obligé de passer
par des envoietouche... cela fonctionne à 100% sur mon micro mais pas sur
d'autres micros !


Merci de m'aider à éviter de voir apparaitre la boite de dialogue
"enregistrer sous" et de devoir la piloter !!!

Downloadfile("http://domaine/chemin/fichier.zip","F:Mesdocumentsfichier.zip")


l'API URLDownloadToFile ???

Y a t'il une solution Windev ou par VBS ???

Merci



httprequête() ? peut être ? et httpdonnerésultat()






ResAppel est un booléen
IdFichier est un entier

// Ouverture du fichier "C:MonFichierZIP.zip"
IdFichier = fOuvre("C:MonFichierZIP.zip", foCréation)
SI IdFichier <> -1 ALORS
// Récupération du fichier
ResAppel = HTTPRequête("http://domaine/chemin/fichier.zip")
SI ResAppel = Vrai ALORS
// Enregistrement
fEcrit(IdFichier, HTTPDonneRésultat(),
Taille(HTTPDonneRésultat())
FIN
// Fermeture du fichier
fFerme(IdFichier)
FIN

--
Cordialement JeAn-PhI
Thierry 46
Le #17376521
JeAn-PhI a écrit :
Thierry 46 a exposé le 29/09/2008 :
Bonjour,

Sur les autres micros (à part le mien où c'est ok) le système ne prend
pas en compte le senkeys "%r" (ALT r), ensuite c'est ok si on
intervient....
Problème de focus ? ??

JeAn-PhI a écrit :
Thierry 46 a pensé très fort :
Bonjour,

Est-il possible d'enregistrer un fichier dont on ne connait que
'adresse http sans avoir à l'ouvrir?

Télécharger un fichier distant depuis son adresse HTTP

J'arrive à tout automatiser mais pour ce passage je suis obligé de
passer par des envoietouche... cela fonctionne à 100% sur mon micro
mais pas sur d'autres micros !


Merci de m'aider à éviter de voir apparaitre la boite de dialogue
"enregistrer sous" et de devoir la piloter !!!

Downloadfile("http://domaine/chemin/fichier.zip","F:Mesdocumentsfichier.zip")



l'API URLDownloadToFile ???

Y a t'il une solution Windev ou par VBS ???

Merci



httprequête() ? peut être ? et httpdonnerésultat()






ResAppel est un booléen
IdFichier est un entier

// Ouverture du fichier "C:MonFichierZIP.zip"
IdFichier = fOuvre("C:MonFichierZIP.zip", foCréation)
SI IdFichier <> -1 ALORS
// Récupération du fichier
ResAppel = HTTPRequête("http://domaine/chemin/fichier.zip")
SI ResAppel = Vrai ALORS
// Enregistrement
fEcrit(IdFichier, HTTPDonneRésultat(), Taille(HTTPDonneRésultat())
FIN
// Fermeture du fichier
fFerme(IdFichier)
FIN



Bonjour,

merci, je suis ok avec votre solution que j'ai trouvé sur Internet
ResAppel est un booléen
IdFichier est un entier
// Ouverture du fichier
IdFichier = fOuvre(sTexte_garde, foCréationSiInexistant+foLectureEcriture)
SI IdFichier=-1 ALORS
Erreur("L'ouverture du fichier ZIP a échoué", ErreurInfo())
SINON
ResAppel = HTTPRequête("http:/hermes/tempo/"+texte)
SI ResAppel = Vrai ALORS

fEcrit(IdFichier , HTTPDonneRésultat(), Taille(HTTPDonneRésultat()))
FIN
// Fermeture du fichier
fFerme(IdFichier)
FIN
Publicité
Poster une réponse
Anonyme