terminal et accents

Le
Thomas
bonjour :-)


dans le terminal, ça ne marche pas correctement quand il y a des accents
dans les noms de fichiers
le curseur fait n'importe quoi quand on revient en arrière, par exemple

je n'ai pas de pb à l'affichage proprement dit
je crois que je n'avais pas de pb sous 10.4 parce qu'au moment de
glisser le fichier ça s'écrivait avec des chiffres (que ça retraduisait
sans pb en accent par la suite)

est ce que qqn a une solution ?

--
Téléassistance / Télémaintenance
http://www.portparallele.com/ThomasDECONTES/
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 5
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jo
Le #23092931
On 2011-02-06 17:48:52 +0100, Thomas said:

bonjour :-)



Bonsoir,


dans le terminal, ça ne marche pas correctement quand il y a des accents
dans les noms de fichiers
[...]

est ce que qqn a une solution ?



Terminal->Préférences->Encodage donne quoi?

--
Jo
"Don't suffer from insanity, enjoy every minute of it."
Patrick Stadelmann
Le #23093161
In article Jo
Terminal->Préférences->Encodage donne quoi?



Vérifier aussi que Dans Réglages->Avancé, l'option "Eviter l'entrée non
ASCII" soit bien cochée.

Patrick
--
Patrick Stadelmann
Thomas
Le #23093151
In article Jo
On 2011-02-06 17:48:52 +0100, Thomas said:

> bonjour :-)

Bonsoir,
>
>
> dans le terminal, ça ne marche pas correctement quand il y a des accents
> dans les noms de fichiers
> [...]

> est ce que qqn a une solution ?

Terminal->Préférences->Encodage donne quoi?



il y en a plein de cochés, dont utf-8 (c'est le seul d'unicode) et mac
os roman

il faut que je laisse que ces 2 là, ou que utf-8, ... ?

--
Téléassistance / Télémaintenance
http://www.portparallele.com/ThomasDECONTES/
Thomas
Le #23093241
In article
Patrick Stadelmann
In article Jo
> Terminal->Préférences->Encodage donne quoi?

Vérifier aussi que Dans Réglages->Avancé, l'option "Eviter l'entrée non
ASCII" soit bien cochée.



ça n'était pas coché et je viens de le cocher, mais ça semble ne rien
changer :

- les accents des fichiers s'affichent tjr bien, aussi bien quand on les
glisse avec la souris que quand on les complète avec tabulation
- ça fiche tjr le même bazar avec le curseur

--
Téléassistance / Télémaintenance
http://www.portparallele.com/ThomasDECONTES/
Thomas
Le #23101061
In article
Thomas
bonjour :-)


dans le terminal, ça ne marche pas correctement quand il y a des accents
dans les noms de fichiers
le curseur fait n'importe quoi quand on revient en arrière, par exemple

je n'ai pas de pb à l'affichage proprement dit
je crois que je n'avais pas de pb sous 10.4 parce qu'au moment de
glisser le fichier ça s'écrivait avec des chiffres (que ça retraduisait
sans pb en accent par la suite)

est ce que qqn a une solution ?




pas d'autre idée ?

--
Téléassistance / Télémaintenance
http://www.portparallele.com/ThomasDECONTES/
SAM
Le #23104971
Le 08/02/11 12:31, Thomas a écrit :
In article
Thomas
bonjour :-)


dans le terminal, ça ne marche pas correctement quand il y a des accents
dans les noms de fichiers





Qu'est-ce qui ne "marche" pas "correctement" ?


le curseur fait n'importe quoi quand on revient en arrière, par exemple





J'sais pas c'que ça veut dire

pourquoi le "curseur" revient en arrière ?
Comment le fais-tu ?

je n'ai pas de pb à l'affichage proprement dit
je crois que je n'avais pas de pb sous 10.4 parce qu'au moment de
glisser le fichier ça s'écrivait avec des chiffres (que ça retraduisait
sans pb en accent par la suite)

est ce que qqn a une solution ?




pas d'autre idée ?



Vu qu'on a bien les accentués ... non ... !

et le bouton [ Rétablir les réglages par défaut ]
dans Terminal / Préférences / Encodages
... des fois ...
... non ?



--
Stéphane Moriaux avec/with iMac-intel
Thomas
Le #23106081
In article SAM
Le 08/02/11 12:31, Thomas a écrit :
> In article
> > Thomas >
>> bonjour :-)
>>
>>
>> dans le terminal, ça ne marche pas correctement quand il y a des accents
>> dans les noms de fichiers

Qu'est-ce qui ne "marche" pas "correctement" ?


>> le curseur fait n'importe quoi quand on revient en arrière, par exemple

J'sais pas c'que ça veut dire

pourquoi le "curseur" revient en arrière ?
Comment le fais-tu ?



dans .bash_history :

nohup outils-arb-cmp-d /Volumes/Stockage/Sauvegardes/z
recup/2011/thomas/Library/Mail /Volumes/Stockage/Sauvegardes/z
recup/2010/3 quand je suis repassé sur le
portable/thomas/Library/Mail &> /Volumes/Espace de secours
externe/oacd-2.log &

quand je "revient en arrière" dans l'historique, en appuyant sur la
flèche vers le haut :
http://dl.free.fr/qQaAzeP3C

quand j'appuie sur la flèche vers la droite :
j'ai le bruit d'erreur tout de suite (donc je suis au bout)

quand j'appuie sur la flèche vers la gauche, jusqu'à avoir le bruit
d'erreur :
http://dl.free.fr/aurcJWzvi

donc je te raconte pas le bazar pour modifier la commande
(ou je te raconte, si t'as besoin de précisions supplémentaires)
est ce que c'est assez clair comme ça ?


>> je n'ai pas de pb à l'affichage proprement dit
>> je crois que je n'avais pas de pb sous 10.4 parce qu'au moment de
>> glisser le fichier ça s'écrivait avec des chiffres (que ça retraduisait
>> sans pb en accent par la suite)
>>
>> est ce que qqn a une solution ?
>
>
> pas d'autre idée ?

Vu qu'on a bien les accentués ... non ... !



ok, je pensais que tout le monde avait vu le même pb que moi


et le bouton [ Rétablir les réglages par défaut ]
dans Terminal / Préférences / Encodages
... des fois ...
... non ?



non, ça ne change rien (je n'avais rien changé là dedans)

--
Téléassistance / Télémaintenance
http://www.portparallele.com/ThomasDECONTES/
jperrocheau
Le #23111301
Thomas
> Vérifier aussi que Dans Réglages->Avancé, l'option "Eviter l'entrée non
> ASCII" soit bien cochée.

ça n'était pas coché et je viens de le cocher, mais ça semble ne rien
changer :

- les accents des fichiers s'affichent tjr bien, aussi bien quand on les
glisse avec la souris que quand on les complète avec tabulation
- ça fiche tjr le même bazar avec le curseur



Dans l'aide:
---
Pour afficher les encodages des caractères high-bit :
Choisissez Terminal > Préférences, puis cliquez sur Réglages.
Cliquez sur Avancé.
Sélectionnez un réglage dans la liste située à gauche de la sous-fenêtre
Réglages.
Dans la section Émulation, sélectionnez « Éviter les caractères non
ASCII ».
Désélectionnez « La touche "Option" est une touche virtuelle », le cas
échéant.
Dans la section International, choisissez le jeu de caractères souhaité
dans le menu local « Codage des caractères ».
Sélectionnez « Définir la variable d'environnement LANG au démarrage ».
---

--
Jacques Perrocheau
______________________________________________________________________
e-mail: mailto:
Thomas
Le #23112071
In article (Jacques Perrocheau) wrote:

Thomas
> > Vérifier aussi que Dans Réglages->Avancé, l'option "Eviter l'entrée non
> > ASCII" soit bien cochée.
>
> ça n'était pas coché et je viens de le cocher, mais ça semble ne rien
> changer :
>
> - les accents des fichiers s'affichent tjr bien, aussi bien quand on les
> glisse avec la souris que quand on les complète avec tabulation
> - ça fiche tjr le même bazar avec le curseur

Dans l'aide:



où ça dans l'aide ?
quand je cherche "accents" il n'y a pas de résultat

---
Pour afficher les encodages des caractères high-bit :
Choisissez Terminal > Préférences, puis cliquez sur Réglages.
Cliquez sur Avancé.
Sélectionnez un réglage dans la liste située à gauche de la sous-fenêtre
Réglages.

Dans la section Émulation, sélectionnez « Éviter les caractères non
ASCII ».



déjà fait, sur les conseils de Patrick Stadelmann ci dessus

Désélectionnez « La touche "Option" est une touche virtuelle », le cas
échéant.



pas trouvé

Dans la section International, choisissez le jeu de caractères souhaité
dans le menu local « Codage des caractères ».



le le jeu de caractères souhaité est utf-8 (par défaut), au motif que
c'est celui qui contiens les caractères du monde entier dans le même jeu
de caractères
il me semble qu'en plus, c'est celui qui est approprié du fait que c'est
celui qui est utilisé dans le système de fichiers
(et c'est d'ailleurs celui qu'on m'a dit de mettre sous 10.4 pour que
les choses tombent enfin en marche)

Sélectionnez « Définir la variable d'environnement LANG au démarrage ».



déjà coché

---




je m'aperçois que j'ai oublié de préciser que je suis sous 10.6


et pendant que j'y suis, je précise :

bien entendu, le nec + ultra ca serait que tout se passe bien, y compris
l'affichage des accents à tous les niveaux

mais en attendant de pouvoir y arriver, je préférerais maitriser le
curseur, et ne pas avoir un affichage parfait (comme sous 10.4, quoi)

(que fait l'option "Eviter l'entrée non ASCII", puisque ça n'est pas ça
?)

--
Téléassistance / Télémaintenance
http://www.portparallele.com/ThomasDECONTES/
SAM
Le #23112701
Le 11/02/11 01:30, Thomas a écrit :
In article (Jacques Perrocheau) wrote:

Dans l'aide:



où ça dans l'aide ?
quand je cherche "accents" il n'y a pas de résultat



Ha?

Apprendre à se servir d'un champ de recherche ?

Pourquoi rechercher d'abord du "particulier" et non pas du général ?
comme avec le terme : accent
par exemple

hop ! « Affichage des caractères high-bit »


Oui, oui, c'est sous système 10.6 (10.6.5)

--
Stéphane Moriaux avec/with iMac-intel
Publicité
Poster une réponse
Anonyme