Test egalités multiples

Le
Droopy191
Bonjour,

J'ai des données en colonnes.
les valeurs sur une ligne doivent etre différentes entre elles
Comment faire pour savoir si au moins 2 valeurs sont identiques ?

Pour le moment je fais un si( ou(a1¢, a2£,) , VRAI, FAUX)
Mais c'est trop lourd à gérer et source d'erreur car le nombre de
cellules peut varier d'une ligne à l'autre.

Une idée pour le coder avec une formule en indiquant par exemple une
plage ou les cellules de début et fin.

--
DR
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #4852551
Bonsoir,

Il y quelque chose que je n'ai pas saisie.....
les valeurs sur une ligne doivent etre différentes entre elles
Pour le moment je fais un si( ou(a1¢, a2£,...) , VRAI, FAUX)
C'est pas une ligne qui est testée ??????



--
Salutations
JJ


"Droopy191" 4701391e$0$27789$
Bonjour,

J'ai des données en colonnes.
les valeurs sur une ligne doivent etre différentes entre elles
Comment faire pour savoir si au moins 2 valeurs sont identiques ?

Pour le moment je fais un si( ou(a1¢, a2£,...) , VRAI, FAUX)
Mais c'est trop lourd à gérer et source d'erreur car le nombre de
cellules peut varier d'une ligne à l'autre.

Une idée pour le coder avec une formule en indiquant par exemple une
plage ou les cellules de début et fin.

--
DR


JB
Le #4852531
Bonsoir,

=SI(ESTNA(MODE(A2:A100));"ok";"plusieurs")

JB
http://boisgontierj.free.fr


On 1 oct, 20:15, Droopy191
Bonjour,

J'ai des données en colonnes.
les valeurs sur une ligne doivent etre différentes entre elles
Comment faire pour savoir si au moins 2 valeurs sont identiques ?

Pour le moment je fais un si( ou(a1¢, a2£,...) , VRAI, FAUX)
Mais c'est trop lourd à gérer et source d'erreur car le nombre de
cellules peut varier d'une ligne à l'autre.

Une idée pour le coder avec une formule en indiquant par exemple une
plage ou les cellules de début et fin.

--
DR


Droopy191
Le #4852411
Bonsoir,

Il y quelque chose que je n'ai pas saisie.....
les valeurs sur une ligne doivent etre différentes entre elles
Pour le moment je fais un si( ou(a1¢, a2£,...) , VRAI, FAUX)
C'est pas une ligne qui est testée ??????



Oui ;-)

=si( ou(a1±, b1Á,...) , VRAI, FAUX)

j'ai retenu la proposition de JB avec mode()

--
DR


Modeste
Le #4852211
Bonsour® Droopy191 avec ferveur ;o))) vous nous disiez :
J'ai des données en colonnes.
les valeurs sur une ligne doivent etre différentes entre elles
Comment faire pour savoir si au moins 2 valeurs sont identiques ?

Pour le moment je fais un si( ou(a1¢, a2£,...) , VRAI, FAUX)
Mais c'est trop lourd à gérer et source d'erreur car le nombre de
cellules peut varier d'une ligne à l'autre.

Une idée pour le coder avec une formule en indiquant par exemple une
plage ou les cellules de début et fin.


utiliser une MEFC
selon le nombre de colonnes
selectionner A1:Ax
Menu Format > mise en forme conditionnelle
Condition 1
La formule est : =NB.SI($A1:$I1;A1)>1
Motif : Rouge

ensuite utiliser le pinceau de recopie de format pour les lignes suivantes



--
--
@+
;o)))

Publicité
Poster une réponse
Anonyme