[testing] compiler gqis 2.0.1

Le
Gaëtan PERRIER
Bonjour,

J'essaie de compiler qgis 2.0.1 sur testing depuis le paquet source du dé=
pôt
qgis pour debian wheezy.
J'ai installé toutes les dépendances mais lorsque que je lance debuild =
-uc -us
ça se finit sur :

CMake Error: The following variables are used in this project, but they are
set to NOTFOUND. Please set them or make sure they are set and tested
correctly in the CMake files: PYTHON_LIBRARY

Auriez-vous une idée de comment corriger cela ?

Gaëtan

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/20131126225343.3c2880475b1c5bf47204a1f3@neuf.fr
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Samy Mezani
Le #25821272
le 26/11/2013 22:53, Gaëtan PERRIER a écrit:
J'essaie de compiler qgis 2.0.1 sur testing depuis le paquet source du dépôt
qgis pour debian wheezy.



Bonjour,

C'est vrai que ça devient de pire en pire de pouvoir utiliser QGis sur
Debian depuis quelques temps...

Si je comprends bien pour Sid et Jessie, ils proposent d'utiliser les
'nightly-builds' ou de compiler soi-même.
J'avais aussi tenté la compilation sur Sid, mais sans succès.

Ça ne résoudra pas ton problème, mais as-tu essayé une version nightly
qui pourrait correspondre à tes version de Qt, Python, etc. sur Jessie ?

Sur Sid, j'ai celle-là : 2.1.0+git20131103+a411e79~unstable1
Depuis je bloque sa mise à jour avec "aptitude hold qgis".

<HS>
Quand je vois que le format Excel est maintenant reconnu par défaut, et
toujours pas le format ODS... Bien-sûr il ya l'extension XYTools mais bon...
</HS>

Samy

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Gaëtan PERRIER
Le #25823312
Le Wed, 27 Nov 2013 09:08:03 +0100
Samy Mezani
le 26/11/2013 22:53, Gaëtan PERRIER a écrit:
> J'essaie de compiler qgis 2.0.1 sur testing depuis le paquet source du
> dépôt qgis pour debian wheezy.

Bonjour,

C'est vrai que ça devient de pire en pire de pouvoir utiliser QGis sur
Debian depuis quelques temps...

Si je comprends bien pour Sid et Jessie, ils proposent d'utiliser les
'nightly-builds' ou de compiler soi-même.
J'avais aussi tenté la compilation sur Sid, mais sans succès.

Ça ne résoudra pas ton problème, mais as-tu essayé une version ni ghtly
qui pourrait correspondre à tes version de Qt, Python, etc. sur Jessie ?



Justement avant j'étais en nightly mais comme régulièrement lors des mises à
jours il manquait des bouts, ça m'obligeait à freezer qgis, je me suis donc
dit que pour être tranquille j'allais installer la version stable ...

Gaëtan

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Gaëtan PERRIER
Le #25941402
Je reviens sur le sujet parce que je viens de voir que maintenant il y avait
des dépôts pour jessie et sid fournissant la version stable de qgis.
J'ai donc essayé mais malheureusement la version jessie n'a pas les bonnes
dépendances car elle dépend de libgdal1 alors que dans debian jessie c' est
libgdal1h ...

Gaëtan

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme