[testing] installer hplip 3.15.2

Le
Gaëtan PERRIER
Bonjour,

La version d'hplip dans debian date d'il y a plus de 8 mois
(3.14.6) et la durée de vie des imprimantes sur le marché n'est pas si =
longue.
Du coup nombre d'imprimantes en vente actuellement nécessite au moins la
version 3.14.10.
Je me demande donc si quelqu'un a déjà installer hplip depuis le wizard=
du
site http://hplipopensource.com ? Est-ce ça pose des problèmes ?

Gaëtan

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: https://lists.debian.org/20150221004154.e98cd018bb4cd8a97d4210b7@neuf.fr
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
yamo'
Le #26340234
Salut,

Gaëtan PERRIER a écrit le 21/02/2015 00:50 :
Bonjour,

La version d'hplip dans debian date d'il y a plus de 8 mois
(3.14.6) et la durée de vie des imprimantes sur le marché n'est pas si longue.
Du coup nombre d'imprimantes en vente actuellement nécessite au moins la
version 3.14.10.
Je me demande donc si quelqu'un a déjà installer hplip depuis le wizard du
site http://hplipopensource.com ? Est-ce ça pose des problèmes ?






Je ne sais pas mais, tu as deux méthodes d'installation (pour la
deuxième qui devrait mieux fonctionner, je ferais checkinstall au lieu
de make install) :


Je ne peux pas en dire plus, je n'ai que du canon chez moi.

--
Stéphane

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/mc9ja8$ptd$
Gaëtan PERRIER
Le #26340425
Le Sat, 21 Feb 2015 10:31:51 +0100
yamo'
Salut,

Gaëtan PERRIER a écrit le 21/02/2015 00:50 :
> Bonjour,
>
> La version d'hplip dans debian date d'il y a plus de 8 mois
> (3.14.6) et la durée de vie des imprimantes sur le marché n'est pas si
> longue. Du coup nombre d'imprimantes en vente actuellement nécessite au
> moins la version 3.14.10.
> Je me demande donc si quelqu'un a déjà installer hplip depuis le wi zard du
> site http://hplipopensource.com ? Est-ce ça pose des problèmes ?




Je ne sais pas mais, tu as deux méthodes d'installation (pour la
deuxième qui devrait mieux fonctionner, je ferais checkinstall au lieu
de make install) :




Effectivement je n'avais pas fait attention à cette méthode. Si quelqu' un à
des retours ? Faut-il d'abord enlever les paquets debian ?


Je ne peux pas en dire plus, je n'ai que du canon chez moi.




Les pilotes sont sous quel licence ? Est-ce que l'on a une pérennité en
fonction des évolutions de Linux. Je n'ai pas envie de retomber dans le
problème que j'ai eu avec mon scanner Epson qui avait un pilote proprio et
dont j'ai du me séparer quand je suis passé en 64 bits car epson n'a pas
fournit de version 64 bits pour les scanner anciens.

Gaëtan

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Romain Casati
Le #26340530
This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--k4cdmVk4rMVW0WkhOGk5QE8rAql8jGbRE
Content-Type: text/plain; charset=windows-1252
Content-Transfer-Encoding: quoted-printable

Bonjour

On 21/02/2015 00:41, Gaëtan PERRIER wrote:
Bonjour,

La version d'hplip dans debian date d'il y a plus de 8 mois
(3.14.6) et la durée de vie des imprimantes sur le marché n'est pas si longue.
Du coup nombre d'imprimantes en vente actuellement nécessite au moins la
version 3.14.10.
Je me demande donc si quelqu'un a déjà installer hplip depuis le wi zard du
site http://hplipopensource.com ? Est-ce ça pose des problèmes ?

Gaëtan




J'ai récemment installé une HP ENVY 4507 sur une Debian stable 32bits en
suivant ces instructions :

http://hplipopensource.com/hplip-web/install/install/index.html

J'avais pris soin de désinstaller le paquet hplib et tout a bien
fonctionné, même l'impression recto-verso (duplex) et le scanner ! Ç a a
un peu râlé au début, disant que le pilote n'était compatible qu' avec
Debian 7.6 et que 7.8 n'était pas supporté mais c'était juste un
avertissement.

Bonne installation,
Romain


--k4cdmVk4rMVW0WkhOGk5QE8rAql8jGbRE
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAEBAgAGBQJU6tsAAAoJEBnSfTFkaJJgBzUP/i9Q0HgO1gL+WrkjWbO9zoBJ
7hHWKwgc8/pMkawoE1QWs6wpBQJTlxsiXJdLUN/mhZpm4WJy9jJselRULg0Z8Oz8
K462MhQEXLuAq2nYpK9q103GOzDj8GbW2C4zbZRGn+w1IRigmNpRint/glOMexWX
qlOyN6V9VZdoqCvnL9NwW7Wa8RCGupT/TcO3GPVJfn+nTlWmejbjOyfBZK0/ocl5
49cLaL25aDCM7DtgPg67W7iFhmbt43dF1rbxMa2ILsETNZ+O6VV8kOwnDXRS1GrS
PIxW4EuLmOvv73y3kxbrrVIXDHdilvu9XWHO5yMb0ECbbOsRlfkvFMlyiQmg9XLP
p3RquQ4gMYCRcJUbgsPLRt84BCFA/5Zn4be7N/F53tlN/8SfwjfkL9hq9avFbXCk
GJlLN1tNuXezzHlz0ivNJlJtQ/9ifFHGWIU1DRGS7NjeOYyKv4uTi9vkcDPy6Xv/
r12jqqv0zkdmg34AjyVH2slH6JqpS0/qRDHnj3CrVVcUVWzSUnsmCIqUHcNL6EXg
7darLLe2JgAMGjnSTWvIfMW3PlCPEaSV1VJ4kyflT132QT0NMyCildwPBJqz8a1D
WCf/8/cetuh1wTyjBf26RWQhIdoBaiHPcmhPKIfXtjamOL/W/C9NiRql3KS2rMkb
L1kmPvXaYWr2qTR9IV/B
=7WHc
-----END PGP SIGNATURE-----

--k4cdmVk4rMVW0WkhOGk5QE8rAql8jGbRE--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Romain Casati
Le #26340532
This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--8vqOHmfEF99uTfswEglqNs8hLfoVomoUW
Content-Type: text/plain; charset=windows-1252
Content-Transfer-Encoding: quoted-printable



On 22/02/2015 16:27, Gaëtan PERRIER wrote:
Le Sat, 21 Feb 2015 10:31:51 +0100
yamo'
Salut,

Gaëtan PERRIER a écrit le 21/02/2015 00:50 :
Bonjour,

La version d'hplip dans debian date d'il y a plus de 8 mois
(3.14.6) et la durée de vie des imprimantes sur le marché n'est p as si
longue. Du coup nombre d'imprimantes en vente actuellement nécessit e au
moins la version 3.14.10.
Je me demande donc si quelqu'un a déjà installer hplip depuis le wizard du
site http://hplipopensource.com ? Est-ce ça pose des problèmes ?






Je ne sais pas mais, tu as deux méthodes d'installation (pour la
deuxième qui devrait mieux fonctionner, je ferais checkinstall au li eu
de make install) :




Effectivement je n'avais pas fait attention à cette méthode. Si que lqu'un à
des retours ? Faut-il d'abord enlever les paquets debian ?


Je ne peux pas en dire plus, je n'ai que du canon chez moi.




Les pilotes sont sous quel licence ? Est-ce que l'on a une pérennité en
fonction des évolutions de Linux. Je n'ai pas envie de retomber dans le
problème que j'ai eu avec mon scanner Epson qui avait un pilote propr io et
dont j'ai du me séparer quand je suis passé en 64 bits car epson n' a pas
fournit de version 64 bits pour les scanner anciens.



D'après cette page http://hplipopensource.com/node/296 , les pilotes
sont sous trois licences libres GPLv2, MIT et BSD (c'est indiqué dans
l'en-tête de chaque fichier apparemment). Il y a aussi ce petit
paragraphe qui m'interroge :

"A small subset of HP devices require proprietary software technologies
to allow full access to printer features and performance. These
technologies cannot be open sourced. Because of this, HP is releasing
binary plug-ins for each of these printers that work in conjunction with
our Linux Open Source Printing Software to improve the printing
experience for HP’s Linux Printing Customers. These binary plug-ins
require the user to read and agree to a license agreement at the time of
driver installation."

Je n'ai pas le souvenir d'avoir accepté une licence au moment de
l'installation... Cependant, le paquet hplip de Debian est sur la
branche main et pas non-free.

Concernant ton problème, n'était-il pas possible d'installer les paqu ets
32bit nécessaires même sur ton architecture 64bit afin de faire
fonctionner les pilotes Epson ? C'est assez facile avec Debian, il y a
un tutoriel ici https://wiki.debian.org/fr/Multiarch/HOWTO .

Romain

Gaëtan





--8vqOHmfEF99uTfswEglqNs8hLfoVomoUW
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAEBAgAGBQJU6t7nAAoJEBnSfTFkaJJgRAwP/3lo+sxMGGXH16Jesy6Xi6g6
9p6XbElw/CP0w/OQ2SrAPCxO9DHEcGfZTF+u5YswDZppo7qZxRcc3esvvZNE1BbU
amPMGQdLlO6UMoHQumMh7sLgS/t6mzCB3PYk6YSLm9ZsfybUOq7AaTFG+53xxy5k
zaZiE8UMTFJyMZ7uAXHUtfgIvJcGyOoPSdiuJPBZFvia4FQuYHA4LYRTGkgajUVV
Ht88rwbK6cRyFHHFETAACt2MsLm2B0845lNZpNhDyyMnM/SH9yIsSoj/v1cfy85u
HGA5oqvd8Y+msyBZHgyd46NjxcMmAVbo/YX5fphlNFaCCDzcDVX/t6UtmzS9EOFD
yPmWwWl4uWTIORaTWJfeW/MAibXsaXGq0lWNKm22M6EVzRwpCKjhOovJwsxEVvcp
NjZd0W+ssYgwQ2gZc2TCWIEeflQjays2YLOPaOSXJ6usTJEQkHsZVrvos6ijm8u1
MlS7eWFpTBzdT/CVq7NvUMLiX6sYptllulIx3sIozk3p8M8FvkhVjRrWX7WMIugJ
nO7jD/2oc6dfGiC6xMJ6xqIqgPcLOzJ7pbybTfIXpzhu1sTQSXDCKL9suoQZq/1J
rgdXrU1qTOvQDRQdELOH2baxSd2YoSPUV2t8bNyz8DgRwVNJVaxWSLz8vjl9VvuP
zZ7O+CYbu94ojcvTJqkX
=kFDl
-----END PGP SIGNATURE-----

--8vqOHmfEF99uTfswEglqNs8hLfoVomoUW--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Sylvain L. Sauvage
Le #26340554
Le lundi 23 février 2015, 09:03:51 Romain Casati a écrit :
[…]
>> Je ne peux pas en dire plus, je n'ai que du canon chez moi.
>
> Les pilotes sont sous quel licence ?
> […]
D'après cette page http://hplipopensource.com/node/296 , les
pilotes sont sous trois licences libres GPLv2, MIT et BSD
[…]



Gaëtan parlait des pilotes Canon… dont je suppose la lic ence
(suis pas allé voir le site) empêche de faire des paquets†¦

→ https://wiki.debian.org/PrinterDriver/Canon/UFR-II

Il y a aussi ce petit paragraphe qui m'interroge :

"A small subset of HP devices require proprietary software
technologies to allow full access to printer features and
performance. These technologies cannot be open sourced.
Because of this, HP is releasing binary plug-ins for each of
these printers that work in conjunction with our Linux Open
Source Printing Software to improve the printing experience
for HP’s Linux Printing Customers. These binary plug-ins
require the user to read and agree to a license agreement at
the time of driver installation."

Je n'ai pas le souvenir d'avoir accepté une licence au moment
de l'installation... Cependant, le paquet hplip de Debian est
sur la branche main et pas non-free.



Ça doit concerner des micrologiciels (firmware) pour certains
produits. S’ils ne sont pas fournis dans Debian, pas besoin
d’EULA.

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Erwan David
Le #26340558
On Mon, Feb 23, 2015 at 11:29:26AM CET, "Sylvain L. Sauvage"
Le lundi 23 février 2015, 09:03:51 Romain Casati a écrit :
>[…]
> >> Je ne peux pas en dire plus, je n'ai que du canon chez moi.
> >
> > Les pilotes sont sous quel licence ?
> > […]
> D'après cette page http://hplipopensource.com/node/296 , les
> pilotes sont sous trois licences libres GPLv2, MIT et BSD
> […]

Gaëtan parlait des pilotes Canon… dont je suppose la licence
(suis pas allé voir le site) empêche de faire des paquets…

https://wiki.debian.org/PrinterDriver/Canon/UFR-II

> Il y a aussi ce petit paragraphe qui m'interroge :
>
> "A small subset of HP devices require proprietary software
> technologies to allow full access to printer features and
> performance. These technologies cannot be open sourced.
> Because of this, HP is releasing binary plug-ins for each of
> these printers that work in conjunction with our Linux Open
> Source Printing Software to improve the printing experience
> for HP’s Linux Printing Customers. These binary plug-ins
> require the user to read and agree to a license agreement at
> the time of driver installation."
>
> Je n'ai pas le souvenir d'avoir accepté une licence au moment
> de l'installation... Cependant, le paquet hplip de Debian est
> sur la branche main et pas non-free.

Ça doit concerner des micrologiciels (firmware) pour certains
produits. S’ils ne sont pas fournis dans Debian, pas besoin
d’EULA.



hplip ne contient pas ces softs, mais peut les télécharger et c'est à
ce moment là que la question est posée (j'ai du accepter cette licence
pour un binaire pour ma laserjet M125

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Gaëtan PERRIER
Le #26340838
Le Mon, 23 Feb 2015 08:47:12 +0100
Romain Casati
Bonjour

On 21/02/2015 00:41, Gaëtan PERRIER wrote:
> Bonjour,
>
> La version d'hplip dans debian date d'il y a plus de 8 mois
> (3.14.6) et la durée de vie des imprimantes sur le marché n'est pas si
> longue. Du coup nombre d'imprimantes en vente actuellement nécessite au
> moins la version 3.14.10.
> Je me demande donc si quelqu'un a déjà installer hplip depuis le wi zard du
> site http://hplipopensource.com ? Est-ce ça pose des problèmes ?
>
> Gaëtan
>

J'ai récemment installé une HP ENVY 4507 sur une Debian stable 32bits en
suivant ces instructions :

http://hplipopensource.com/hplip-web/install/install/index.html

J'avais pris soin de désinstaller le paquet hplib et tout a bien
fonctionné, même l'impression recto-verso (duplex) et le scanner ! Ça a
un peu râlé au début, disant que le pilote n'était compatible qu' avec
Debian 7.6 et que 7.8 n'était pas supporté mais c'était juste un
avertissement.

Bonne installation,
Romain




Merci pour ton retour.

Gaëtan

PS: réponse tardive, le message était dans les spams ...

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
yamo'
Le #26340921
Salut,

Gaëtan PERRIER a écrit le 22/02/2015 16:30 :
Le Sat, 21 Feb 2015 10:31:51 +0100
yamo'




Effectivement je n'avais pas fait attention à cette méthode. Si quelqu'un à
des retours ? Faut-il d'abord enlever les paquets debian ?



En faisant checkinstall (sans le make install), ce ne sera pas utile.


Je ne peux pas en dire plus, je n'ai que du canon chez moi.




Les pilotes sont sous quel licence ? Est-ce que l'on a une pérennité en
fonction des évolutions de Linux. Je n'ai pas envie de retomber dans le
problème que j'ai eu avec mon scanner Epson qui avait un pilote proprio et
dont j'ai du me séparer quand je suis passé en 64 bits car epson n'a pas
fournit de version 64 bits pour les scanner anciens.



C'est très variable. Mais en fait, je ne les utilise que très rarement
et je n'ai pas eu le temps de m'en occuper sérieusement ; elles ne sont
pas installées sauf sur un viel ordi sur debian squeeze. Et j'ai un
problème de configuration de cups. Là mon IP4200 bien que branchée sur
une debian squeeze n'est réellement utilisée que sur un XP bidouillé
pour qu'il n'aille pas sur le net...
J'en ai une autre que je n'ai pas réussit à faire fonctionner en 64bits!


Les imprimantes : une imprimante achetée il y a longtemps quand j'étais
sur windows, l'autre j'avais vérifié qu'elle était supportée et en fait
c'est pas vraiment le cas...
La prochaine ne sera probablement pas une canon.



--
Stéphane

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/mckd4g$kd5$
Gaëtan PERRIER
Le #26341116
Le Mon, 23 Feb 2015 08:47:12 +0100
Romain Casati
Bonjour

On 21/02/2015 00:41, Gaëtan PERRIER wrote:
> Bonjour,
>
> La version d'hplip dans debian date d'il y a plus de 8 mois
> (3.14.6) et la durée de vie des imprimantes sur le marché n'est pas si
> longue. Du coup nombre d'imprimantes en vente actuellement nécessite au
> moins la version 3.14.10.
> Je me demande donc si quelqu'un a déjà installer hplip depuis le wi zard du
> site http://hplipopensource.com ? Est-ce ça pose des problèmes ?
>
> Gaëtan
>

J'ai récemment installé une HP ENVY 4507 sur une Debian stable 32bits en
suivant ces instructions :

http://hplipopensource.com/hplip-web/install/install/index.html

J'avais pris soin de désinstaller le paquet hplib et tout a bien
fonctionné, même l'impression recto-verso (duplex) et le scanner ! Ça a
un peu râlé au début, disant que le pilote n'était compatible qu' avec
Debian 7.6 et que 7.8 n'était pas supporté mais c'était juste un
avertissement.

Bonne installation,
Romain




Salut,

Je suis passé par la méthode manuelle
http://hplipopensource.com/hplip-web/install/manual/distros/debian.html
avec checkinstall
Il faut enlever les paquets hplip existant car il y des conflits avec le
paquet généré.
L'imprimante est bien reconnue par contre le scanner ...
Pour info je suis relié en ethernet.

Gaëtan

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Gaëtan PERRIER
Le #26341692
Le Fri, 27 Feb 2015 01:15:23 +0100
Gaëtan PERRIER

L'imprimante est bien reconnue par contre le scanner ...
Pour info je suis relié en ethernet.




Quand je lance hp-scan voici ce qu'il me dit:

HP Linux Imaging and Printing System (ver. 3.15.2)
Scan Utility ver. 2.2

Copyright (c) 2001-15 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Using device: hpaio:/net/ENVY_7640_series?ip2.168.1.81

warning: No destinations specified. Adding 'file' destination by default.
error: Unable to locate device hpaio:/net/ENVY_7640_series?ip2.168.1.81
using SANE backend hpaio:. Please check HPLIP installation.

Je ne sais pas quoi vérifier et où vérifier dans mon installation hpl ip ?

Gaëtan

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Publicité
Poster une réponse
Anonyme