[Testing/Sid] Problème automount USB

Le
Christophe Gallaire
Bonjour,

Ça fait maintenant un bon moment que je rencontre un problème avec le montage
automatique des supports de stockage USB : à l'insertion la clé ou le disque USB
sont montés sur les points /media/usb0, /media/usb1 Il m'est impossible de
les démonter en tant qu'utilisateur. Seul un :

# umount /media/usb0

permet de retirer proprement le média.

J'ai tenté de contourner le problème en créant une règle perso UDEV avec une
entrée dans /etc/fstab mais le problème persiste :

Error mounting: mount exited with exit code 1: helper failed with:
mount: only root can mount /dev/iAudio on /media/iAudio

Une idée ?

@+

Christophe
--
Christophe Gallaire

Attention ! Suppression des mails entrants dont la taille est supérieure à 2Mo !
N'envoyez, s'il vous plaît, que des pièces jointes en formats ouverts.

"Les clèbs [mutts] n'ont pas de punaises [bugs] mais des puces !"

Carnet de route : http://www.road2mayotte.org

Linux On The Root : http://ubunteros.tuxfamily.org/
--
Signature numérique GPG de ce mail : 1D6DB30A
-

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/20100417035002.GA11289@namak
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
christophe
Le #21582741
Bonjour,

Le samedi 17 avril 2010 à 06:50 +0300, Christophe Gallaire a écrit :
Bonjour,

Ça fait maintenant un bon moment que je rencontre un problème avec le montage
automatique des supports de stockage USB : à l'insertion la clé ou le disque USB
sont montés sur les points /media/usb0, /media/usb1... Il m'est impossible de
les démonter en tant qu'utilisateur. Seul un :

# umount /media/usb0

permet de retirer proprement le média.

J'ai tenté de contourner le problème en créant une règle perso UDEV avec une
entrée dans /etc/fstab mais le problème persiste :

Error mounting: mount exited with exit code 1: helper failed with:
mount: only root can mount /dev/iAudio on /media/iAudio



Il suffit de mettre l'option 'user' à l'entrée fstab :

/dev/iAudio /media/iAudio auto user,noauto 0 0

Par défaut, seul root peut effectuer un montage, et seule la personne
ayant effectué le montage le démonter (cf. man mount, rubrique "The
non-superuser mounts" pour plus d'informations sur les options user et
users).

Cordialement,
Christophe

Une idée ?

@+

Christophe
--
Christophe Gallaire

Attention ! Suppression des mails entrants dont la taille est supérieure à 2Mo !
N'envoyez, s'il vous plaît, que des pièces jointes en formats ouverts.

"Les clèbs [mutts] n'ont pas de punaises [bugs] mais des puces !"

Carnet de route : http://www.road2mayotte.org
---------------
Linux On The Root : http://ubunteros.tuxfamily.org/
-----------------
Signature numérique GPG de ce mail : 1D6DB30A
----------------------------------





--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Christophe Gallaire
Le #21583541
Bonjour,

christophe a dit dans un souffle :
Bonjour,

Le samedi 17 avril 2010 à 06:50 +0300, Christophe Gallaire a écrit :
Bonjour,

Ça fait maintenant un bon moment que je rencontre un problème avec le montage
automatique des supports de stockage USB : à l'insertion la clé ou le disque USB
sont montés sur les points /media/usb0, /media/usb1... Il m'est impossible de
les démonter en tant qu'utilisateur. Seul un :

# umount /media/usb0

permet de retirer proprement le média.

J'ai tenté de contourner le problème en créant une règle perso UDEV avec une
entrée dans /etc/fstab mais le problème persiste :

Error mounting: mount exited with exit code 1: helper failed with:
mount: only root can mount /dev/iAudio on /media/iAudio



Il suffit de mettre l'option 'user' à l'entrée fstab :

/dev/iAudio /media/iAudio auto user,noauto 0 0



J'ai bien utilisé l'option "user". J'ai l'impression qu'il y a quelque chose, un
mécanisme qui outrepasse ce qui est contenu dans /etc/fstab.

Je peux monter, à l'insertion, le périphérique sur le bureau mais je ne peux pas
le démonter avec les droits de l'utilisateur.

Par défaut, seul root peut effectuer un montage, et seule la personne
ayant effectué le montage le démonter (cf. man mount, rubrique "The
non-superuser mounts" pour plus d'informations sur les options user et
users).


Cordialement,
Christophe

Une idée ?





@+





Christophe
--
Christophe Gallaire

Attention ! Suppression des mails entrants dont la taille est supérieure à 2Mo !
N'envoyez, s'il vous plaît, que des pièces jointes en formats ouverts.

"Les clèbs [mutts] n'ont pas de punaises [bugs] mais des puces !"

Carnet de route : http://www.road2mayotte.org
---------------
Linux On The Root : http://ubunteros.tuxfamily.org/
-----------------
Signature numérique GPG de ce mail : 1D6DB30A
----------------------------------

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Christophe Gallaire
Le #21583671
christophe a dit dans un souffle :
Bonjour,

Le samedi 17 avril 2010 à 06:50 +0300, Christophe Gallaire a écrit :
Bonjour,

Ça fait maintenant un bon moment que je rencontre un problème avec le montage
automatique des supports de stockage USB : à l'insertion la clé ou le disque USB
sont montés sur les points /media/usb0, /media/usb1... Il m'est impossible de
les démonter en tant qu'utilisateur. Seul un :

# umount /media/usb0





J'ai oublié de préciser deux choses :

1. Le périphérique apparaît deux fois : une fois la forme d'une icône de clé USB
et une icône sous la forme d'un disque dur. Au montage, si je clique sur la
première icône (clé usb) voilà le message d'erreur :

Impossible de monter l'emplacement
Erreur interne : No mount object for mounted volume

2. Si je démonte le périphérique par umount /media/iAudio et clique à nouveau
sur l'icône de la clé, il se monte normalement et je peux le démonter avec
les droits de l'utilisateur. L'icône du disque dur d'ailleurs disparaît au
démontage mais ne réapparaît pas si je clique sur la clé.

permet de retirer proprement le média.

J'ai tenté de contourner le problème en créant une règle perso UDEV avec une
entrée dans /etc/fstab mais le problème persiste :

Error mounting: mount exited with exit code 1: helper failed with:
mount: only root can mount /dev/iAudio on /media/iAudio



Il suffit de mettre l'option 'user' à l'entrée fstab :

/dev/iAudio /media/iAudio auto user,noauto 0 0

Par défaut, seul root peut effectuer un montage, et seule la personne
ayant effectué le montage le démonter (cf. man mount, rubrique "The
non-superuser mounts" pour plus d'informations sur les options user et
users).

Cordialement,
Christophe

Une idée ?





@+





Christophe
--
Christophe Gallaire

Attention ! Suppression des mails entrants dont la taille est supérieure à 2Mo !
N'envoyez, s'il vous plaît, que des pièces jointes en formats ouverts.

"Les clèbs [mutts] n'ont pas de punaises [bugs] mais des puces !"

Carnet de route : http://www.road2mayotte.org
---------------
Linux On The Root : http://ubunteros.tuxfamily.org/
-----------------
Signature numérique GPG de ce mail : 1D6DB30A
----------------------------------





--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Frederic MASSOT
Le #21583971
Christophe Gallaire a écrit :
christophe a dit dans un souffle :
Bonjour,

Le samedi 17 avril 2010 à 06:50 +0300, Christophe Gallaire a écrit :
Bonjour,

Ça fait maintenant un bon moment que je rencontre un problème avec le
montage
automatique des supports de stockage USB : à l'insertion la clé ou le
disque USB
sont montés sur les points /media/usb0, /media/usb1... Il m'est
impossible de
les démonter en tant qu'utilisateur. Seul un :

# umount /media/usb0





J'ai oublié de préciser deux choses :

1. Le périphérique apparaît deux fois : une fois la forme d'une icône de
clé USB
et une icône sous la forme d'un disque dur. Au montage, si je clique
sur la
première icône (clé usb) voilà le message d'erreur : Impossible
de monter l'emplacement
Erreur interne : No mount object for mounted volume

2. Si je démonte le périphérique par umount /media/iAudio et clique à
nouveau
sur l'icône de la clé, il se monte normalement et je peux le démonter
avec
les droits de l'utilisateur. L'icône du disque dur d'ailleurs
disparaît au
démontage mais ne réapparaît pas si je clique sur la clé.




Normalement, c'est udev associé à devicekit-disks (bientôt remplacé par
udisks) qui gère la découverte des périphériques disques. Puis pour les
droits d'accès il y a le fichier "/etc/fstab" et policykit.

Tu as modifié les règles de udev (cf /etc/udev/rules.d/*) ?

Tu fais partie de quel groupe ?

Il y a quelque chose dans le fichier "/etc/PolicyKit/PolicyKit.conf" ?


--
============================================= | FRÉDÉRIC MASSOT |
| http://www.juliana-multimedia.com |
| mailto: |
==========================Þbian=GNU/Linux==
--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Christophe Gallaire
Le #21584131
Frederic MASSOT a dit dans un souffle :
Christophe Gallaire a écrit :
christophe a dit dans un souffle :
Bonjour,

Le samedi 17 avril 2010 à 06:50 +0300, Christophe Gallaire a écrit :
Bonjour,

Ça fait maintenant un bon moment que je rencontre un problème avec le
montage
automatique des supports de stockage USB : à l'insertion la clé ou le
disque USB
sont montés sur les points /media/usb0, /media/usb1... Il m'est
impossible de
les démonter en tant qu'utilisateur. Seul un :

# umount /media/usb0





J'ai oublié de préciser deux choses :

1. Le périphérique apparaît deux fois : une fois la forme d'une icône de
clé USB
et une icône sous la forme d'un disque dur. Au montage, si je clique
sur la
première icône (clé usb) voilà le message d'erreur : Impossible
de monter l'emplacement
Erreur interne : No mount object for mounted volume

2. Si je démonte le périphérique par umount /media/iAudio et clique à
nouveau
sur l'icône de la clé, il se monte normalement et je peux le démonter
avec
les droits de l'utilisateur. L'icône du disque dur d'ailleurs
disparaît au
démontage mais ne réapparaît pas si je clique sur la clé.




Normalement, c'est udev associé à devicekit-disks (bientôt remplacé par
udisks) qui gère la découverte des périphériques disques. Puis pour les
droits d'accès il y a le fichier "/etc/fstab" et policykit.

Tu as modifié les règles de udev (cf /etc/udev/rules.d/*) ?



Non. J'ai créé une règle ici : /lib/udev/rules.d/

cat 10-local.rules
BUS=="usb", ATTRS{serial}=="5002000FFE5A99850910301523570C3E", KERNEL=="sd*",
NAME="iAudio", GROUP="zamasp"

Tu fais partie de quel groupe ?



zamasp:x:1000:root,zamasp

Il y a quelque chose dans le fichier "/etc/PolicyKit/PolicyKit.conf" ?



Absolument rien.

@+

Christophe
--
============================================= >| FRÉDÉRIC MASSOT |
| http://www.juliana-multimedia.com |
| mailto: |
==========================Þbian=GNU/Linux== >
--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/



--
Christophe Gallaire

Attention ! Suppression des mails entrants dont la taille est supérieure à 2Mo !
N'envoyez, s'il vous plaît, que des pièces jointes en formats ouverts.

"Les clèbs [mutts] n'ont pas de punaises [bugs] mais des puces !"

Carnet de route : http://www.road2mayotte.org
---------------
Linux On The Root : http://ubunteros.tuxfamily.org/
-----------------
Signature numérique GPG de ce mail : 1D6DB30A
----------------------------------

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Frederic MASSOT
Le #21584911
Christophe Gallaire a écrit :
[...]

Normalement, c'est udev associé à devicekit-disks (bientôt remplacé par
udisks) qui gère la découverte des périphériques disques. Puis pour les
droits d'accès il y a le fichier "/etc/fstab" et policykit.

Tu as modifié les règles de udev (cf /etc/udev/rules.d/*) ?



Non. J'ai créé une règle ici : /lib/udev/rules.d/

cat 10-local.rules
BUS=="usb", ATTRS{serial}=="5002000FFE5A99850910301523570C3E",
KERNEL=="sd*",
NAME="iAudio", GROUP="zamasp"

Tu fais partie de quel groupe ?



zamasp:x:1000:root,zamasp



La commande "id" te donne toute ces infos.

Normalement, tu devrais faire partie du groupe "plugdev", voir "disk".

Il y a quelque chose dans le fichier "/etc/PolicyKit/PolicyKit.conf" ?



Absolument rien.



Le bloc ci-dessous permet aux utilisateurs du groupe "adm" d'avoir tout
les droits pour PolicyKit :

<define_admin_auth group="adm"/>
</config>

Tu peux l'adapter à tes besoins.

--
============================================= | FRÉDÉRIC MASSOT |
| http://www.juliana-multimedia.com |
| mailto: |
==========================Þbian=GNU/Linux==
--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme