[testing] vim 8: erreur au lancement

Le
Gaëtan PERRIER
Bonjour,

Depuis le passage à Vim 8 j'ai une série d'erreurs au lancement:

Erreur détectée en traitant /usr/share/vim/vim80/mswin.vim :
ligne 47 :
E121: Variable non définie : paste#paste_cmd
E15: Expression invalide : 'inoremap <script> <C-V> <C-G>u' . paste#paste_c=
md
['i'] ligne 48 :
E121: Variable non définie : paste#paste_cmd
E15: Expression invalide : 'vnoremap <script> <C-V> ' . paste#paste_cmd['v']

Erreur détectée en traitant /usr/share/vim/vim80/menu.vim :
ligne 156 :
E121: Variable non définie : paste#paste_cmd
E15: Expression invalide : 'vnoremenu <script> &Edit.&Paste<Tab>"+gP^I' .
paste#paste_cmd['v']

Avez-vous la même chose ?

Gaëtan
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
bernard schoenacker
Le #26412716
On Thu, 13 Oct 2016 00:04:43 +0200
Gaëtan PERRIER
Bonjour,
Depuis le passage à Vim 8 j'ai une série d'erreurs au lancement:
Erreur détectée en traitant /usr/share/vim/vim80/mswin.vim :
ligne 47 :
E121: Variable non définie : paste#paste_cmd
E15: Expression invalide : 'inoremap <script> <C-V> <C-G>u' .
paste#paste_cmd ['i'] ligne 48 :
E121: Variable non définie : paste#paste_cmd
E15: Expression invalide : 'vnoremap <script> <C-V> ' .
paste#paste_cmd['v']
Erreur détectée en traitant /usr/share/vim/vim80/menu.vim :
ligne 156 :
E121: Variable non définie : paste#paste_cmd
E15: Expression invalide : 'vnoremenu <script>
&Edit.&Paste<Tab>"+gP^I' .
paste#paste_cmd['v']
Avez-vous la même chose ?
Gaëtan


bonjour,
serait il possible de comparer :
dpkg -l |awk '/vim/ {print $1" "$2" "$3}'
ii neovim 0.1.5-6
ii neovim-runtime 0.1.5-6
ii python-neovim 0.1.9-1
ii python3-neovim 0.1.9-1
ii python3-neovim-gui 0.1.3-1
ii vim 2:8.0.0022-1
ii vim-addon-manager 0.5.5
ii vim-common 2:8.0.0022-1
ii vim-gtk 2:8.0.0022-1
ii vim-gui-common 2:8.0.0022-1
ii vim-latexsuite 20130116.788-1
ii vim-runtime 2:8.0.0022-1
ii vim-syntastic 3.5.0-1
ii vim-tiny 2:8.0.0022-1
ii vim-vimoutliner 0.3.4+pristine-9.2
ensuite, serait il possible de faire un essai avec un autre vimrc ?
comme celui-ci :
wget http://formation-debian.via.ecp.fr/fichiers-config/vimrc
ce qui est modifié chez moi :
colorscheme koehler
set statusline=%<%f%h%m%r%=%{&ff} %l,%c%V %P " " Contenu de la barre
de status "
set list
set listchars=tab:>-,trail:-
set hlsearch
--
bernard schoenacker
Gaëtan PERRIER
Le #26412776
Le Thu, 13 Oct 2016 01:46:41 +0200
bernard schoenacker
On Thu, 13 Oct 2016 00:04:43 +0200
Gaëtan PERRIER
Bonjour,
Depuis le passage à Vim 8 j'ai une série d'erreurs au lancement:
Erreur détectée en traitant /usr/share/vim/vim80/mswin.vim :
ligne 47 :
E121: Variable non définie : paste#paste_cmd
E15: Expression invalide : 'inoremap <script> <C-V> <C-G>u' .
paste#paste_cmd ['i'] ligne 48 :
E121: Variable non définie : paste#paste_cmd
E15: Expression invalide : 'vnoremap <script> <C-V> ' .
paste#paste_cmd['v']
Erreur détectée en traitant /usr/share/vim/vim80/menu.vim :
ligne 156 :
E121: Variable non définie : paste#paste_cmd
E15: Expression invalide : 'vnoremenu <script>
&Edit.&Paste<Tab>"+gP^I' .
paste#paste_cmd['v']
Avez-vous la même chose ?
Gaëtan

bonjour,
serait il possible de comparer :
dpkg -l |awk '/vim/ {print $1" "$2" "$3}'


ii vim 2:8.0.0022-1
ii vim-addon-manager 0.5.5
ii vim-common 2:8.0.0022-1
ii vim-conque 2.3-1
ii vim-fugitive 2.2-2
ii vim-gnome 2:8.0.0022-1
ii vim-gocomplete 20150303-3
ii vim-gtk3 2:8.0.0022-1
ii vim-gui-common 2:8.0.0022-1
ii vim-runtime 2:8.0.0022-1
ii vim-scripts 20130814
ii vim-syntax-gtk 20110314-1
ii vim-tabular 1.0-3
ii vim-tiny 2:8.0.0022-1
ii vim-youcompleteme 0+20160327+git1b76af4-2
ii neovim 0.1.5-6
ii neovim-runtime 0.1.5-6
ii python-neovim 0.1.9-1
ii python3-neovim 0.1.9-1
ii python3-neovim-gui 0.1.3-1
ii vim 2:8.0.0022-1
ii vim-addon-manager 0.5.5
ii vim-common 2:8.0.0022-1
ii vim-gtk 2:8.0.0022-1
ii vim-gui-common 2:8.0.0022-1
ii vim-latexsuite 20130116.788-1
ii vim-runtime 2:8.0.0022-1
ii vim-syntastic 3.5.0-1
ii vim-tiny 2:8.0.0022-1
ii vim-vimoutliner 0.3.4+pristine-9.2
ensuite, serait il possible de faire un essai avec un autre vimrc ?
comme celui-ci :
wget http://formation-debian.via.ecp.fr/fichiers-config/vimrc
ce qui est modifié chez moi :
colorscheme koehler
set statusline=%<%f%h%m%r%=%{&ff} %l,%c%V %P " " Contenu de la barre
de status "
set list
set listchars=tab:>-,trail:-
set hlsearch

utiliser un vimrc n'utilisant pas les plugins incriminés fait certes
disparaître les erreurs mais ne résout pas le problème pour autant ...
Gaëtan
Gaëtan PERRIER
Le #26412775
Le problème venait du fait que le runtimepath ne contenait
pas /usr/share/vim/vim80
Gaëtan
bernard schoenacker
Le #26412782
On Thu, 13 Oct 2016 23:20:29 +0200
Gaëtan PERRIER
Le problème venait du fait que le runtimepath ne contenait
pas /usr/share/vim/vim80
Gaëtan

bonjour,
depuis vim 7.0 la directive change dans le vimrc :
runtime! debian.vim " "solution system Debian Vim70"
--
bernard schoenacker
Gaëtan PERRIER
Le #26413091
Le Fri, 14 Oct 2016 04:13:00 +0200
bernard schoenacker
On Thu, 13 Oct 2016 23:20:29 +0200
Gaëtan PERRIER
Le problème venait du fait que le runtimepath ne contenait
pas /usr/share/vim/vim80
Gaëtan

bonjour,
depuis vim 7.0 la directive change dans le vimrc :
runtime! debian.vim " "solution system Debian Vim70"


Pas compris ce que tu veux dire ? runtime utilise runtimepath (selon le
help) ?
Gaëtan
bernard schoenacker
Le #26413090
On Mon, 17 Oct 2016 00:12:51 +0200
Gaëtan PERRIER
Le Fri, 14 Oct 2016 04:13:00 +0200
bernard schoenacker
On Thu, 13 Oct 2016 23:20:29 +0200
Gaëtan PERRIER > Le problème venait du fait que le runtimepath ne contenait
> pas /usr/share/vim/vim80
>
>
> Gaëtan
bonjour,
depuis vim 7.0 la directive change dans le vimrc :
runtime! debian.vim " "solution system Debian Vim70"

Pas compris ce que tu veux dire ? runtime utilise runtimepath (selon
le help) ?
Gaëtan


bonjour,
toutafé thierry ... ;)
--
bernard schoenacker
Publicité
Poster une réponse
Anonyme