[testing] wine et son

Le
Gaëtan PERRIER
Bonjour,

Je n'arrive pas à avoir de son dans Wine. J'ai tenté plusieurs config dans
winecfg (alsa puis oss), j'ai chargé snd_seq mais sans aucun résultat.
Est-ce que quelqu'un arrive à avoir du son sous Wine?

Merci.

Gaëtan


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Guy Roussin
Le #9597831
> Est-ce que quelqu'un arrive à avoir du son sous Wine?


Oui. Moi.

Le son n'est pas le point fort de wine, mais il s'améliore au fil de s
versions j'ai donc bien du son avec wine et la plupart des applications q ue
j'ai pu tester ... donc prendre une version récente de wine !

NB: Je suis en etch (x86) et j'utilise la méthode proposée sur le site winehq.org
pour installer wine 0.9.44 sur debian etch:

# wget -q http://wine.budgetdedicated.com/apt/387EE263.gpg -O- | sudo apt -key add -
# wget http://wine.budgetdedicated.com/apt/sources.list.d/etch.list -O
/etc/apt/sources.list.d/winehq.list
# aptitude update
# aptitude remove libwine
# aptitude install wine

le 'aptitude remove libwine' est nécessaire suite à un problà ¨me de dépendance ...

Guy
Gaëtan PERRIER
Le #9597121
Le Mon, 03 Sep 2007 12:16:22 +0200
Guy Roussin
> Est-ce que quelqu'un arrive à avoir du son sous Wine?
Oui. Moi.

Le son n'est pas le point fort de wine, mais il s'améliore au fil des
versions j'ai donc bien du son avec wine et la plupart des applications que
j'ai pu tester ... donc prendre une version récente de wine !

NB: Je suis en etch (x86) et j'utilise la méthode proposée sur le site
winehq.org pour installer wine 0.9.44 sur debian etch:

# wget -q http://wine.budgetdedicated.com/apt/387EE263.gpg -O- | sudo
# apt-key add - wget
# http://wine.budgetdedicated.com/apt/sources.list.d/etch.list -O
/etc/apt/sources.list.d/winehq.list
# aptitude update
# aptitude remove libwine
# aptitude install wine

le 'aptitude remove libwine' est nécessaire suite à un problème de
dépendance ...

Guy



Oui c'est aussi la version de winehq que j'utilise, mais rien à faire...

Gaëtan


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Nicolas Folin
Le #9597111
Guy Roussin a écrit :
Est-ce que quelqu'un arrive à avoir du son sous Wine?



Oui. Moi.

Le son n'est pas le point fort de wine, mais il s'améliore au fil des
versions j'ai donc bien du son avec wine et la plupart des applications que
j'ai pu tester ... donc prendre une version récente de wine !

NB: Je suis en etch (x86) et j'utilise la méthode proposée sur le site winehq.org
pour installer wine 0.9.44 sur debian etch:

# wget -q http://wine.budgetdedicated.com/apt/387EE263.gpg -O- | sudo apt-key add -
# wget http://wine.budgetdedicated.com/apt/sources.list.d/etch.list -O
/etc/apt/sources.list.d/winehq.list
# aptitude update
# aptitude remove libwine
# aptitude install wine

le 'aptitude remove libwine' est nécessaire suite à un problème de dépendance ...

Guy





juste pour passer de ma version 0.9.25 à la 0.9.44, j'ai essayé ça...
Et là, je pose une question: j'ai l'habitude d'utiliser apt-get.
Lorsque j'ai fait ces même lignes en indiquant apt-get à la place
d'aptitude,
j'ai eu:
<<
Souhaitez-vous continuer [O/n] ? o
(Lecture de la base de données... 129165 fichiers et répertoires déjà
installés.)
Préparation du remplacement de wine 0.9.25-2.1 (en utilisant
.../wine_0.9.44~winehq0~debian~4.0-1_i386.deb) ...
Dépaquetage de la mise à jour de wine ...
dpkg : erreur de traitement de
/var/cache/apt/archives/wine_0.9.44~winehq0~debian~4.0-1_i386.deb
(--unpack) :
tentative de remplacement de « /usr/lib/wine/mapi32.dll.so », qui
appartient aussi au paquet libwine
dpkg-deb: sous-processus paste tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/wine_0.9.44~winehq0~debian~4.0-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)






Et en refaisant la même chose avec aptitude, tout est très bien passé.

Il y a une explication "rationnelle" à ce comportement ? Je ne dois plus
utiliser
apt-get ou aptitude est plus "souple" dans ses résolutions ?

En tout cas, merci pour l'astuce, j'ai mon WINE à jour maintenant, et je
vais
pouvoir relancer mes jeux (ben oui, pour quoi vous utilisez WINE vous ?)


Amicalement
Nicolas Folin


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Guy Roussin
Le #9597051
Nicolas Folin a écrit :
Guy Roussin a écrit :
Est-ce que quelqu'un arrive à avoir du son sous Wine?



Oui. Moi.

Le son n'est pas le point fort de wine, mais il s'améliore au fil des
versions j'ai donc bien du son avec wine et la plupart des application s que
j'ai pu tester ... donc prendre une version récente de wine !

NB: Je suis en etch (x86) et j'utilise la méthode proposée s ur le site winehq.org
pour installer wine 0.9.44 sur debian etch:

# wget -q http://wine.budgetdedicated.com/apt/387EE263.gpg -O- | sudo apt-key add -
# wget http://wine.budgetdedicated.com/apt/sources.list.d/etch.list -O
/etc/apt/sources.list.d/winehq.list
# aptitude update
# aptitude remove libwine
# aptitude install wine

le 'aptitude remove libwine' est nécessaire suite à un probl ème de dépendance ...

Guy





juste pour passer de ma version 0.9.25 à la 0.9.44, j'ai essayé ça...
Et là, je pose une question: j'ai l'habitude d'utiliser apt-get.
Lorsque j'ai fait ces même lignes en indiquant apt-get à la p lace
d'aptitude,
j'ai eu:
<<
Souhaitez-vous continuer [O/n] ? o
(Lecture de la base de données... 129165 fichiers et répertoi res déjà
installés.)
Préparation du remplacement de wine 0.9.25-2.1 (en utilisant
.../wine_0.9.44~winehq0~debian~4.0-1_i386.deb) ...
Dépaquetage de la mise à jour de wine ...
dpkg : erreur de traitement de
/var/cache/apt/archives/wine_0.9.44~winehq0~debian~4.0-1_i386.deb
(--unpack) :
tentative de remplacement de « /usr/lib/wine/mapi32.dll.so » , qui
appartient aussi au paquet libwine
dpkg-deb: sous-processus paste tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/wine_0.9.44~winehq0~debian~4.0-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Et en refaisant la même chose avec aptitude, tout est très bi en passé.

Il y a une explication "rationnelle" à ce comportement ? Je ne doi s plus
utiliser
apt-get ou aptitude est plus "souple" dans ses résolutions ?



Cette erreur est la raison du "aptitude remove libwine" que je suggerais ...
Visiblement, l'empaqueteur a oublié libwine dans la liste des paquet s
remplacés (cf aptitude show wine).
Aussi, je ne pense pas que apt-get ou aptitude change quelquechose à ce niveau.


Guy
Publicité
Poster une réponse
Anonyme