texlive lenny (bug ?) qqch pourrait être arrangé

Le
bonjour,

j'ai rencontré un petit souci ave l'installation
de texlive-latex-recommended, avec aptitude sous lenny.

(au départ, j'ai déjà les paquets suivants :
"texlive-{
base,
base-bin,
common,
doc-base,
doc-fr,
fonts-recommended,
latex-base,
tipa}")



$ sudo apt-get -s install texlive-latex-recommended prosper
texlive-pstricks

Les NOUVEAUX paquets suivants seront installés :
prosper tetex-bin tetex-extra texlive texlive-bibtex-extra
texlive-font-utils texlive-fonts-extra texlive-lang-croatian
texlive-lang-cyrillic texlive-lang-czechslovak texlive-lang-danish
texlive-lang-dutch texlive-lang-finnish texlive-lang-french
texlive-lang-german texlive-lang-greek texlive-lang-hungarian
texlive-lang-italian texlive-lang-latin texlive-lang-mongolian
texlive-lang-norwegian texlive-lang-other texlive-lang-polish
texlive-lang-portuguese texlive-lang-spanish texlive-lang-swedish
texlive-lang-vietnamese texlive-latex-extra texlive-latex-recommended
texlive-math-extra texlive-pictures texlive-pstricks
texlive-publishers

$ sudo apt-get install texlive-latex-recommended (réelle)

Les NOUVEAUX paquets suivants seront installés :
texlive-latex-recommended

$ sudo apt-get install texlive-pstricks (réelle)

Les NOUVEAUX paquets suivants seront installés :
texlive-pstricks

$ sudo apt-get -s install prosper (réelle ou simulée)

Les NOUVEAUX paquets suivants seront installés :
prosper

==

Dans prosper les dépendances sont données avec
"tetex-*" en premier
et
"texlive-*" en second.

Mais la politique annoncée est de suivre "texlive"
parce que tetex n'est plus maintenu (ou autre ?).

=

En tout cas, si vous voulez installer (avec aptitude),
"texlive-latex-recommended" (ce qui a priori n'est pas
une "grosse chose"), et que votre aptitude est configuré
pour suivre les "recommandés" (ce qui est un choix
non-déraisonnable, envisageable ?),
vous vous retrouvez avec tous les paquets listés
en haut.



il y a peut être quelque chose à faire.

Il y a peut être ici lieu à un rapport de bug
(ce n'est pas très grave, mais peut être génant,
et est peut être facile à modifier -- l'ordre des
dépendances alternatives ?).

Deux choses :

Soit je me plante peut être complètement (il y a quelque
chose que j'ai omis de considérer ; j'ai fait
des fautes de frappe en tapant mes commandes ?).

J'ai fait des installs avec aptitude et d'autres
(ici pour cette démonstraction), avec apt-get
(qui ne renseigne pas la base de aptitude).
et comme il y a des dépendances circulaires
c'est difficile d'être sûr.

Sinon, je voudrais avoir votre avis concernant un
éventuel mail au responsable du paquet.

(on peut remplacer ainsi les dépendance/recommandation
à une dizaine de paquets au lieu d'une trentaine).

Bon dimanche

FA.




_____________________________________________________________________________
Ne gardez plus qu'une seule adresse mail ! Copiez vos mails vers Yahoo! Mail


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Le #9580381
Vérification faite, ce que j'ai dit a déjà fait l'objet d'un rapport de
bug

http://bugs.debian.org/cgi-bin/bugreport.cgi?bugB3013

Ainsi que je l'ai expliqué (dessous, donc), je pense
qu'il sufirait, lors des dépendances alternatives
tetex | texlive, d'inverser l'ordre :
texlive | tetex au lieu de tetex | texlive.

C'est aussi ce que préconise l'intervenant dans
son troisième ou quatrième message :
dans un premier temps suppression de la dépendance tetex,
puis proposition d'inversion de l'ordre des alternatives.

J'ai pas cru comprendre qu'il ait été compris.
Or il parle beaucoup mieux l'anglais que moi.
(J'ai déjà du mal avec le français).

Le mainteneur préconise de résoudre les dépendances soi-même
en partant du bas de l'arbre des dépendances.
Ce que j'ai fait. Mais il faut aussi penser
à ceux qui n'y penserait pas(*) et qui du coup
préfererait se passer de certain paquet
plutôt que de voir leur machine injustifiablement
alourdie. Car TeX/LaTeX est lourd, en poids,
mais surtout en temps d'installation : il se reconfigure
tout le temps, et une simple mise à jour de routine
peut voir sa durée très augmentée.
(*) : moi par exemple. Lorsque l'on fait apt-get,
on s'attend à ce qu'il fasse le mieux. On peut oublier
qu'il n'est qu'une machine. Et on ne pense pas forcément
à ces dépendances alternatives (la doc d'apt-get
dit qu'il choisi au hasard ; peut être ne peut on pas
fixer d'ordre de priorité lors d'une alternative).

FA




--- a écrit :

bonjour,

j'ai rencontré un petit souci ave l'installation
de texlive-latex-recommended, avec aptitude sous lenny.

(au départ, j'ai déjà les paquets suivants :
"texlive-{
base,
base-bin,
common,
doc-base,
doc-fr,
fonts-recommended,
latex-base,
tipa}")

=========== >
$ sudo apt-get -s install texlive-latex-recommended prosper
texlive-pstricks

Les NOUVEAUX paquets suivants seront installés :
prosper tetex-bin tetex-extra texlive texlive-bibtex-extra
texlive-font-utils texlive-fonts-extra texlive-lang-croatian
texlive-lang-cyrillic texlive-lang-czechslovak texlive-lang-danish
texlive-lang-dutch texlive-lang-finnish texlive-lang-french
texlive-lang-german texlive-lang-greek texlive-lang-hungarian
texlive-lang-italian texlive-lang-latin texlive-lang-mongolian
texlive-lang-norwegian texlive-lang-other texlive-lang-polish
texlive-lang-portuguese texlive-lang-spanish texlive-lang-swedish
texlive-lang-vietnamese texlive-latex-extra
texlive-latex-recommended
texlive-math-extra texlive-pictures texlive-pstricks
texlive-publishers

$ sudo apt-get install texlive-latex-recommended (réelle)

Les NOUVEAUX paquets suivants seront installés :
texlive-latex-recommended

$ sudo apt-get install texlive-pstricks (réelle)

Les NOUVEAUX paquets suivants seront installés :
texlive-pstricks

$ sudo apt-get -s install prosper (réelle ou simulée)

Les NOUVEAUX paquets suivants seront installés :
prosper

==== >
Dans prosper les dépendances sont données avec
"tetex-*" en premier
et
"texlive-*" en second.

Mais la politique annoncée est de suivre "texlive"
parce que tetex n'est plus maintenu (ou autre ?).

=== >
En tout cas, si vous voulez installer (avec aptitude),
"texlive-latex-recommended" (ce qui a priori n'est pas
une "grosse chose"), et que votre aptitude est configuré
pour suivre les "recommandés" (ce qui est un choix
non-déraisonnable, envisageable ?),
vous vous retrouvez avec tous les paquets listés
en haut.

== >
il y a peut être quelque chose à faire.

Il y a peut être ici lieu à un rapport de bug
(ce n'est pas très grave, mais peut être génant,
et est peut être facile à modifier -- l'ordre des
dépendances alternatives ?).

Deux choses :

Soit je me plante peut être complètement (il y a quelque
chose que j'ai omis de considérer ; j'ai fait
des fautes de frappe en tapant mes commandes ...?).

J'ai fait des installs avec aptitude et d'autres
(ici pour cette démonstraction), avec apt-get
(qui ne renseigne pas la base de aptitude).
et comme il y a des dépendances circulaires
c'est difficile d'être sûr.

Sinon, je voudrais avoir votre avis concernant un
éventuel mail au responsable du paquet.

(on peut remplacer ainsi les dépendance/recommandation
à une dizaine de paquets au lieu d'une trentaine).

Bon dimanche

FA.








_____________________________________________________________________________

Ne gardez plus qu'une seule adresse mail ! Copiez vos mails vers
Yahoo! Mail


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact








_____________________________________________________________________________
Ne gardez plus qu'une seule adresse mail ! Copiez vos mails vers Yahoo! Mail


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme