Texte dans 1 cellule avec les fonctions SI

Le
Forum
bonsoir à tous
je sais que c'est possible mais je n'arrive pas à trouver la formule.

mon tableau :

cellule C : une valeur à entrer manuellement
cellule D : également
cellule E : = C X D (pas de problème :-))
cellule F : une valeur à entrer manuellement
cellule G : également

cellule H : = E X F X G (toujours pas de problème :-))

Ce que je souhaite :
Dans la cellule I :
Si le produit de la cellule H est compris entre 200 et 150 / alors inscrire
"xxxxxxxxx n°1"
Si le produit de la cellule H est compris entre 149 et 100 / alors inscrire
"xxxxxxxxx n°2"
Si le produit de la cellule H est compris entre 99 et 50 / alors inscrire
"xxxxxxxxx n°3"
Si le produit de la cellule H est compris entre 49 et 0 / alors inscrire
"xxxxxxxxx n°4"

et ca serai même le top si en plus je pouvais avoir de la couleur
différentes dans la cellule "I" différentes dès lors qu'il y aura la phrase
n° - 2 - 3 - ou 4
ex : rouge pour la phrase 1
bleu pour la phrase 2
vert pour la phrase 3
jaune pour la phrase 4

Merci à tous pour votre aide
Pascal
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #23904911
bonjour Pascal,

=INDEX({"no4";"no3";"no2";"no1"};EQUIV(H1;{0;50;100;150}))

pour la couleur utilise une mise en forme conditionnel.


--
isabelle



Le 2011-10-25 17:21, Forum a écrit :
bonsoir à tous
je sais que c'est possible mais je n'arrive pas à trouver la formule.

mon tableau :

cellule C : une valeur à entrer manuellement
cellule D : également
cellule E : = C X D (pas de problème :-))
cellule F : une valeur à entrer manuellement
cellule G : également

cellule H : = E X F X G (toujours pas de problème :-))

Ce que je souhaite :
Dans la cellule I :
Si le produit de la cellule H est compris entre 200 et 150 / alors inscrire "xxxxxxxxx n°1"
Si le produit de la cellule H est compris entre 149 et 100 / alors inscrire "xxxxxxxxx n°2"
Si le produit de la cellule H est compris entre 99 et 50 / alors inscrire "xxxxxxxxx n°3"
Si le produit de la cellule H est compris entre 49 et 0 / alors inscrire "xxxxxxxxx n°4"

et ca serai même le top si en plus je pouvais avoir de la couleur différentes dans la cellule "I"



différentes dès lors qu'il y aura la phrase n° - 2 - 3 - ou 4
ex : rouge pour la phrase 1
bleu pour la phrase 2
vert pour la phrase 3
jaune pour la phrase 4

Merci à tous pour votre aide
Pascal
isabelle
Le #23904931
une petite modification,

=SI(H1>200;"";INDEX({"no4";"no3";"no2";"no1"};EQUIV(H1;{0;50;100;150})))


--
isabelle



Le 2011-10-25 20:46, isabelle a écrit :
bonjour Pascal,

=INDEX({"no4";"no3";"no2";"no1"};EQUIV(H1;{0;50;100;150}))

pour la couleur utilise une mise en forme conditionnel.


isabelle
Le #23904921
ou bien...

=INDEX({"no4";"no3";"no2";"no1";""};EQUIV(H1;{0;50;100;150;201}))


--
isabelle

Le 2011-10-25 20:49, isabelle a écrit :
une petite modification,

=SI(H1>200;"";INDEX({"no4";"no3";"no2";"no1"};EQUIV(H1;{0;50;100;150})))


Forum
Le #23905891
Merci Isabelle, ca marche, c'est cool
je m'attaque aux mises en forme conditionnelles !!!!!!!!!!!!
bonne journée
Pascal

"isabelle" a écrit dans le message de groupe de discussion :
j87lle$hm4$

ou bien...

=INDEX({"no4";"no3";"no2";"no1";""};EQUIV(H1;{0;50;100;150;201}))


--
isabelle

Le 2011-10-25 20:49, isabelle a écrit :
une petite modification,

=SI(H1>200;"";INDEX({"no4";"no3";"no2";"no1"};EQUIV(H1;{0;50;100;150})))


Publicité
Poster une réponse
Anonyme