Texte en noir dans une cellule

Le
Polio2004
Comment puis je détecter dans une cellule du texte en noir ? Dans ma colonne
j'ai 4 couleurs de texte, seul le noir doit subir un traitement.
Merci de votre aide
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #4699151
Bonjour,


Dans un module:

Function couleur(c As Range)
couleur = c.Font.ColorIndex
End Function

Dans le tableur:

=SI(couleur(C2)=3;"rouge";"")


JB
http://boisgontierjacques.free.fr

On 13 sep, 16:57, "Polio2004"
Comment puis je détecter dans une cellule du texte en noir ? Dans ma co lonne
j'ai 4 couleurs de texte, seul le noir doit subir un traitement.
Merci de votre aide


Polio2004
Le #4698921
Merci. C'est presque bon. Il me trouve les cellules vides en couleur noir.
Il faudrait peut être y rajouter un test ?

"JB"
Bonjour,


Dans un module:

Function couleur(c As Range)
couleur = c.Font.ColorIndex
End Function

Dans le tableur:

=SI(couleur(C2)=3;"rouge";"")


JB
http://boisgontierjacques.free.fr

On 13 sep, 16:57, "Polio2004"
Comment puis je détecter dans une cellule du texte en noir ? Dans ma
colonne
j'ai 4 couleurs de texte, seul le noir doit subir un traitement.
Merci de votre aide


Publicité
Poster une réponse
Anonyme