thunderbird-24 et l'affichage des BALs

Le
Alex Ternaute
[supersedes]
Bonjour,

Hier, Thunderbird a été mis à jour de la version 23 (pas sûr, en fait) à
la version 24 sur mon poste. Aussitôt, la déconvenue : d'une part les
icônes permettant de distinguer la poubelle, les indésirables etc. ont
disparu mais, surtout, le signalement des boîtes contenant des nouveaux
messages (point jaune, nom de la boîte en gras) n'existe plus.

Comme j'ai peut-être hérité d'un problème rencontré lors de la mise à
jour, j'essaie de télécharger une version installable de TB-24 pour
Linux. En 64bits ; je passe sur le fait que, sans Google, je me demande
comment trouver les pages de téléchargement des versions 64bits sur le
site de Mozilla.
Parce qu'à partir de leur page d'accueil, je n'ai rien vu

Bref ; ça ne fonctionne pas mieux. Course en avant : la 24.0b3
corrigerait-elle le problème ? non. J'ai donc cherché à revenir quelques
versions en arrière : la version 23 n'a rien réglé (d'où mon incertitude
au sujet de la version précédente) ; la 17 l'a empiré : plus de boîte
visible du tout !

La 21.0b1 fonctionne. Aussitôt, TB-21.0b1 me propose de charger la
dernière version en 32 bits alors que mon OS et --surtout-- TB sont en
64 bits !
J'ai bloqué les mises-à-jour et pour un moment, je pense.

Quelqu'un a-t-il eu ce problème ?
--
Alex
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Delta Ophiuchus
Le #25672252
*Bonjour/Bonsoir/Bonne nuit Alex Ternaute*, qui a écrit le 19/09/2013
13:33 :

Quelqu'un a-t-il eu ce problème ?



Je ne l'ai pas eu. Pour information je suis passé de la version 17.0.8 à
la version 24.0 en mise à jour par le site de mise à jour de ?À propos
de Thunderbird.
Pour ton problème, tu utilises quel thème dans OutilsModules
complémentairesApparence ? Je viens d'essayer le thème par défaut et il
affiche bien toutes les icônes.

J'ai de nombreux thèmes qui sont toujours compatibles, un seul ne l'est
plus avec la version 24.
Tu peux essayer d'autres thèmes qui fonctionnent avec la version 24 pour
voir si ce met fin à ton problème:
https://addons.mozilla.org/fr/thunderbird/themes/

--
http://www.synec-doc.be/doc/accents2.htm

Le premier anti-virus/anti-spyware/anti-malware, ce n'est pas un
programme, c'est toi :
http://www.certa.ssi.gouv.fr/
Delta Ophiuchus
Le #25672992
*Bonjour/Bonsoir/Bonne nuit Delta Ophiuchus*, qui a écrit le 19/09/2013
13:57 :

*Bonjour/Bonsoir/Bonne nuit Alex Ternaute*, qui a écrit le 19/09/2013
13:33 :

> Quelqu'un a-t-il eu ce problème ?


Je ne l'ai pas eu.



Mais j'en ai eu un autre :
https://addons.mozilla.org/fr/thunderbird/addon/mnenhy/ ne fonctionne
plus, je suis donc revenu à mon ancienne version 17.0.8. Et j'ai du
réinstaller Lightning 1.9 car la dernière version ne fonctionne pas avec
Thunderbird 24.

--
http://www.synec-doc.be/doc/accents2.htm

Le premier anti-virus/anti-spyware/anti-malware, ce n'est pas un
programme, c'est toi :
http://www.certa.ssi.gouv.fr/
Alex Ternaute
Le #25673052
Bonsoir,

Delta Ophiuchus :


Quelqu'un a-t-il eu ce problème ?


Je ne l'ai pas eu.


Merci de t'intéresser à mes tribulations.

Pour information je suis passé de la version 17.0.8 à
la version 24.0 en mise à jour par le site de mise à jour de ?À propos
de Thunderbird.



C'est comme ça que le problème est survenu chez moi, à ceci près que je
n'avais pas noté la version précédente.

Pour ton problème, tu utilises quel thème dans OutilsModules
complémentairesApparence ? Je viens d'essayer le thème par défaut et il
affiche bien toutes les icônes.



J'utilise bien le thème par défaut et je n'en avais pas installé d'autre
sur cette machine. D'ailleurs plus ça va et moins je personnalise
l'aspect des applications : c'est pas que ça ne compte pas mais
justement, c'est l'aspect par défaut qui me lasse le moins à la longue,
en général.

Tu peux essayer d'autres thèmes qui fonctionnent avec la version 24 pour
voir si ce met fin à ton problème:
https://addons.mozilla.org/fr/thunderbird/themes/



Ah. Je viens de comprendre que TB a toujours un thème/habillage même quand
on n'en choisit pas, que ce dernier peut donc défaillir et du coup,
l'application se retrouve plus ou moins à poil.

Je viens d'essayer un nouveau thème. Dans TB-21, les noms des dossiers
contenant de nouveaux messages sont maintenant écrits en rouge mais dans
TB-24 ils gardent le même aspect que les autres. Le thème ne semble donc
pas être en cause mais plutôt le "mécanisme" qui manipule les différents
éléments du thème en fonction du contexte (Xul, js, que sais-je ?) qui a
l'air en panne.

Question plus générale qui concerne les thèmes : j'ai téléchargé un thème
dans une archive --par exemple flashy.tld.xpi-- que j'ai dézippée pour
voir ; il s'y trouve un fichier au nom pas vraiment étonnant de flashy.js.
Seulement je ne vois pas ce fichier .js dans l'arborescence de mon compte
thunderbird, ni même le dossier .mozilla (on aurait pu imaginer une forme
de collaboration avec firefox), y compris lorsque ce thème est activé. Je
ne parle pas du dossier d'installation sous /usr où je n'ai pas les
droits d'écriture.

Autre question, si tu sais : l'habillage par défaut est stocké comme un
ajout, dans un fichier *.xpi ou bien il est intégré ? C'est juste par
curiosité parce que les 2 solutions ont leur vulnérabilité potentielle en
cas de changement de version mal géré : l'une par manque de souplesse et
l'autre par excès.

à +
--
Alex
Delta Ophiuchus
Le #25673102
*Bonjour/Bonsoir/Bonne nuit Alex Ternaute*, qui a écrit le 19/09/2013
19:02 :


Question plus générale qui concerne les thèmes : j'ai téléchargé un thème
dans une archive --par exemple flashy.tld.xpi-- que j'ai dézippée pour
voir ; il s'y trouve un fichier au nom pas vraiment étonnant de flashy.js.
Seulement je ne vois pas ce fichier .js dans l'arborescence de mon compte
thunderbird, ni même le dossier .mozilla (on aurait pu imaginer une forme
de collaboration avec firefox), y compris lorsque ce thème est activé. Je
ne parle pas du dossier d'installation sous /usr où je n'ai pas les
droits d'écriture.



Je n'ai pas de .js pour les thèmes, tout est stocké dans les xpi. J'ai
quelques js en lien avec les extensions mais ce sont des fichiers de
paramètres.



Autre question, si tu sais : l'habillage par défaut est stocké comme un
ajout, dans un fichier *.xpi ou bien il est intégré ? C'est juste par
curiosité parce que les 2 solutions ont leur vulnérabilité potentielle en
cas de changement de version mal géré : l'une par manque de souplesse et
l'autre par excès.



Les thèmes que j'utilise sont stockés sous leur forme xpi dans mon profil :
C:UsersUser-NameAppDataRoamingThunderbirdProfilestbnd7obr.defaultextensions
Je n'en trouve nulle mention autre part, ni sous aucune autre forme.

--
http://www.synec-doc.be/doc/accents2.htm

Le premier anti-virus/anti-spyware/anti-malware, ce n'est pas un
programme, c'est toi :
http://www.certa.ssi.gouv.fr/
Alex Ternaute
Le #25673862
Bonjour,

Delta Ophiuchus :

J'ai quelques js en lien avec les extensions mais ce sont des fichiers
de paramètres.



Ah ? chez moi tous les js contiennent exclusivement du javascript...

Les thèmes que j'utilise sont stockés sous leur forme xpi dans mon
profil : []
Je n'en trouve nulle mention autre part, ni sous aucune autre forme.



Pas mieux.


PS : excellent, les accents...
--
Alex
Delta Ophiuchus
Le #25674092
*Bonjour/Bonsoir/Bonne nuit Alex Ternaute*, qui a écrit le 20/09/2013
10:42 :

Bonjour,

Delta Ophiuchus :

J'ai quelques js en lien avec les extensions mais ce sont des fichiers
de paramètres.



Ah ? chez moi tous les js contiennent exclusivement du javascript...



Chez moi également :-) Les fichiers js en dehors de l'archive xpi en
rapport avec mes thèmes sont leurs réglages.


Les thèmes que j'utilise sont stockés sous leur forme xpi dans mon
profil : []
Je n'en trouve nulle mention autre part, ni sous aucune autre forme.



Pas mieux.


PS : excellent, les accents...



À que oui !


--
http://www.synec-doc.be/doc/accents2.htm

Le premier anti-virus/anti-spyware/anti-malware, ce n'est pas un
programme, c'est toi :
http://www.certa.ssi.gouv.fr/
Alex Ternaute
Le #25678242
Bonjour,

Je disais la semaine dernière:

Hier [dans] Thunderbird [...] les icônes permettant de distinguer la
poubelle, les indésirables etc. ont disparu mais, surtout, le
signalement des boîtes contenant des nouveaux messages (point jaune,
nom de la boîte en gras) n'existe plus.



Comme j'ai écrit ça le lendemain, c'est que le pb avait survécu à un
reboot...
Ce matin, TB insistait pour que je fasse une MAJ de la 21.0b1 vers la
24-0b3. J'ai réinstallé la release 24 pour voir si TB proposerait une MAJ.

D'une part il ne propose pas de MAJ mais... le pb a disparu ! L'archive
tbz que j'ai réinstallée est datée du 19, c-à-d que c'est la même que
celle qui posait problème jeudi...

Mon système doit avoir un peu de plomb dans l'aile.
--
Alex
yamo'
Le #25682682
Salut,

Delta Ophiuchus a tapoté, le 19/09/2013 19:00:
Mais j'en ai eu un autre :
https://addons.mozilla.org/fr/thunderbird/addon/mnenhy/ ne fonctionne



Pour Mnenhy, c'est étonnant ; j'ai l'équivalent de Thunderbird 24 avec
Seamonkey 2.21. Tu devrais essayer en installant le plugin qui permet de
forcer un module à être compatible et envoyer des rapports de bug :

qui fonctionne sur Seamonkey mais le site stupide de mozilla me renvoie
à chaque fois sur firefox. Ça a des chances de fonctionner sur le
Thunderbird.

plus, je suis donc revenu à mon ancienne version 17.0.8. Et j'ai du
réinstaller Lightning 1.9 car la dernière version ne fonctionne pas avec
Thunderbird 24.




Pour Lightning, il faut se référer à


--
Stéphane BOFH excuse #134:

because of network lag due to too many people playing deathmatch
Delta Ophiuchus
Le #25683392
*Bonjour/Bonsoir/Bonne nuit yamo'*, qui a écrit le 24/09/2013 21:20 :

Salut,

Delta Ophiuchus a tapoté, le 19/09/2013 19:00:
Mais j'en ai eu un autre :
https://addons.mozilla.org/fr/thunderbird/addon/mnenhy/ ne fonctionne



Pour Mnenhy, c'est étonnant ; j'ai l'équivalent de Thunderbird 24 avec
Seamonkey 2.21. Tu devrais essayer en installant le plugin qui permet de
forcer un module à être compatible et envoyer des rapports de bug :



Il doit y avoir des différences entre Seamonkey et Thunderbird car
Mnenhy est réellement incompatible, de nombreuses choses ne fonctionnent
plus. Je ne parle pas d'une alerte d'installation puisque dans ces cas
là je modifie le install.rdf :

<!-- thunderbird -->
<em:id>{3550f703-e582-4d05-9a08-453d09bdfdc6}</em:id>

Il suffit de changer le 17 en 56 par exemple :-) En dessous il y a la
même chose pour seamonkey.





Je ne l'utilise plus, je préfère modifier le fichier xpi.


qui fonctionne sur Seamonkey mais le site stupide de mozilla me renvoie
à chaque fois sur firefox. Ça a des chances de fonctionner sur le
Thunderbird.

plus, je suis donc revenu à mon ancienne version 17.0.8. Et j'ai du
réinstaller Lightning 1.9 car la dernière version ne fonctionne pas avec
Thunderbird 24.




Pour Lightning, il faut se référer à



Merci pour cette adresse qui est plus claire que celle que j'utilise :
https://addons.mozilla.org/fr/thunderbird/addon/lightning/versions/


--
http://www.synec-doc.be/doc/accents2.htm

Le premier anti-virus/anti-spyware/anti-malware, ce n'est pas un
programme, c'est toi :
http://www.certa.ssi.gouv.fr/
Jean-Marc Desperrier
Le #25687692
Alex Ternaute a écrit :
TB insistait pour que je fasse une MAJ de la 21.0b1 vers la
24-0b3. J'ai réinstallé la release 24 pour voir si TB proposerait une MAJ.

D'une part il ne propose pas de MAJ



De temps en temps, les mises à jour corrigent un problème applicable à
un seul OS, donc si tu n'es pas sur cet OS et que tu as la version
immédiatement précédente, elle ne t'es pas proposée.

Mais ici en fait, tu étais sur le canal béta, et la première béta de TB
25 n'étant pas encore sortie, il n'a pas proposé de mise à jour par
rapport à la 24-0b3.
Publicité
Poster une réponse
Anonyme