thunderbird et caractères

Le
alainL
Bonjour,
Un mail que je veux transférer apparaît avec des modifications de
caractères: @ et ** à la place des apostrophes etc
Si je clique sur "répondre" ces modifs n'interviennent pas, c'est juste
pour "transférer" et seulement pour ce message.
Comment faire pour obtenir un encodage correct de ce transfert ?
Merci

--
AlainL

http://autourdalos.fr
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Olivier Miakinen
Le #22377711
Bonjour,

Le 20/07/2010 11:44, alainL a écrit :

Un mail que je veux transférer apparaît avec des modifications de
caractères: @ et ** à la place des apostrophes etc...



Quel encodage (iso-8859-1, UTF-8, cp1252, rien d'explicite) ?

Quel format (texte ? HTML ? s'il y a les deux, lequel affiches-tu) ?

Si je clique sur "répondre" ces modifs n'interviennent pas, c'est juste
pour "transférer" et seulement pour ce message.
Comment faire pour obtenir un encodage correct de ce transfert ?



Je te propose la chose suivante pour ne pas avoir des manips trop
compliquées à faire.
1) Tu crées dans ton compte Thunderbird un nouveau dossier que tu nommes
Miakinen.txt (peu importe qu'il soit sous « Courrier entrant » ou
ailleurs).
2) Tu copies le message dans ce dossier (clic droit + Copier vers...).
3) Tu cherches sur ton disque dur le fichier Miakinen.txt (si tu sais
où est ton profil Thunderbird cela peut accélérer les choses, mais
ce n'est pas indispensable).
4) Tu le mets sur 5) Tu m'envoies l'URL cjoint à
Optionnel : entre les étapes 3 et 4 tu peux éditer Miakinen.txt avec un
éditeur de texte si jamais il y avait des choses confidentielles que tu
veuilles supprimer avant de me l'envoyer. Veille à laisser tous les
entêtes, et aussi les apostrophes qui se changent en @. Attention, très
important si tu fais ça, il faut vraiment que ce soit un *éditeur* de
texte du genre de vim ou notepad, pas un traitement de texte qui va tout
cacabouiller (le mieux serait quand même que tu ne touches à rien).
alainL
Le #22378551
Le 20/07/2010 12:28, Olivier Miakinen a écrit :
Bonjour,

Le 20/07/2010 11:44, alainL a écrit :

Un mail que je veux transférer apparaît avec des modifications de
caractères: @ et ** à la place des apostrophes etc...



Quel encodage (iso-8859-1, UTF-8, cp1252, rien d'explicite) ?

Quel format (texte ? HTML ? s'il y a les deux, lequel affiches-tu) ?

Si je clique sur "répondre" ces modifs n'interviennent pas, c'est juste
pour "transférer" et seulement pour ce message.
Comment faire pour obtenir un encodage correct de ce transfert ?



Je te propose la chose suivante pour ne pas avoir des manips trop
compliquées à faire.
1) Tu crées dans ton compte Thunderbird un nouveau dossier que tu nommes
Miakinen.txt (peu importe qu'il soit sous « Courrier entrant » ou
ailleurs).
2) Tu copies le message dans ce dossier (clic droit + Copier vers...).
3) Tu cherches sur ton disque dur le fichier Miakinen.txt (si tu sais
où est ton profil Thunderbird cela peut accélérer les choses, mais
ce n'est pas indispensable).
4) Tu le mets sur 5) Tu m'envoies l'URL cjoint à
Optionnel : entre les étapes 3 et 4 tu peux éditer Miakinen.txt avec un
éditeur de texte si jamais il y avait des choses confidentielles que tu
veuilles supprimer avant de me l'envoyer. Veille à laisser tous les
entêtes, et aussi les apostrophes qui se changent en @. Attention, très
important si tu fais ça, il faut vraiment que ce soit un *éditeur* de
texte du genre de vim ou notepad, pas un traitement de texte qui va tout
cacabouiller (le mieux serait quand même que tu ne touches à rien).



Merci. J'ai obtenu un fichier.text que voici :
http://cjoint.com/?hur1y1XPpz


--
AlainL
Olivier Miakinen
Le #22378851
Le 20/07/2010 18:02, alainL m'a répondu :

Je te propose la chose suivante pour ne pas avoir des manips trop
compliquées à faire.
1) Tu crées dans ton compte Thunderbird un nouveau dossier que tu nommes
Miakinen.txt (peu importe qu'il soit sous « Courrier entrant » ou
ailleurs).
2) Tu copies le message dans ce dossier (clic droit + Copier vers...).
3) Tu cherches sur ton disque dur le fichier Miakinen.txt (si tu sais
où est ton profil Thunderbird cela peut accélérer les choses, mais
ce n'est pas indispensable).
4) Tu le mets sur 5) Tu m'envoies l'URL cjoint à
[...]



Merci. J'ai obtenu un fichier.text que voici :
http://cjoint.com/?hur1y1XPpz



Visiblement c'est le message forwardé que tu as envoyé. Ce serait bien
que tu fasses la même chose avec le message d'origine (effacer puis
recréer Miakinen.txt afin de virer toute trace de la manip précédente).

Déjà, je peux te dire à quoi ressemble ce message. Il s'agit d'un
message en deux parties, texte et html, chacune des parties étant
*presque* bien encodée en UTF-8. Les 'é' sont bien encodés par 'c3 a9',
les 'ç' par 'c3 a7', les '«' par 'c2 ab', les '»' par 'c2 bb', et ainsi
de suite. Les seuls problèmes sont :
1) 'à' = 'c3 20' au lieu de 'c3 a0' ;
2) '’' = 'e2 3f 3f' au lieu de 'e2 80 99'.
Je parierais que les '€' deviendraient 'e2 3f ac' au lieu de 'e2 82 ac'.

C'est clairement un bug, et l'explication qui me semble la plus
naturelle est que ton Thunderbird a traité ce message comme s'il était
en ISO-8859-quelquechose au lieu d'UTF-8. En effet, dans ce mode il
remplace les espaces insécables (a0) par des sécables (20), ce qui
explique le premier problème, et il doit remplacer les caractères
inconnus (80 à 9f) par des points d'interrogation (3f), ce qui explique
le second problème.

Questions supplémentaires : quelle est ta version de Thunderbird, as-tu
des extensions, et as-tu changé quelque chose par rapport à la config
par défaut concernant le choix du jeu de caractères ?

Cordialement,
--
Olivier Miakinen
alainL
Le #22379601
Le 20/07/2010 19:24, Olivier Miakinen a écrit :
Le 20/07/2010 18:02, alainL m'a répondu :

Je te propose la chose suivante pour ne pas avoir des manips trop
compliquées à faire.
1) Tu crées dans ton compte Thunderbird un nouveau dossier que tu nommes
Miakinen.txt (peu importe qu'il soit sous « Courrier entrant » ou
ailleurs).
2) Tu copies le message dans ce dossier (clic droit + Copier vers...).
3) Tu cherches sur ton disque dur le fichier Miakinen.txt (si tu sais
où est ton profil Thunderbird cela peut accélérer les choses, mais
ce n'est pas indispensable).
4) Tu le mets sur 5) Tu m'envoies l'URL cjoint à
[...]



Merci. J'ai obtenu un fichier.text que voici :
http://cjoint.com/?hur1y1XPpz



Visiblement c'est le message forwardé que tu as envoyé. Ce serait bien
que tu fasses la même chose avec le message d'origine (effacer puis
recréer Miakinen.txt afin de virer toute trace de la manip précédente).

Déjà, je peux te dire à quoi ressemble ce message. Il s'agit d'un
message en deux parties, texte et html, chacune des parties étant
*presque* bien encodée en UTF-8. Les 'é' sont bien encodés par 'c3 a9',
les 'ç' par 'c3 a7', les '«' par 'c2 ab', les '»' par 'c2 bb', et ainsi
de suite. Les seuls problèmes sont :
1) 'à' = 'c3 20' au lieu de 'c3 a0' ;
2) '’' = 'e2 3f 3f' au lieu de 'e2 80 99'.
Je parierais que les '€' deviendraient 'e2 3f ac' au lieu de 'e2 82 ac'.

C'est clairement un bug, et l'explication qui me semble la plus
naturelle est que ton Thunderbird a traité ce message comme s'il était
en ISO-8859-quelquechose au lieu d'UTF-8. En effet, dans ce mode il
remplace les espaces insécables (a0) par des sécables (20), ce qui
explique le premier problème, et il doit remplacer les caractères
inconnus (80 à 9f) par des points d'interrogation (3f), ce qui explique
le second problème.

Questions supplémentaires : quelle est ta version de Thunderbird, as-tu
des extensions, et as-tu changé quelque chose par rapport à la config
par défaut concernant le choix du jeu de caractères ?

Cordialement,



Ma version TB : 3.0.5. Je n'ai pas changé le jeu de caractères et pas
chargé d'extension. J'ai dû, suite à un plantage après mise à jour,
faire deux ou trois repêchages de dossiers, mais je n'ai pas modifié la
configuration et les transferts marchaient toujours.
Le message que j'ai reçu avait déjà été transféré plusieurs fois.
Je viens de "copier (le fichier reçu) vers" miakinen2...Là, il apparaît
en caractères normaux... mais copié-collé dans le bloc-notes, il affiche
avec un autre encodage. Le voici, un peu raccourci quand même !

http://cjoint.com/?huwnt5fqz6

Cordialement

--
AlainL
MELMOTH
Le #22380931
Ce cher mammifère du nom de alainL nous susurrait, le mardi 20/07/2010,
dans nos oreilles grandes ouvertes mais un peu sales tout de même, et
dans le message suivants :

Ma version TB : 3.0.5.



On en est à la version *3.0.6* !...

--
Car avec beaucoup de science, il y a beaucoup de chagrin ; et celui qui
accroît sa science accroît sa douleur.
[Ecclésiaste, 1-18]
MELMOTH - souffrant
alainL
Le #22381751
Le 21/07/2010 13:03, MELMOTH a écrit :
Ce cher mammifère du nom de alainL nous susurrait, le mardi 20/07/2010,
dans nos oreilles grandes ouvertes mais un peu sales tout de même, et
dans le message suivants :

Ma version TB : 3.0.5.



On en est à la version *3.0.6* !...





Dois-je comprendre que le problème évoqué vient de là ?

Ensuite, je digère doucement mes difficultés lors du passage à la 3.0.5
...!


--
AlainL
Sergio
Le #22381881
Le 21/07/2010 13:03, MELMOTH a écrit :
Ce cher mammifère du nom de alainL nous susurrait, le mardi 20/07/2010,
dans nos oreilles grandes ouvertes mais un peu sales tout de même, et
dans le message suivants :

Ma version TB : 3.0.5.



On en est à la version *3.0.6* !...



3.1 tant qu'à faire... (je suis en 3.0.5...)

--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
alainL
Le #22382761
Le 21/07/2010 13:03, MELMOTH a écrit :
Ce cher mammifère du nom de alainL nous susurrait, le mardi 20/07/2010,
dans nos oreilles grandes ouvertes mais un peu sales tout de même, et
dans le message suivants :

Ma version TB : 3.0.5.



On en est à la version *3.0.6* !...



Rectification: mon TB a dû interpréter le post de Melmoth : il vient de
faire sa mise à jour, tout seul ! Je suis en 3.6...
Qui sait si, grâce à Sergio, je ne vais pas me retrouver en 3.1 demain
matin ???

--
AlainL

http://autourdalos.fr
Erwan David
Le #22382951
Sergio
Le 21/07/2010 13:03, MELMOTH a écrit :
Ce cher mammifère du nom de alainL nous susurrait, le mardi 20/07/2010,
dans nos oreilles grandes ouvertes mais un peu sales tout de même, et
dans le message suivants :

Ma version TB : 3.0.5.



On en est à la version *3.0.6* !...



3.1 tant qu'à faire... (je suis en 3.0.5...)



ET même 3.1.1

--
Le travail n'est pas une bonne chose. Si ça l'était,
les riches l'auraient accaparé
Olivier Miakinen
Le #22384281
Le 20/07/2010 22:25, alainL a écrit :

[...] J'ai obtenu un fichier.text que voici :
http://cjoint.com/?hur1y1XPpz



[...] Les 'é' sont bien encodés par 'c3 a9',
les 'ç' par 'c3 a7', les '«' par 'c2 ab', les '»' par 'c2 bb', et ainsi
de suite. Les seuls problèmes sont :
1) 'à' = 'c3 20' au lieu de 'c3 a0' ;
2) '’' = 'e2 3f 3f' au lieu de 'e2 80 99'.

C'est clairement un bug, et l'explication qui me semble la plus
naturelle est que ton Thunderbird a traité ce message comme s'il était
en ISO-8859-quelquechose au lieu d'UTF-8. En effet, dans ce mode il
remplace les espaces insécables (a0) par des sécables (20), ce qui
explique le premier problème, et il doit remplacer les caractères
inconnus (80 à 9f) par des points d'interrogation (3f), ce qui explique
le second problème.

[...]



Ma version TB : 3.0.5. Je n'ai pas changé le jeu de caractères et pas
chargé d'extension. J'ai dû, suite à un plantage après mise à jour,
faire deux ou trois repêchages de dossiers, mais je n'ai pas modifié la
configuration et les transferts marchaient toujours.



Ok.

Le message que j'ai reçu avait déjà été transféré plusieurs fois.
Je viens de "copier (le fichier reçu) vers" miakinen2...Là, il apparaît
en caractères normaux... mais copié-collé dans le bloc-notes, il affiche
avec un autre encodage. Le voici, un peu raccourci quand même !

http://cjoint.com/?huwnt5fqz6



Ce message est avec le charset UTF-8 mais encodé en quoted-printable.
L'encodage me semble parfait, y compris les à (à) ainsi que les
apostrophes (’). Le comportement de ton Thunderbird est donc
vraiment un bug, et je ne sais pas que te dire pour tenter de le
contourner (si j'étais suffisamment doué en anglais je pourrais au moins
chercher dans les rapports de bugs, mais hélas ce n'est pas le cas).

À tout hasard, essaye quand même de créer un profil vierge pour voir si
ça se reproduit toujours. Tu peux aussi essayer de jouer sur la config,
en testant d'autres comportements par défaut (choix du charset, choix
MIME ou pas MIME, etc.)

Désolé de ne pas pouvoir t'aider plus.

Cordialement,
--
Olivier Miakinen
Publicité
Poster une réponse
Anonyme