Une tiote question sur une histoire de liens symboliques.

Le
G-raison
Bonjour,

Bon, c'est pour un jeu faut pas trop perdre de temps non plus.
Mais là je suis encore coincé avec ces histoires de liens.

Voilà,
J'ai mis UT2004 dans mon répertoire.
J'ai téléchargé le patch que j'ai mis dans /usr/local/src.
Vu que c'est dit que c'est là qu'il fallait le mettre (ici :
http://charles.plessy.org/ut2k4.html)

Où faut-il que je mette le lien symbolique pour que le patch marche dans le
jeu? (pourtant je l'avais déjà fait?!)
J'en ai mis partout, ça n'a pas l'air d'être bon.

J'aurais bien aimé laisser le patch dans mon /home vu que la partition est
plus grosse mais bon.

Si je lance le fichier .bin j'ai cette erreur :
[root@localhost System]# ./ut2004-bin
./ut2004-bin: error while loading shared libraries: ./libSDL-1.2.so.0:
cannot open shared object file: No such file or directory

Pourtant c'est normalement ce fichier qui installe le patch.

Je pense que c'est une histoire de lien symbolique ou un truc avec mon path
mais comme j'ai toujours un vide là-dessus.

Bon, si quelqu'un à un peu de temps à perdre, ça m'arrangerai. ;-)

--
@+
gr
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Frederic Bezies
Le #1901201

Bonjour,

Bon, c'est pour un jeu faut pas trop perdre de temps non plus.
Mais là je suis encore coincé avec ces histoires de liens.

Voilà,
J'ai mis UT2004 dans mon répertoire.
J'ai téléchargé le patch que j'ai mis dans /usr/local/src.
Vu que c'est dit que c'est là qu'il fallait le mettre (ici :
http://charles.plessy.org/ut2k4.html)

Où faut-il que je mette le lien symbolique pour que le patch marche dans le
jeu? (pourtant je l'avais déjà fait?!...)
J'en ai mis partout, ça n'a pas l'air d'être bon.

J'aurais bien aimé laisser le patch dans mon /home vu que la partition est
plus grosse mais bon.

Si je lance le fichier .bin j'ai cette erreur :
[ System]# ./ut2004-bin
./ut2004-bin: error while loading shared libraries: ./libSDL-1.2.so.0:
cannot open shared object file: No such file or directory

Pourtant c'est normalement ce fichier qui installe le patch.

Je pense que c'est une histoire de lien symbolique ou un truc avec mon path
mais comme j'ai toujours un vide là-dessus.

Bon, si quelqu'un à un peu de temps à perdre, ça m'arrangerai. ;-)



C'est la libsdl qui manque. Installe la en fonction de ta distribution.

--
Frederic Bezies -
Weblog : http://frederic.bezies.free.fr/blog/

G-raison
Le #1901196
Frederic Bezies wrote:

C'est la libsdl qui manque. Installe la en fonction de ta distribution.


Je viens de voir que cette librairie se trouve dans le répertoire système du
jeu.
C'est simplement que le patch ne la trouve pas.

C'est pour ça que je pensais qu'il y avait un lien symbolique à mettre.
Mais je ne trouve pas où.

Bon, je retripote le truc.

--
@+
gr

G-raison
Le #1901072
Frederic Bezies wrote:

C'est la libsdl qui manque. Installe la en fonction de ta distribution.


Je reviens vite fait sur ta réponse.

J'ai refais l'installation d'ut2004.
Ca marche.

J'installe le patch ut2004.megapack-english-3.run.
L'installation se passe bien.
Je tape ut2004 pour lancer le jeu et vlan :
./ut2004-bin: error while loading shared libraries: libstdc++.so.5: cannot
open shared object file: No such file or directory

Pourtant j'ai libstdc++.so.6 et libsdl-1.2.so.0 dans /usr/lib/
Donc j'ai tout.

Pourquoi ça a l'air de ne pas trouver ces bibliothèque là?

--
@+
gr

Nicolas George
Le #1901071
G-raison wrote in message
./ut2004-bin: error while loading shared libraries: libstdc++.so.5: cannot
open shared object file: No such file or directory

Pourtant j'ai libstdc++.so.6 et libsdl-1.2.so.0 dans /usr/lib/
Donc j'ai tout.

Pourquoi ça a l'air de ne pas trouver ces bibliothèque là?


Parce que depuis la dernière mise à jour des mathématiques, 5 est différent
de 6.

G-raison
Le #1901070
Nicolas George wrote:

Parce que depuis la dernière mise à jour des mathématiques, 5 est
différent de 6.


Oui, ça j'arrive à le comprendre, je n'ai pas encore bu l'apéro. :-)

Ceci dit est-ce que je peux installer la version 5 alors que j'ai la 6
d'installer?
Ca va peut-être fiche un foin du diable là-dedans?

--
@+
gr

Nicolas George
Le #1901069
G-raison wrote in message
Ceci dit est-ce que je peux installer la version 5 alors que j'ai la 6
d'installer?


Oui.

G-raison
Le #1901068
Nicolas George wrote:

Oui.


Ah ben voilà, merci. ;-)

--
@+
gr

G-raison
Le #1901067
Nicolas George wrote:

Oui.


Bon, ça marche! :-)
Heureux je suis.

Je n'ai plus qu'à réinstaller ma web-cam. (rien à voir avec le jeu...)
(mais là j'ai retrouvé la discutions que l'on avait eu sur google il y a
déjà un bout de temps...)

--
@+
gr

Publicité
Poster une réponse
Anonyme