total de cellules en fonction d'autres cellules...

Le
Dominique Delos
Bonjour à tous !!!

Excel 2003
Sur mon tableau, la 1ère colonne comporte une liste de noms (parfois les
mêmes), et la 2ème des chiffres
Est-il possible d'obtenir l'addition des cellules de la 2ème colonne par
rapport au nombre de fois où le même nom apparait dans la 1ère ??
Ouille ouille ouille, pas très clair tout çaje prends un exemple :

Dupont 14
Dupont 10
Durand 8
Martin 9

L'idéal serait que je puisse avoir dans une 3ème colonne : Dupont 24
Merci d'avance de vos lumières ;-)
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Xavier powaga
Le #5165551
si dans la colonne A il y a les noms et en B les chiffres
met en C1 la formule suivante
tu peux ensuite copier la cellule vers celles d'en dessous (C2...Cn)

=SOMMEPROD((A:A¡)*1;B:B)
"Dominique Delos" <Non précisée> a écrit dans le message de news:

Bonjour à tous !!!

Excel 2003
Sur mon tableau, la 1ère colonne comporte une liste de noms (parfois les
mêmes), et la 2ème des chiffres...
Est-il possible d'obtenir l'addition des cellules de la 2ème colonne par
rapport au nombre de fois où le même nom apparait dans la 1ère ??
Ouille ouille ouille, pas très clair tout ça...je prends un exemple :

Dupont 14
Dupont 10
Durand 8
Martin 9

L'idéal serait que je puisse avoir dans une 3ème colonne : Dupont 24
Merci d'avance de vos lumières... ;-)



AV
Le #5165501
Sur mon tableau, la 1ère colonne comporte une liste de noms (parfois les
mêmes), et la 2ème des chiffres...
Est-il possible d'obtenir l'addition des cellules de la 2ème colonne par


Connais-tu les Tableaux Croisés Dynamiques ?
Si non... faut vite mettre le nez..

AV

Dominique Delos
Le #5165371
Merci de vos 2 solutions, j'essaie ça dès que possible ! et reviens dire
"AV"
Sur mon tableau, la 1ère colonne comporte une liste de noms (parfois les
mêmes), et la 2ème des chiffres...
Est-il possible d'obtenir l'addition des cellules de la 2ème colonne par


Connais-tu les Tableaux Croisés Dynamiques ?
Si non... faut vite mettre le nez..

AV




Dominique Delos
Le #5163861
Bon ben ça marche pas :-(

J'ai une erreur #NOMBRE!

Une idée ??

"Xavier powaga" 47b6b5f3$0$17395$
si dans la colonne A il y a les noms et en B les chiffres
met en C1 la formule suivante
tu peux ensuite copier la cellule vers celles d'en dessous (C2...Cn)

=SOMMEPROD((A:A¡)*1;B:B)
"Dominique Delos" <Non précisée> a écrit dans le message de news:

Bonjour à tous !!!

Excel 2003
Sur mon tableau, la 1ère colonne comporte une liste de noms (parfois les
mêmes), et la 2ème des chiffres...
Est-il possible d'obtenir l'addition des cellules de la 2ème colonne par
rapport au nombre de fois où le même nom apparait dans la 1ère ??
Ouille ouille ouille, pas très clair tout ça...je prends un exemple :

Dupont 14
Dupont 10
Durand 8
Martin 9

L'idéal serait que je puisse avoir dans une 3ème colonne : Dupont 24
Merci d'avance de vos lumières... ;-)







Dominique Delos
Le #5163851
Effectivement le TCD donne de bons résultats...et même ceux que j'attendais
;-))
J'adopte - merci

"AV"
Sur mon tableau, la 1ère colonne comporte une liste de noms (parfois les
mêmes), et la 2ème des chiffres...
Est-il possible d'obtenir l'addition des cellules de la 2ème colonne par


Connais-tu les Tableaux Croisés Dynamiques ?
Si non... faut vite mettre le nez..

AV




Xavier powaga
Le #5163801
effectivement
=SOMMEPROD((A1:A65000¡)*1;B1:B65000)
comme ça y a pas d'erreur

"Dominique Delos"
dans le message de news:
Bon ben ça marche pas :-(

J'ai une erreur #NOMBRE!

Une idée ??

"Xavier powaga" 47b6b5f3$0$17395$
si dans la colonne A il y a les noms et en B les chiffres
met en C1 la formule suivante
tu peux ensuite copier la cellule vers celles d'en dessous (C2...Cn)

=SOMMEPROD((A:A¡)*1;B:B)
"Dominique Delos" <Non précisée> a écrit dans le message de news:

Bonjour à tous !!!

Excel 2003
Sur mon tableau, la 1ère colonne comporte une liste de noms (parfois les
mêmes), et la 2ème des chiffres...
Est-il possible d'obtenir l'addition des cellules de la 2ème colonne par
rapport au nombre de fois où le même nom apparait dans la 1ère ??
Ouille ouille ouille, pas très clair tout ça...je prends un exemple :

Dupont 14
Dupont 10
Durand 8
Martin 9

L'idéal serait que je puisse avoir dans une 3ème colonne : Dupont 24
Merci d'avance de vos lumières... ;-)











Dominique Delos
Le #5163721
Nettement mieux...merci ;-))

"Xavier powaga" 47b71828$0$24287$
effectivement
=SOMMEPROD((A1:A65000¡)*1;B1:B65000)
comme ça y a pas d'erreur

"Dominique Delos"
écrit dans le message de news:
Bon ben ça marche pas :-(

J'ai une erreur #NOMBRE!

Une idée ??

"Xavier powaga" 47b6b5f3$0$17395$
si dans la colonne A il y a les noms et en B les chiffres
met en C1 la formule suivante
tu peux ensuite copier la cellule vers celles d'en dessous (C2...Cn)

=SOMMEPROD((A:A¡)*1;B:B)
"Dominique Delos" <Non précisée> a écrit dans le message de news:

Bonjour à tous !!!

Excel 2003
Sur mon tableau, la 1ère colonne comporte une liste de noms (parfois
les mêmes), et la 2ème des chiffres...
Est-il possible d'obtenir l'addition des cellules de la 2ème colonne
par rapport au nombre de fois où le même nom apparait dans la 1ère ??
Ouille ouille ouille, pas très clair tout ça...je prends un exemple :

Dupont 14
Dupont 10
Durand 8
Martin 9

L'idéal serait que je puisse avoir dans une 3ème colonne : Dupont 24
Merci d'avance de vos lumières... ;-)















Publicité
Poster une réponse
Anonyme