des touches qui ne passent plus dans tty1 (dont "entrée")

Le
Aurelien
Salut,

J'ai un problème bizarre.
Depuis quelques jours (semaines), je n'arrive plus à me logguer dans
tty1. A chaque fois je fais une erreur à la saisie de mon mot de passe.
J'ai essayé de le taper comme nom d'utilisateur, pour voir, et je me
suis rendu compte que certaines lettres ne passaient pas. Et parfois,
aussi, la touche "entrée" n'était pas interprétée. Comme ça ne sont pas
toujours les mêmes lettres qui ne sont pas saisies, j'ai pensé à un
problème de clavier, mais dans tous les autres tty et en X, ça marche
parfaitement, sans aucun souci.
Je ne sais pas s'il y a ce genre de choses dans la conception d'un
terminal, mais ça me fait un peu penser à un timer qui serait trop lent
et qui ne saisirait pas tout.

Ca n'est pas ultra-gênant, mais bon, ça serait idiot de ne pas savoir
d'où ça vient. Si quelqu'un a une idée.

A plus tard.
Aurélien

--
Aurélien

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
bernard.schoenacker
Le #20161271
Selon Aurelien
Salut,

J'ai un problème bizarre.
Depuis quelques jours (semaines), je n'arrive plus à me logguer dans
tty1. A chaque fois je fais une erreur à la saisie de mon mot de passe.
J'ai essayé de le taper comme nom d'utilisateur, pour voir, et je me
suis rendu compte que certaines lettres ne passaient pas. Et parfois,
aussi, la touche "entrée" n'était pas interprétée. Comme ça ne sont pas
toujours les mêmes lettres qui ne sont pas saisies, j'ai pensé à un
problème de clavier, mais dans tous les autres tty et en X, ça marche
parfaitement, sans aucun souci.
Je ne sais pas s'il y a ce genre de choses dans la conception d'un
terminal, mais ça me fait un peu penser à un timer qui serait trop lent
et qui ne saisirait pas tout.

Ca n'est pas ultra-gênant, mais bon, ça serait idiot de ne pas savoir
d'où ça vient. Si quelqu'un a une idée.

A plus tard.
Aurélien

--
Aurélien




bonjour,

ne serait ce pas un gremlins qui serait passé par là ?

un peut plus de détail concernant la liste des paquets
installés et ayant trait au clavier ferait grandement
avancer les choses .....

for pkg in kbd console ;do dpkg -l |grep $pkg ;done

ainsi rendre compte à la liste de l'état des paquets et
de reconfigurer console-data avec les valeurs convenables ....

slt
bernard

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Aurelien
Le #20161251
On Wed, Sep 16, 2009 at 06:26:54PM +0200, Aurelien wrote :
Salut,

J'ai un problème bizarre.
Depuis quelques jours (semaines), je n'arrive plus à me logguer dans
tty1. A chaque fois je fais une erreur à la saisie de mon mot de passe.
J'ai essayé de le taper comme nom d'utilisateur, pour voir, et je me
suis rendu compte que certaines lettres ne passaient pas. Et parfois,
aussi, la touche "entrée" n'était pas interprétée. Comme ça ne sont pas
toujours les mêmes lettres qui ne sont pas saisies, j'ai pensé à un
problème de clavier, mais dans tous les autres tty et en X, ça marche
parfaitement, sans aucun souci.
Je ne sais pas s'il y a ce genre de choses dans la conception d'un
terminal, mais ça me fait un peu penser à un timer qui serait trop lent
et qui ne saisirait pas tout.

Ca n'est pas ultra-gênant, mais bon, ça serait idiot de ne pas savoir
d'où ça vient. Si quelqu'un a une idée.

A plus tard.
Aurélien




J'ai oublié de préciser que je suis en SID (à jour), distribution 64 bits.



--
Aurélien

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Aurelien
Le #20161681
On Wed, Sep 16, 2009 at 09:08:08PM +0200, wrote :
Selon Aurelien
> Salut,
>
> J'ai un problème bizarre.
> Depuis quelques jours (semaines), je n'arrive plus à me logguer dans
> tty1. A chaque fois je fais une erreur à la saisie de mon mot de passe.
> J'ai essayé de le taper comme nom d'utilisateur, pour voir, et je me
> suis rendu compte que certaines lettres ne passaient pas. Et parfois,
> aussi, la touche "entrée" n'était pas interprétée. Comme ça ne sont pas
> toujours les mêmes lettres qui ne sont pas saisies, j'ai pensé à un
> problème de clavier, mais dans tous les autres tty et en X, ça marche
> parfaitement, sans aucun souci.
> Je ne sais pas s'il y a ce genre de choses dans la conception d'un
> terminal, mais ça me fait un peu penser à un timer qui serait trop lent
> et qui ne saisirait pas tout.
>
> Ca n'est pas ultra-gênant, mais bon, ça serait idiot de ne pas savoir
> d'où ça vient. Si quelqu'un a une idée.
>
> A plus tard.
> Aurélien
>
> --
> Aurélien


bonjour,

ne serait ce pas un gremlins qui serait passé par là ?



Possible, mais dans ce cas, il est d'une évanescence particulière,
puisque seul(e) tty1 est concerné (et pas les autres tty, notamment
celui-ci depuis lequel je vous écris).


un peut plus de détail concernant la liste des paquets
installés et ayant trait au clavier ferait grandement
avancer les choses .....

for pkg in kbd console ;do dpkg -l |grep $pkg ;done



Les voici ci-dessous, mais je permets de douter que les paquets de
configuration du clavier et des consoles soient défectueux s'ils
fonctionnent sur toutes les autres tty. A la rigueur, il est possible
que le fichier de configuration de console-tools soit en cause, dans la
mesure où il fait le distingo entre les vcs (ah, par contre, c'est vrai,
j'ai oublié de vous préciser que j'utilisais le framebuffer, avec une
résolution 1280x1024 en console).

ii console-common
ii console-data
ii console-setup
ii console-terminus
ii console-tools
ii consolekit
ii libconsole
ii libxine1-console


Pour kbd, c'est du X, exclusivement, si je ne m'abuse
ii libgnomekbd-common
rc libgnomekbd1
ii libgnomekbd3
rc libgnomekbdui1
ii xserver-xorg-input-kbd


ainsi rendre compte à la liste de l'état des paquets et
de reconfigurer console-data avec les valeurs convenables ...



Pour info, dans /etc/console-tools/config, les lignes sur KEYBOARD_RATE
et KEYBOARD_DELAY sont commentées (comme dans le fichier .dpkg-dist).
Je précise que je n'ai pas utilisé kbdrate (que j'ai découvert en
regardant le fichier de config susnommé), et que je serai de toute façon
dans l'incapacité de le faire dans tty1, puisque je n'arrive pas à me
logguer puisque toutes les lettres ne passent pas (attention, je ne veux
pas dire que certains caractères spéciaux ne passent pas, c'est
certaines lettres, au hasard, pas toujours les mêmes, et parfois même
la touche "entrée", d'où le fait que j'ai pensé à un problème de timer,
même je ne sais pas si ce genre d'outil est utilisé dans la gestion des
consoles - on en utilise en gestion des événements MIDI, par exemple).


--
Aurélien

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Guy Roussin
Le #20162291
Ce serait pas un probleme de "touches lentes" ?
Sous gnome, voir Systeme/Preferences/Clavier/Onglet Accessibilité
Il faut tout décocher ...

Guy

Aurelien a écrit :
Salut,

J'ai un problème bizarre.
Depuis quelques jours (semaines), je n'arrive plus à me logguer dans
tty1. A chaque fois je fais une erreur à la saisie de mon mot de pass e.
J'ai essayé de le taper comme nom d'utilisateur, pour voir, et je me
suis rendu compte que certaines lettres ne passaient pas. Et parfois,
aussi, la touche "entrée" n'était pas interprétée. Comme ça n e sont pas
toujours les mêmes lettres qui ne sont pas saisies, j'ai pensé à un
problème de clavier, mais dans tous les autres tty et en X, ça marc he
parfaitement, sans aucun souci.
Je ne sais pas s'il y a ce genre de choses dans la conception d'un
terminal, mais ça me fait un peu penser à un timer qui serait trop lent
et qui ne saisirait pas tout.

Ca n'est pas ultra-gênant, mais bon, ça serait idiot de ne pas savo ir
d'où ça vient. Si quelqu'un a une idée.

A plus tard.
Aurélien





--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Jean-Michel OLTRA
Le #20162831
Bonjour,


Le mercredi 16 septembre 2009, Aurelien a écrit...


Je ne sais pas s'il y a ce genre de choses dans la conception d'un
terminal, mais ça me fait un peu penser à un timer qui serait trop lent
et qui ne saisirait pas tout.



Tu pourrais essayer, avec `stty`, de voir si il y a des différences
entre les terminaux, ceux qui fonctionnent correctement, et l'autre.

--
jm

A.E.L. Sarl (R.C.S CASTRES 490843240)
http://www.spidboutic.fr



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
bernard.schoenacker
Le #20163281
Selon Aurelien
On Wed, Sep 16, 2009 at 09:08:08PM +0200, wrote :
> Selon Aurelien >
> > Salut,
> >
> > J'ai un problème bizarre.
> > Depuis quelques jours (semaines), je n'arrive plus à me logguer dans
> > tty1. A chaque fois je fais une erreur à la saisie de mon mot de passe.
> > J'ai essayé de le taper comme nom d'utilisateur, pour voir, et je me
> > suis rendu compte que certaines lettres ne passaient pas. Et parfois,
> > aussi, la touche "entrée" n'était pas interprétée. Comme ça ne sont pas
> > toujours les mêmes lettres qui ne sont pas saisies, j'ai pensé à un
> > problème de clavier, mais dans tous les autres tty et en X, ça marche
> > parfaitement, sans aucun souci.
> > Je ne sais pas s'il y a ce genre de choses dans la conception d'un
> > terminal, mais ça me fait un peu penser à un timer qui serait trop lent
> > et qui ne saisirait pas tout.
> >
> > Ca n'est pas ultra-gênant, mais bon, ça serait idiot de ne pas savoir
> > d'où ça vient. Si quelqu'un a une idée.
> >
> > A plus tard.
> > Aurélien
> >
> > --
> > Aurélien
>
>
> bonjour,
>
> ne serait ce pas un gremlins qui serait passé par là ?

Possible, mais dans ce cas, il est d'une évanescence particulière,
puisque seul(e) tty1 est concerné (et pas les autres tty, notamment
celui-ci depuis lequel je vous écris).

>
> un peut plus de détail concernant la liste des paquets
> installés et ayant trait au clavier ferait grandement
> avancer les choses .....
>
> for pkg in kbd console ;do dpkg -l |grep $pkg ;done

Les voici ci-dessous, mais je permets de douter que les paquets de
configuration du clavier et des consoles soient défectueux s'ils
fonctionnent sur toutes les autres tty. A la rigueur, il est possible
que le fichier de configuration de console-tools soit en cause, dans la
mesure où il fait le distingo entre les vcs (ah, par contre, c'est vrai,
j'ai oublié de vous préciser que j'utilisais le framebuffer, avec une
résolution 1280x1024 en console).

ii console-common
ii console-data
ii console-setup
ii console-terminus
ii console-tools
ii consolekit
ii libconsole
ii libxine1-console


Pour kbd, c'est du X, exclusivement, si je ne m'abuse
ii libgnomekbd-common
rc libgnomekbd1
ii libgnomekbd3
rc libgnomekbdui1
ii xserver-xorg-input-kbd

>
> ainsi rendre compte à la liste de l'état des paquets et
> de reconfigurer console-data avec les valeurs convenables ...

Pour info, dans /etc/console-tools/config, les lignes sur KEYBOARD_RATE
et KEYBOARD_DELAY sont commentées (comme dans le fichier .dpkg-dist).
Je précise que je n'ai pas utilisé kbdrate (que j'ai découvert en
regardant le fichier de config susnommé), et que je serai de toute façon
dans l'incapacité de le faire dans tty1, puisque je n'arrive pas à me
logguer puisque toutes les lettres ne passent pas (attention, je ne veux
pas dire que certains caractères spéciaux ne passent pas, c'est
certaines lettres, au hasard, pas toujours les mêmes, et parfois même
la touche "entrée", d'où le fait que j'ai pensé à un problème de timer,
même je ne sais pas si ce genre d'outil est utilisé dans la gestion des
consoles - on en utilise en gestion des événements MIDI, par exemple).


--
Aurélien



bonjour,

il reste un paquet qui n'y figure point dans la liste : kbd-compat

Description:
Wrappers around console-tools for backward compatibility with `kbd'
This package provides the following wrapper scripts, for compatibility with
old `kbd' package, for programs which depends on the former's command-line
interfaces :
setfont, loadunimap, saveunimap, mapscrn, setlogcons.

donc, je pense que cet utilitaire pourra résoudre vos soucis ....



slt
bernard

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme