Tournee_gui.py ne fonctionne plus

Le
martel
Bonsoir,
J'utilise pour mon travail à titre personnel une petite application
écrit en python, dont l'auteur ne donne plus de nouvelle depuis un
certain temps.
Cette application ne fonctionne plus depuis que je suis sous "jessie" et
elle fonctionne encore sur un ordinateur que j'ai à la maison sous "wheezy".
L'installation et dépendance, sont OK.

python-tournee_0.6.2_all.deb

Au lancement de l'application j'ai le message suivant:
martel@debian:~$ tournee_gui.py
Traceback (most recent call last):
File "/usr/local/bin/tournee_gui.py", line 23, in <module>
from tournee import trn_gen, gui
File "/usr/local/lib/python2.7/dist-packages/tournee/trn_gen.py", line
76, in <module>
class Tournee:
File "/usr/local/lib/python2.7/dist-packages/tournee/trn_gen.py", line
77, in Tournee
listeclasse = find_classe(trn, (TrnModule,TrnModuleXml))
File "/usr/local/lib/python2.7/dist-packages/tournee/my_import.py",
line 57, in find_classe
new_mod = __import__(new_name, globals(), locals(), [""] )
File
"/usr/local/lib/python2.7/dist-packages/tournee/trn/trnClientPdf.py",
line 33, in <module>
from tournee.util_pdf import FrameDocTemplate, pdf_encode
File "/usr/local/lib/python2.7/dist-packages/tournee/util_pdf.py",
line 27, in <module>
if float(reportlab.Version) < 2:
ValueError: invalid literal for float(): 3.1.31

Je pense que le souci vient de reportlab qui est dans une version
supérieur ?
Comment corriger le problème ?
Merci par avance pour toutes idées ou solution.

Cordialement.

Christophe Martel.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: https://lists.debian.org/54BA780C.9000103@laposte.net
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Lorenzo Bernardi
Le #26334482
Bonsoir,

je ne connais pas ce logiciel donc je peux pas vraiment donner de
coup de main la dessus mais.
On 01/17/15 15:56, martel wrote:
line 27, in <module>
if float(reportlab.Version) < 2:
ValueError: invalid literal for float(): 3.1.31

Je pense que le souci vient de reportlab qui est dans une version
supérieur ?


en fait le probleme vient du fait que 3.1.31 ne peut pas etre converti
en float.

Comment corriger le problème ?


Mais ca on peut le changer part
reporlab.Version.split('.')[0] (ca decoupe la chaine au niveau des
points et la transforme en liste dont on prend le premier element ici 3.

Reste a savoir ce que dit le test apres. Est ce que reportlab doit etre
inferieur a une version 2 pour que le code marche? Si oui ca risque
d'etre difficile. Si il faut que la version de reportlab soit superieur
a deux alors ca peut peut etre passer.

Sinon apres il faut peut etre cree un environement virtuel avec
virtualenv et la on peut installer une version 2.3 de reportlab. Mais
c'est un peu complique.

cordialement

L.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Publicité
Poster une réponse
Anonyme